Updating QuickGPS

Tei Registered Users Posts: 45
Outstanding Wayfarer
edited January 24 in TomTom Sports
I wanted to continue the old thread but could not find it anymore. Some months ago there was discussion about whether updating QuickGPS depended on the weekday: some people had found out that updating on Sundays was problematic. Since then I've had problems on any day of the week. Especially in several occasions when I've run and synced my watch after the run and found QuickGPS up to date, the very next morning it has been out of date. This has happened several times in the last few weeks. As I've understood, QuickGPS needs updating every three days or so, but it seem that QuickGPS does not get updated every time I sync my watch. For example, I run every single day of the week, and after each run I sync my watch and upload the activity to MySport, and still sometimes I can find the next day that QuickGPS is not up to date. Can someone explain how it works?


  • tfarabaugh
    tfarabaugh Posts: 16,992
    The file lasts for three days so that is the minimum sync interval you need to have the latest file (it will work without it, it will just take longer to acquire satellites). There as an issue with the GPS file for some watches. You should be able to fix it for your watch by following these steps (make sure you have installed the latest version of Connect if prompted):

    1) You have to connect to MySports Connect, then press CTRL (Windows) or CMD (MAC) on your keyboard whilst you hover your mouse over the reset button.
    2) You'll see the reset button turns into a "Turn Off" button.
    3) Hit that, disconnect the watch and the screen will go dead.
    4) Reconnect the watch and it will wake up and quick fix should now update as usual.

    I hope this helped answer your question. If so, please mark it as a solution so others can look for it if they have the same question.
  • Tei
    Tei Registered Users Posts: 45
    Outstanding Wayfarer
    I followed these steps after my morning run today (before which I synced my watch to update the QuickGPS). So, it was up to date before I started. When I disconnected my watch from my computer (after it had stopped charging), QuickGPS was out-of-date again!
  • Krzyzu011
    Krzyzu011 Registered Users Posts: 12
    Outstanding Explorer
    Does QuickGPS can be update only by computer? Or is there a way to update it via App Bluetooth connection?
  • Tei
    Tei Registered Users Posts: 45
    Outstanding Wayfarer
    I normally use the MySport mobile app in my Android phone to update QuickGPS and upload the activity from my watch.
  • mnbvcxz
    mnbvcxz Registered Users Posts: 56
    Prominent Wayfarer
    I've had the same problem for quite some time -- whether I synch my watch via computer or iphone. Perhaps the answer is a "Factory Reset," but I'm too stubborn to do that.
  • elkine
    elkine Registered Users Posts: 1
    Apprentice Traveler
    Just sharing my case.
    The QuickGPS update worked fine for me until one week ago, then it stopped working.
    I tried to update from MySports Connect and from the mobile app (both of which worked before), and even did a Factory Reset, to no avail.

    Today I saw this thread and tried the Power-off Reset (didn't know that existed). The update went through at last, glad to get the GPS signal quickly again :)
    So thanks for the tip tfarabaugh about the Power-off reset, at least it works for some people !
  • SatishG
    SatishG Registered Users Posts: 9
    Apprentice Traveler
    I have a Spark3 with Music . I'm facing problems updating the QuickGPS using the Android App. Whenever I pair my watch with the mobile, after syncing the activities, the status under the progress bar shows ' updating quickGPS' but it suddenly stops processing when the progress bar reaches around 75% . Is there a solution for this ?
  • boubourunner
    boubourunner Registered Users Posts: 13
    Master Traveler
    Hey @SatishG,

    I had the exact same issue.
    I solved this issue by using an alternative App in order to update QuickGPS over bluetooth from my android phone. (MySport App has never been able to update QuickGPS from my mobile phone, I'm sure that TomTom can(will) fix it)

    You can find all informations on this post: sync issue workaround
    ( https://en.discussions.tomtom.com/sports-connect-apps-website-389/alternative-mobile-application-clue-for-synchronisation-issue-1033595 )

    Here is my current workflow on android:
    • before an activity I update QuickGPS with ttdroid App
    • after an activity I can use TomTom MySport App for activity Upload
    (ttdroid can also upload activity on your mobile phone If you want)
  • SatishG
    SatishG Registered Users Posts: 9
    Apprentice Traveler
    Hey @boubourunner ,

    Thanks for the reply. You really took the problem in hand and solved it yourself. I read the story of ttdroid and understood root cause of the problem. Really great !

    However, I would like to stick with the official TomTom app.

    Thanks anyways.
  • lampard
    lampard Retired TomTom Employee Posts: 6,075 Retired Community Moderators and Admins
    Hi SatishG,

    Welcome to the Community!

    If you're not able to update the QuickGPSfix on your watch, you can perform the Power-Off reset on your watch to fix it. Also, I've put you on the software version 1.7.64, the software will be offered once you complete the reset.

    Please give it a test run and let us know the outcome after the reset and firmware update.

    Cheers, lampard
  • boubourunner
    boubourunner Registered Users Posts: 13
    Master Traveler

    What describes SatishG is what I can reproduce with my phone (that is not in the compatibility list).

    It was the same with 1.7.62 => 1.7.60 => 1.7.64 , before after reset ... (pairing OK, sync start, upload activities OK, but failure while dowloading QuickGPS to the watch. the same for all big file downlaod to the watch indeed).

    After a lot of investigations I can tell you that the issue can be fixed from the android mobile application. (As it's not possible to change android stack on all mobiles phones )

    @lampard, I you can, show this to App development team (If you have contacts): https://en.discussions.tomtom.com/spark-and-spark-3-runner-2-and-runner-3-473/bluetooth-synchonisation-issue-firmware-versus-mobile-app-workaround-1033599

    The post contains link to pdf with the explaination of how the mobile App fails. It's should not be that complicated to fix it: In short: The mobile App must be sure that previous bluetooth write is over before writing again. From android API you know that you can do the next "writeToCharacteristic" when you receive the callback "onCharacteristicWrite" from previous "writeToCharacteristic". If you do that you will never have the error "java.lang.Exception: Attempting to send a message before the current message is complete.WriteCharacteristicMessage" that happens while using TomTom MySport App.

    I can speak like this because I tried it by myself and wrote my own android application to download QuickGPS to the watch. And it works (same watch, same firmware, no reset, same mobile).

    I understand that you expect a fix from TomTom. For me, this fix will come from the mobile Application. (another way is to change our mobile phone ...... )
  • boubourunner
    boubourunner Registered Users Posts: 13
    Master Traveler
    forgot to tell, of course you should try what @lampard suggested even if it didn't work for me. We never knows if issues are exactly the same ... (But If I had to bet you know how ;) )
  • SatishG
    SatishG Registered Users Posts: 9
    Apprentice Traveler

    Thanks for the instructions. I have done the power-off and updated firmware as well as QuickGPS.
    Let us see whether QuckGPS update works when next time I pair the phone.


    Thanks for your help.
  • SatishG
    SatishG Registered Users Posts: 9
    Apprentice Traveler
    @lampard ,

    I am back with the update and it is not very encouraging.

    Since a couple of days, my watch is showing that the QuickGPS needs update. I am again facing the same problem . It is not getting updated over android app. Is there any other workaround ?

    As suggested by @boubourunner , this issue needs to be fixed in the app.
    Hope the Tomtom app development team can look into this.

  • martineV
    martineV Registered Users Posts: 4
    Apprentice Traveler

    I'm having the same problem with the Apple app, already several times.

    A reset works indeed, but it's a pity that I need to perform such a reset every 2 to 3 weeks :(