App cannot start. Check your internet connect

Sasapigac Registered Users Posts: 2
Apprentice Traveler
Hi, after updated to this version, 1.16, I lost subscription info. Couldn't restore it because app says there is no internet connection, while there is actually. Uninstalled app, installed it again, but now stuck at opening screen saying App can not connect to Tomtom. Did Clear data but didn't help. Please help but don't advise to make some activities on my device because it is perfectly working and all other apps are OK. I'd rather suggest you to recheck on your side and publish amended Android app. Thx.


  • Mad Monte
    Mad Monte Registered Users Posts: 1
    Apprentice Traveler
    I have the same issue as Sasapigac, I try to login and it says I have no internet connection when I am on WiFi or Oops something went wrong. FIX this ASAP.
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Welcome to the Community!

    Please, follow the steps below to sort this out:
    • Uninstall the app
    • Clear cache data for the following apps (note, going to Settings > Applications / Manage Applications, might not show them. Via the 'More link in the top right corner, enable 'Show System Apps')
      - Google Play Services
      - Google Play Store
      - Google Services Framework.
    • Set the time to "automatic"
    • Restart the phone (this is important)
    • After the phone restarts check and make sure their internet browser has access to the internet with Wi-Fi® and/or 3G/4G
    • Download a fresh copy of the app from the Google Play store and install

    Please, post back here to tell us how your doing with this so that we can help you further, if needed :D

    Cheers, Mikko
  • Sasapigac
    Sasapigac Registered Users Posts: 2
    Apprentice Traveler
    Hi Mikko,
    Many thanks for this comprehensive instructions. That's helped and the App now works as it should.

    Dear all, please follow strictly above instructions to solve this problem - it works !

    Many thanks!

    Best regards,

  • Vascoa
    Vascoa Registered Users Posts: 2
    Apprentice Traveler
    I've tried this solution and it didn't work.

    I was thinking about purchasing the app, but it will only connect by Wifi.
    With data, all other apps are working except tomtom go.

    I'm using an old phone Samsung Galaxy note 2, with jelly bean 4.1.2

    I've read there is a recently upgraded tomtom version, is it not compatible with jelly bean?

    I'll try this solution once more, but does anyone have another solution?
  • axeleration
    axeleration Registered Users Posts: 1
    Apprentice Traveler
    For me the re-install did only work for a day or so...
    The following workaround has worked for me several times (v1.161 (2077) on android 5.0.1) :
    - in Go app log off: this will likely cause the wheel of death (guess it can't find internet connection and freaks out)
    - as the app is unresponsive, kill it from outside, i use the "Active apps" widget for that
    - restart the phone, yes annoying, takes long...
    - restart TT GO, log in, tadaa

    Again, this is a workaround and not a fix. In my opinion this is a bug that has come with one of the last two updates...
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    There seems to be two different issues discussed here at the moment. The original issue reported here is one where you'd get a Check you internet connection error upon startup using any internet connection. This issue can often be solved by the steps I've provided above.

    Unfortunately, some customers are also experiencing another similar issue where the above error message is shown when using a mobile data (3G/4G) connection but not when using a Wi-Fi® connection.In these cases the following steps are recommended:
    • Clear the app's data (Settings > Apps > GO > Clear data). Please note, that this will delete your personal information, e.g. My Places, My Routes and destination prediction data. You can save and restore My Places with MyDrive.
    • Soft reset your phone
    • Open GO Mobile and toggle off TomTom Traffic and Speed Cameras in the TomTom Services menu.
    • Turn TomTom Traffic and Speed Cameras on again.

    Should this not help you sort this out, please contact Customer Service. They'll be able to get to the bottom of your issue and assist you accordingly.

    Cheers, Mikko
  • tgold
    tgold Registered Users Posts: 2,192
    Revered Voyager
    This cure will leave the user with no downloaded maps while connected via mobile data. It seems not much better than the disease itself.
  • jc531
    jc531 Registered Users Posts: 1
    Apprentice Traveler
    I too have had this problem and it is very frustrating. I've just got a new phone running Android 7.0 and have downloaded TomTom Navigation 1.16.1 - when I open the app it tries to download a map but says "Unable to show maps. Check your internet connection and try again." I am connected to both WiFi and Mobile Data and everything else on the phone works perfectly. I've tried following the instructions above but that doesn't solve the problem.

    I had to reset my old phone (updated to Android 6.0.1) as it wasn't working and have tried reinstalling TomTom on it, but it has the same problem.

    I got out the oldest phone I still have, running Android 4.1.1 - the phone barely works but TomTom Navigation installs correctly, connects to the WiFi and lets me log in and download maps. It seems that TomTom 1.16.1 has some problem with the later versions of Android.

    Please sort out this problem ASAP and provide an updated version of TomTom on the Play store, or let us download previous versions which worked fine. I have paid for this app and when it works it is great - I don't want to have to settle for Google Maps or using TomTom on an old broken phone which can crash any minute.
  • schneidernet
    schneidernet Registered Users Posts: 269
    Exalted Navigator
    I reported to TT support. They replied they have never had anyone else experience the problem. Glad to know I'm not crazy.
  • VikramK
    VikramK Administrators Posts: 14,024
    Hi schneidernet

    I had a quick look at the contact history on your account. Unfortunately, I am not able to find the incident number for your recent contact.

    If you can click on this link to sent me the incident number through a private message then I can have a look for further assistance.

  • cterrosi
    cterrosi Registered Users Posts: 2
    Apprentice Traveler
    Dear All,
    Same problem here, app always said error check internet connection and I can't download any map.

    Could you please help me?

    My incident reference number is 1708xx-xxxxxx


    Mod edit: Please do not post any personal information on a public forum!
  • cterrosi
    cterrosi Registered Users Posts: 2
    Apprentice Traveler
    Thanks for letting me know.

    Anyway I need your support for my I issue I am unable to use Tom for android navigator.
  • lampard
    lampard Administrators Posts: 6,004
    Hi cterrosi,

    I can see that the support already informed you about this issue. It is under investigation with no current workaround available.

  • sarddoc
    sarddoc Registered Users Posts: 1
    Apprentice Traveler
    It did not work on my new Samsung Note 9. this is really frustrating. Fix it please!!!