Recorded voice not working?

bobthebob
bobthebob Registered Users Posts: 4
Apprentice Traveler
Hm...I have tried playing around more with this new TomTom Go app and there is another issue with the voices. I can only select one of the English Text To Speech voices. None of the recorded voices will stay selected. It doesn't matter if it is one of the english recorded voices or a foreign language recorded voice, none will work. They preview just fine in the download voice section, but once downloaded, they do not preview properly and even if you select one, the system will not keep it selected once you hit the back button to go back to the map. The system will only keep a TTS voice selected.

(regarding the tts voices, it seems they must match your device language. another forum thread stated this)

Does anyone know what is going on? Is this a bug? I have the latest version (1.13.2) installed.

Comments

  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi Bob,

    Welcome to the Community!

    This issue has already been reported to the product team. Meanwhile, if you select a recorded voice, close the app and launch it again then the recorded voice will be selected.

    Cheers, Mikko
  • bobthebob
    bobthebob Registered Users Posts: 4
    Apprentice Traveler
    It just goes back to the english TTS voice. If I delete the TTS voice and just leave one of the recorded voices and restart the app, I get a message at the top saying that the voice was not compatible with my device's language. (which is set to "English") Yes, I was trying to use an english recorded voice.

    Once this is fixed, please leave a reply or something to let me know that it is fixed. I'll also keep an eye on the play store for updates to this app and the release notes associated with it.
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi Bob,

    Thanks for the elaboration!

    That sounds different than what I've seen reported here before. Please, report this to Customer Service. They can best gather the full details required for investigating the issue.

    Cheers, Mikko
  • tennd
    tennd Registered Users Posts: 3
    Neophyte Traveler
    Hi MikkoK,

    I have the exact same issue.
    The go mobile version is 1.14.1 release/1.14(1818)
    The map version 980.7890(US East South Central)
  • tennd
    tennd Registered Users Posts: 3
    Neophyte Traveler
    Hi, Mikkok

    I make a video to show how i operate the voice setting

    [video]
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi tennd,

    Welcome to the Community!

    We released a new v1.15 of GO Mobile. Can you update your app and see if that helps?

    Could you also mention your phone model and Android version, please?

    Cheers, Mikko
  • tennd
    tennd Registered Users Posts: 3
    Neophyte Traveler
    Hi MikkoK,

    I have updated the latest version of Go mobile. But it still NOT works.
    My phone model is HUAWEI Mate9.
    Android version is 7.0

    attached screenshot
  • MikkoK
    MikkoK Retired TomTom Employee Posts: 23,905 Retired Community Managers and Staff
    Hi tennd,

    The product team got back to me about this. They weren't able to reproduce the issue on Android 7 with GO Mobile 1.15.

    Could you try deleting and re-downloading the Bonnie voice and try again, please?

    Thanks, Mikko
  • Eddepet
    Eddepet Registered Users Posts: 50
    Renowned Trailblazer
    How about deleting all the voices except Bonnie?
  • EmmeEmme
    EmmeEmme Registered Users Posts: 2
    Apprentice Traveler
    If you want to reproduce the issue, get an LG G3s and install Lineage OS. Voice does not work at all.
  • EmmeEmme
    EmmeEmme Registered Users Posts: 2
    Apprentice Traveler
    I tried 1.13, 1.14 and 1.15. None of them works. Always the same error, "this voice is not compatible with the device language" despite it being English UK.

    I will not pay for mileage until the problem is fixed. Google maps in drive mode works great and I can download offline maps.
  • Asprin
    Asprin Registered Users Posts: 271
    Supreme Pioneer
    @EmmeEmme,

    Plus there seems to be updates for Lineage OS all the time.

    Have you checked with them about your problems with voices???

    I quote them:
    "Lineage OS is still very new, so it’s only available for certain makes and models of smartphones and tablets, and installing Lineage OS is something that’s perhaps best left to advanced users, as you may find certain features of your phone no longer work – or now work differently than before."

    Plus I do not think this is supported by TomTomGO..........

    AND you have to root your smartphone to install Lineage OS and rooted phones are not supported by TomTom......
  • jl1974
    jl1974 Registered Users Posts: 12
    Master Explorer
    MikkoK wrote:
    Hi tennd,

    The product team got back to me about this. They weren't able to reproduce the issue on Android 7 with GO Mobile 1.15.

    Could you try deleting and re-downloading the Bonnie voice and try again, please?

    Thanks, Mikko

    To reproduce just download tomtom on a mobile device (I use Android 6). make sure you have an external SD attached to your phone which was formatted as an extension of the internal memory. Tomtom will install on the internal storage. Move it to the external storage and bang you have the issue.

    It is solved again by moving the tomtom app back to the internal memory.

    for me it is a clear bug. Do you offer bug bounty.
  • [Gelöschter Benutzer]
    [Gelöschter Benutzer] Posts: 5,321
    Supreme Navigator
    jl1974 wrote:
    ... just download tomtom on a mobile device (I use Android 6). make sure you have an external SD attached to your phone which was formatted as an extension of the internal memory. Tomtom will install on the internal storage. Move it to the external storage and bang you have the issue.
    No one is forced to.
  • tgold
    tgold Registered Users Posts: 2,192
    Revered Voyager
    jl1974 wrote:
    To reproduce just download tomtom on a mobile device (I use Android 6). make sure you have an external SD attached to your phone which was formatted as an extension of the internal memory. Tomtom will install on the internal storage. Move it to the external storage and bang you have the issue.

    It is solved again by moving the tomtom app back to the internal memory.

    for me it is a clear bug. Do you offer bug bounty.
    A bug is generally understood to be an error in performing a documented function. Are you sure that moving the TomTom GO app to and from external storage is designed or intended to be a supported feature?