New v.1.7 hangs on start (loading app) — TomTom Community

New v.1.7 hangs on start (loading app)

edoardedoard Posts: 16 [Outstanding Explorer]
I have been using the Go app on a Note2 since its very first release (as a customer of the previous TomTom Europe app)

I have been running Android 5.1.1 for some 4-5 months without issues.
However as of the latest TomTom Go app update 1.7 as available on the Google play
it no longer starts.
I have tried uninstalling/reinstalling/removing the Sd card to force it to run from th inbuilt stoarge - nothing helps.

As of now it is useless to me after years of being a TomTom user and have to rely on Nokia maps.
Does anyone else have issues with 1.7 ?

Comments

  • IanS100IanS100 Posts: 302 [Supreme Navigator]
    On my Note 3 it actually loads again, so I now have a working TomTom Sat Nav, which makes a pleasant change. Hopefully it will continue to work once I've used it a few times, I'm keep my fingers crossed.
  • IanS100IanS100 Posts: 302 [Supreme Navigator]
    Brief Amendment:
    I've just tried starting TT with an address link from the calendar, it took almost 4 minutes to start & couldn't find the address, although Google & a few other apps I tried didn't have any problems finding it, this is not a good start :-(
  • eekiemaster_un37eekiemaster_un37 Posts: 1 [Apprentice Traveler]
    Question for support: Is version 1.7 compatible with devices running android 5.11 ???
    Are there others having issues with version 1.7 in combination with 5.11?
  • tgoldtgold Posts: 2,071 [Supreme Pioneer]
    If you mean Android 5.1.1 then I have seen no issues with GO Mobile 1.7 running with that version yet.
  • edoardedoard Posts: 16 [Outstanding Explorer]
    I finally nailed the issue. App 1.7 has issues with the external SD card.
    It will by default download a map there but then it is unable to start.

    If I uninstall the app, eject the SD, install the tomtom app again and download a map,
    it will be written to internal storage and the app will start normally.

    The problem is that I cannot use the whole Europe map again (I normally need countries in East Europe as well as the West)
    because it is >6G and it won't fit on my Note2 internal storage. That's why I have an external SD card that can hold maps music videos etc.

    TomTom, please fix the issue. It has worked until version 1.7
  • TTCTTC Posts: 36 [Outstanding Wayfarer]
    edoard wrote:
    I

    If I uninstall the app, eject the SD, install the tomtom app again and download a map,
    it will be written to internal storage and the app will start normally.
    TomTom, please fix the issue. It has worked until version 1.7

    I can confirm this.
    In my Galaxy Tab S (Android 5.0.2) with SD-card inserted>> no go.
    When I pull out the SD-card and reinstall Go >> Go :-)

    Hope it will be fixed soon...
  • schneidernetschneidernet Posts: 120 [Renowned Wayfarer]
    I have a Galaxy Tab S running 5.0.2. Maps are on the ExtSDcard and TT 1.7 runs fine. Runs fine on my HTC M8 so I'm happy - for now.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Edoard and TTC,

    Can you tell me what kind (model, class) of memory cards you're using? We recommend using class 10 cards.

    Cheers, Mikko
  • TTCTTC Posts: 36 [Outstanding Wayfarer]
    Hi Mikkok.

    Thanks for your reply.
    I use a class 10 card 64 Mb.
    There is no name written on the card so I don't know the brand.
  • schneidernetschneidernet Posts: 120 [Renowned Wayfarer]
    TTC wrote:
    Hi Mikkok.

    Thanks for your reply.
    I use a class 10 card 64 Mb.
    There is no name written on the card so I don't know the brand.

    That's scary. Might be a poorly crafted knock-off. Even the name-branded cards are faked. I always buy from a reputable seller, mainly Amazon. "Real" cards will have names, model and serial numbers, and country of origin on them.

    There are some apps that will read the "internal" info about the card. Try the PlayStore.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Our mobile team also suspects, as schneidernet suggested, that this is likely an issue with the specific memory cards used. I'd recommend trying on another card.

    Cheers, Mikko
  • TTCTTC Posts: 36 [Outstanding Wayfarer]
    Your mobile team and schneidernet are right :8
    Did try it with an other card (transcend 32 Gb class 10) and app started normal after downloading maps to card.
    Thanks for the tip.
  • schneidernetschneidernet Posts: 120 [Renowned Wayfarer]
    TTC wrote:
    Your mobile team and schneidernet are right :8
    Did try it with an other card (transcend 32 Gb class 10) and app started normal after downloading maps to card.
    Thanks for the tip.

    Too many crooks out there.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    TTC wrote:
    Your mobile team and schneidernet are right :8
    Did try it with an other card (transcend 32 Gb class 10) and app started normal after downloading maps to card.
    Thanks for the tip.

    I'm glad to hear you got it sorted! :D And thanks for the confirmation.

    Cheers, Mikko
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi edoard,

    I marked your question as answered as my post above seemed to answer it. In case it didn’t actually answer your question, please post back here so we can help you further.

    Cheers, Mikko
  • JoergKJoergK Posts: 2 [Apprentice Traveler]
    Hi edoard,

    is your sd card formatted to exFat?

    My samsung s5 with cyanogenmod 12.1 (= android 5.1.1) had the same problem. GO 1.6 and all other apps worked fine with the sd card (SanDisk Extreme 64GB, preformatted to exFAT), but GO 1.7 hung on start and in certain cases it made the sd card inaccessible! With an other sd card (samsung 32GB class 10, FAT32) GO 1.7 started without problems.

    So i formatted the sandisk extreme card to FAT32, and now it works :-)
    Unfortunately FAT32 is outdated and doesn't support large files... I hope that bug in GO will be fixed soon!
  • tgoldtgold Posts: 2,071 [Supreme Pioneer]
    I can't believe the app controls whether or not Android can read data from an external storage device formatted in exFAT. I suggest you chase CyanogenMod for any fix.
  • deestodeesto Posts: 2 [Apprentice Traveler]
    As the poster Klerk, I'm having the issue with all sorts of cards. I now have a Sandisk card installed - one of the best. I'm on an Xperia z ultra. The app is useless if I can't install it on SD card, as I also have to have Europe installed as I can't rely on mobile go and running out of internal storage otherwise. Please fix the issue.
  • uodalricusuodalricus Posts: 1 [Apprentice Traveler]
    I also have this issue, on a Sony Xperia Z3 compact. I find the claim that it is caused by "specific memory cards" extremely dubious (to put it very mildly). Why the heck would the ability of the app to start depend on the class (=speed) of the SD card? No other apps, including other navigation apps, have any issue with my SD card. It's only TomTom that is acting up, after more than a year of working without a hitch, with the same SD card.

    There is an older thread (https://en.discussions.tomtom.com/tomtom-go-mobile-and-navigation-for-android-156/go-mobile-app-hang-on-opening-with-app-loading-978199) about the same issue, with quoted emails showing that TomTom engineers are aware of the problem, but unable to debug it.
  • mdinisoaemdinisoae Posts: 2 [Apprentice Traveler]
    I have Sony Xperia Z3 compact and I face similar loading problem after Android upgrade from version 5 (something) to 6.0.1.
    After OS upgrade I had issue with many other applications and I decided to use Factory reset option and then reinstall all applications.
    I did it for TomTom GO too, it was working 2 times and then, suddenly - with no other changes on my mobile - GO application get stack on "Loading app".
    As history, for ~ 9 months I used the application on the same mobile and the same memory card, I made 2 major upgrades on the Android OS and only one time I faced the issue with "Loading app" after an upgrade of GO application. I thought it's was my fault because I didn't check the application after update and perhaps a new Map version was required. I reinstalled the application and it works fine till now with Android 6 upgrade.
  • IanS100IanS100 Posts: 302 [Supreme Navigator]
    The first and most obvious thing to try is to uninstall and reinstall TT GO.
  • mdinisoaemdinisoae Posts: 2 [Apprentice Traveler]
    I reinstalled the application again, downloaded the Europe map and now TTG works: app version 1.11 (1555) with Map ver. 970.7464 (Europe).

    I'm wondering if this will happen again, because always it was happen to me when I needed most (I was in traffic outside my city). I still have 15 days license and I will monitor the application, if it will happens again, with deep regrets, I will not renew my license.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi mdinisoae,

    I'm glad to hear you got this sorted with Ian's help! :D

    This was most likely caused by the Android update for your phone. It is, unfortunately, not uncommon that apps may have problems after OS update but usually re-installing the app solves them.

    We're working hard to make our app more resistant to these scenarios, but should you run into further trouble that re-installing doesn't solve, please contact Customer Service for further assistance.

    Cheers, Mikko
  • Tonyb1973Tonyb1973 Posts: 1 [Apprentice Traveler]
    HI, i have the same issue. I had a sandisk 120gb and was working fine. I took it out to put music on and there was a problem with the format so i re-formatted and tried to open the app and the screen just says loading. So i took out the card and tried to re install the app again but nothing but the loading screen. I have tried to re-install 5 times now and i need this tomorrow morning to travel from Wales to Holland.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Tony,

    Welcome to the forum!

    Sounds to me your issue might be related to the one discussed here.

    Otherwise, I'd recommend you to contact Customer Service for further assistance.

    Cheers, Mikko
This discussion has been closed.

Who's Online8

dannykato
dannykato
Selehman
Selehman
+6 Guests