Start 25 keeps waiting for a valid GPS signal

Hi All,

I have a tomtom Start 25 (on the box it says VIA 225 M). It was working fine since last 8 - 9 months, and all of a sudden has start to give me a problem. It keeps saying waiting for a valid GPS signal... Also when it does connect, it keeps losing the GPS signal.

I have updated with latest QuickGPS fixes but still the same problem,

thanks for your help


  • YamFazManYamFazMan Posts: 14,795 Superusers

    Have you tried a Drum roll start????
    Charge the device for at least 2Hrs or have the device plugged into a power supply
    Press and hold your on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like re-booting your PC
    I use a Soft/drum-roll start after any upgrade large or small.
    It’s also useful to keep in mind for sorting out most minor niggles......

    Note: - Some early Tomtom models have a reset button for more Info see.....

    Help others identify useful content...
    If someone posted something that was helpful?
    Click the 'Like' > 👍 Icon

    If someone answered your question?
    Please answer 'Yes' to Did this answer the question? 'Yes' < >' No'
  • knk warnerknk warner Posts: 2 [Apprentice Seeker]
    I also have purchased a Start 25 (and the box said Via 225 on it) and two days ago the GPS signal started dropping out, it would find it then drop out a few seconds later. I have updated the devise with the latest quick find GPS but it is still doing it. Is it buggered or is the a fix for this issues?? if someone could please assist.
  • ZsoltZsolt Posts: 36,020 Superusers
    Try to press and hold the ON button, until you hear the drum roll. Tried it outdoors of course. Also it is worth doing this soft reset sometimes (depending on the usage say every week, two weeks, month).
  • knk warnerknk warner Posts: 2 [Apprentice Seeker]
    Thank you for this I will give it a go.
  • Haggis007Haggis007 Posts: 1 [Apprentice Traveler]
    I did all of the above and it was just the same, losing signal.
    As I use it every day for deliveries I also deleted the recent locations and did all the updates (GPS fix and MAPs) again.. did drum roll reset and it seems to be working fine again.
Sign In or Register to comment.

Who's Online7

+6 Guests