Map deleted by update; can't re-install. Very frustrated — TomTom Community

Map deleted by update; can't re-install. Very frustrated

m0sbfm0sbf Posts: 7 [Master Explorer]
edited January 2019 in Map purchase & installation

I have been working for 8 hours and am frustrated beyond belief with my Tom Tom Go 5000 and the useless MyDrive app. I decided to update the maps yesterday and the update failed. All additional attempts (and there have been many) also fail. More annoyingly, the update deleted the Europe map on the SD card of my device; leaving only the US map (which is on internal memory). Not much use if I want to drive around the UK.

I can't move the Europe map to internal memory and the USA and Canada map to SD card, as there's not enough internal memory - hence Europe WAS on the SD card. Although the SD card is now frustratingly empty.

The device still boots OK; but has no Europe map!

During the repeated download failures, the fragments of my Europe map have become corrupted. I clicked "Repair"; but that failed too after 20-30 minutes. Tried again, fails yet again.

I have since cleared the Cache and reset the Tom Tom device from "System" - then tried again. That failed mid way through downloading the new map - same error:

Failed to download content for your GO 5000/5100 with ID QRxxxxFxxxxx
Please consult your network settings.

The URL is as follows:

I have reinstalled the MyDrive app. I have turned off Antivirus, I have changed port to 5001. Re-formatted the SD card. All to no avail.
I even tried "Recovery", but when I connect the USB lead to the Tom Tom when the wheel is spinning. MyDrive fails to connect. Happy days!

I have now successfully manually downloaded the 1GB Europe map manually from The file is named Europe3.ttpkg. It seems the best solution would be to try and manually install this map package. I tried clearing the cache and placing this file in that folder, but that doesn't work. Can anyone tell me how I go about manually installing this file on the TomTom Go 5000? I read somewhere about you have to rename it - but none of the files in the cache folder are .ttpk extension. So I am stuck.

We had BT Infinity installed this week, so I don't know whether the BT Hub 5 is causing the problems with downloads. I never had these download problems with my BT Hub 3!

Any advice/help anyone can give on a manual map install on my Go 5000 (with the Europe3.ttpkg file) would be appreciated.


Mod edit: Please do not post any personal information on public forum!


  • dhndhn Posts: 33,368
    Think you are going to need to wait till Monday and call support:

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • AAKAAK Posts: 3 [Apprentice Traveler]
    I have exactly the same problem... my sat nav is now as useful as a paperweight. The update deleted my current map and does not download the new one.

    This app is useless along with all the FAQ and troubleshooting.
  • AAKAAK Posts: 3 [Apprentice Traveler]
    I have no idea how or why, but after about 6 re-installations, reboots and device resets, when I was just about to smashed this on the wall for killing about 10 hours of my weekend, it worked, out of random. And now, its all fine like nothing ever happened.

    This is my last Tomtom, ever, hopefully some sad bastard will steal it from my car, or I end up breaking it gloriously when something like this happens again. And it will happen, no doubt.

    Tomtom should have put more effort into drivers compatibility, user experience and performance of the suite rather than all this fancy visual effects within the app. I think I will have nightmares with the spinning wheel and all the publicity banners that never fail to show, even if the app is not working! Bloody brilliant!
  • MontisonoMontisono Posts: 5 [Neophyte Traveler]
    It is interesting to read these comments, as they mirror my experience exactly. We have had ours for about three years. In that time I have never had an update without various problems. It is quite clear that the people behind TomTom treat their customers with utter contempt. My parents have a Garmin and no trouble at all. Guess where I will be looking for a new sat nav.
  • FlorenceWFlorenceW Posts: 2 [Apprentice Traveler]
    I have the GO6100 - tried my first update last week and same as the guys above it deleted the Europe map completely and will not reinstall another. I have done everything the helpdesk recommended and I still have no map. It corrupts the update, I repair it then I delete it then I start again - it has been going on for hours! After spending £300 less than 10 months ago I am really not happy.
    Can anyone give me any help as to how I get the Europe map back on the device?
  • dhndhn Posts: 33,368
    Have you tried clearing the cache in the Settings? Anything here? maps found
  • m0sbfm0sbf Posts: 7 [Master Explorer]
    Yes I have cleared the cache many times! I am now up to over 15 hours of heartache trying to recover my Sat Nav Europe map. Still have a bricked sat nav.

    The USA map is still installed and working on the units internal memory, so that would be great if I was 3000 miles west of here!

    To summarise, I have also tried the following:

    Changing the port MyDrive is using in the settings menu to 4000, 4001, 5000 or 5001.
    Setting up port forwarding for these ports to the laptop using MyDrive, in the Home Hub 5 admin
    Placing the computer using MyDrive in the DMZ on the Home Hub
    Turning off the Home Hub 5 Firewall (not recommended) and then using a MacBook Pro (with it's Firewall on)
    Setting up Windows 10 inbound and outbound firewall rules to allow MyDrive any port
    Malware and virus checked laptop - clean
    Removed and re-installed MyDrive app with a fresh download used
    Trying another PC with fresh install of MyDrive (that just failed at 100% map upload too)
    New micro SD card tried; always re-formatted before fresh attempts

    I think the "can't download the map updates" problem - which incidentally is just one of two different problems - is caused by the Home Hub 5. When I went to a friend's house yesterday with Virgin cable modem, I was able to download all the Europe maps within minutes, without any hassle (after clearing the cache folder of any corrupted files). I was even using the same laptop. From what I can see there are seven of them now in cache:

    content 1 986383KB
    content 2 911889KB
    content 3 1384151KB
    content 4 1045685KB
    content 5 942815KB
    content 6 712000KB

    However (even with these freshly downloaded Europe map files) all attempts to load them onto the device's SD card have failed. Annoyingly the 'install to SD card' always fails at 100%! So you wait an hour or more only to find that the update failed again! You then get a 'corrupt map' message with the option to 'Repair'. The 'Repair' fails too at 100%.

    Here's another interesting find too - yesterday the 8GB SD card showed 0 bytes free after the failed update - so I assumed that's why the update failed - the card was full - so I bought a bigger 32GB SD card today. When inserted into the card reader of my PC, the 8GB card was literally full of what seemed like replicated TomTom content files.

    I formatted the 32GB card in the Tom Tom Go 5000 for 'maps' and tried again to install the Europe map. Amazingly, after another failed attempt at uploading the Europe map to the SD card, that card was showing as totally full too (0 bytes free)! How can the Europe map be 30GB big - split into 15 2GB content files?! It seems like whatever the process is in MyDrive that is creating the individual content files for the SD card has a serious bug in it. So I think the "gets to 100% then fails" map update issue must be a MyDrive bug.

    Regarding the download issues (the other problem I am having). The Home Hub 5 event log shows some interesting entries which seem to imply that it's firewall is blocking the MyDrive data packets:

    OUT: BLOCK [9] Packet invalid in connection (tcp reset attack is suspected: TCP []:50259->[]:80 on ppp3)
    OUT: BLOCK [9] Packet invalid in connection (tcp reset attack is suspected: TCP []:51360->[]:443 on ppp3)
    BLOCKED 148 more packets (because of Packet invalid in connection)--
    IN: BLOCK [9] Packet invalid in connection (Invalid tcp flags for current tcp state: TCP []:443->[]:50076 on ppp3)

    I now know that the BT Home Hub 5 (on BT Infinity FTTC) has some Firewall issue which seems to render it incompatible with the Tom Tom MyDrive application. This was the main reason why my downloads to cache continually fail.

    This is all massively frustrating and frankly I would never have bought a Tom Tom product, if I had known that I cannot update it.
    It's time they sorted out this horrible MyDrive application and made it work. The Tom Tom Home application was so much better and had much more functionality.

    A call to their support team is needed tomorrow. Let's hope that there is some solution to manually install the maps, or I might be screwed. My patience is running out with this piece of junk. I was this close to sledge hammering it yesterday!
  • LostkiwiLostkiwi Posts: 6 [Master Explorer]
    I have the same issue. Everything fine for the last 2 or so years then updated tomtom 500 today- Europe maps too large for the internal so have it on my SD card - NZ maps on the device are fine but no good for Europe...... Update takes the sd maps off the system and cant reinstall (update & install get to about 50% then speeds up. finishes the update right the way through to 100%) then tells me that the update failed and some of your items didnt install - no europe maps. Just offers a "repair button" which just goes through the whole process again.....

    Have cleared cache, reformatted the sd (which worked fine till this update). Tried wifi and wired connection.
    I cant offer any words of advice, but truly share your frustration. I feel that as we have the same thing, it cant be the devies, but has to be the updates?
  • LostkiwiLostkiwi Posts: 6 [Master Explorer]
    It would be also nice to see someone from tomtom try to assist here.....
  • dhndhn Posts: 33,368
    They don't work on weekends.

    Call support tomorrow:

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • AAKAAK Posts: 3 [Apprentice Traveler]
    Looks like this problem is common... I wish I had some form of advice, but although I have been having problems systematically every single time I try to update my Tomtom, each time it works after many hours of trial and error without any obvious reason.

    I suspect Tomtom does not care about this issue, has been dragging for years and for many people as it seems. Btw, customer service just follows a script with a troubleshooting decision tree, a generic one, they could well employ anyone who knows how to read and it would be as effective.

    Lets look at the bright side, at least they employ good designers, visually this thing is pretty and the interfaces look good and are clear (when it works).
  • m0sbfm0sbf Posts: 7 [Master Explorer]
    24 hours on and I still have no working map. Tom Tom's support were as much use as a chocolate teapot. Just read from a script, with no in-depth technical knowledge of the product. I was told to uninstall the map using the "Uninstall" button then try re-installing it. That failed too!

    I have also tried a full restore - as well as deleting the Home3 directory in LocalApp and re-downloading everything. I am going to try escalating the matter to their second tier support today as I am now up to 15 hours of messing around with this device.

    I did however manage to solve the MyDrive network issues when trying to download maps using the BT Home Hub 5, which blocked the connection:


    1. Go to Windows Control Panel > System and Security > Windows Firewall > Advanced Settings > Inbound Rules > Add Rule > Add MyDrive Connect to "Allow" all ports. You can use all the defaults for "Allow". Save the rule. Do the same for "Outbound Rules".

    2. Go to BT Home Hub 5 admin ( Click on "Advanced Settings". Enter the admin password (if you haven't changed it, this will be on the removable tab on the back of the Hub. Click advanced settings > Firewall. Click "manage games and applications". Click "add new game or application". Name it "TomTom MyDrive". Uncheck the button "copy and existing game/application". Now carefully add all these ports, one at a time:

    Protocol Port Range Translate to
    TCP 80 80 80 80 Click Add
    TCP 443 443 443 443 Click Add
    TCP 3128 3128 3128 3128 Click Add
    TCP 3129 3129 3129 3129 Click Add
    TCP 4000 4000 4000 4000 Click Add

    Click "Apply"
    You'll then need to select TomTom MyDrive from the "Game or application" > Select game or application list > TomTom MyDrive
    Then, under "Device" select the device you'll be running MyDrive on for the update. If you don't know what that device is called; click "Home" in the Home Hub's top menu and you will see all connected devices listed. Make sure you pick the right one and then click "Apply"

    The Home Hub 5 should now work with MyDrive! Shame their map download still fails, for another unconnected reason!
  • m0sbfm0sbf Posts: 7 [Master Explorer]
    I finally have a working UK map; but it's not the full Europe map - which I still can't get to work. I asked nicely to Tom Tom customer service and they added the UK and Ireland map to my account, until we can sort out the Europe map debacle. This (much smaller) map downloaded and installed fine.

    I still believe that there is something wrong with the full Europe map; although TT deny this.
  • fabiotomfabiotom Posts: 5 [Neophyte Traveler]
    m0sbf wrote:
    I finally have a working UK map; but it's not the full Europe map - which I still can't get to work. I asked nicely to Tom Tom customer service and they added the UK and Ireland map to my account, until we can sort out the Europe map debacle. This (much smaller) map downloaded and installed fine.

    I still believe that there is something wrong with the full Europe map; although TT deny this.

    how you solved ?
    I have the same problem. thank you
  • GrangyGrangy Posts: 4 [Master Traveler]
    I have had exactly the same problem. Got a Start 60. Did an update, now have no maps available, flash tool doesn't run. Now have a very expensive piece of crap, that is entirely useless !!
    won,t be wasting my money on tom tom again, and will be telling all how bad this is !!!!
  • GrangyGrangy Posts: 4 [Master Traveler]
    Yeah, been there, done that. Didn't work.
    Depending on which way the wind is blowing, the device will stay connected for anything between 0 seconds & 1 min, it then drops the connection and you have to start again. Each time it doesn't stay connected long enough to download anything .
  • UncleTomTomUncleTomTom Posts: 2 [Apprentice Traveler]
    I had the same problem last weekend. Spent the whole weekend updating my GO 6000. My TomTom has always worked fine, no problems with prior updates. I updated the MyDriveConnect, then started to update my device. As I remember the update also contained a firmware update for my device. The Europe map downloaded without any problems, and started to install on the SD card of my device. After a while the installation failed, I had no map on my SD card and MyDriveConnect told me that it was a problem with my SD card. Tried reformatting the card on my Mac, but the GO 6000 did not recognize the SD card. Since the Europe map was to large for the internal memory i went for the option to download a reduced Europe map with 3D for Scandinavia only. The download was OK, but the installation halted at about 40% and I got a message that the map installation failed. I got the option to "Uninstall" or "Repair" the map.
    This is what I did: I reset the GO 6000 by pressing the power button until the drum sound appeared and kept pressing the button until a status screen showed. Turned the GO 6000 off and connected it to the Mac again and started installing the map. During the installation I got the message "Your device is not responding, try disconnecting and reconnecting it again". I did and the installation continued until about 40%. Then the installation suddenly reached 100%, MyDriveConect said that my device was successfully updated, and my GO 6000 said that it did not have a map installed. I did this several times, repeated the the process, uninstalling the map and resetting the GO 6000, and suddenly it completed the installation. Don´t ask me why. Now the GO 6000 did recognize the memory card, and formatted it. I then tried to install the full Europe map on the SD card again and was back to square one. Repeated the whole process over and over again and finally managed to install the reduced Europe map in the internal memory. I also downloaded the MyDriveConnect to my friends Windows PC and tried, but the problem was identical, so it is not an isolated Mac or Windows problem. This finally worked, but there is a serious bug somewhere here, and TomTom has to fix it. If not we will all be Garmin customers in the future. TomTom has to figure out if the bug is in the Europe map, the update of the MyDriveConnect or in the firmware update of the device. If you are very very patient you can try my solution, or just go and find a sledgehammer and then buy a Garmin.
  • dhndhn Posts: 33,368
    There is a current issue whereby Europe maps are not installing on SD cards. If you call support and refer to CCARE-2148 then Support will know how to proceed for a workaround.

    Norge (Norway)
    Mandag-Fredag: 10:00 til 17:00
  • Mao82Mao82 Posts: 1 [New Traveler]
    :@ I have the same frustrating issue. I cannot install the full Europe map on SD card, but I am able to install a reduced map (3d buildings only for a restricted set of countries) on internal memory. Tom Tom, why the hell didn't you put 16 GB as internal memory? The memory cost is so low ... Hope to see a solution soon!!!
  • Andrew YAndrew Y Posts: 4 [Master Traveler]
    MAny problems here. Tried to install USA map to SD card on 6100. USA installed then Europe came up as corrupted. Now have no europe maps and cannot download and install. Computers show download done but update to device just stalls at 0% time left 59mins 10 seconds.
    I have tried three computers, windows 10, windows 8. but all fail.
  • dhndhn Posts: 33,368
    If you remove the sd card, you should be able to install the smaller (no buildings) Europe map on internal while TomTom figures out a resolution to the issue. Call support and quote CCARE-2148 for their reference in this matter.

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • Andrew YAndrew Y Posts: 4 [Master Traveler]
    Just spoke with to TomTom support. Apparently problem with their system/software. They cannot resolve the issue. They new about this last week but don't have a solution. They suggest waiting till download/ install fails, removing SD Card, then download U.K. Only (as Europe will not fit on 6100 memory!)
  • GrangyGrangy Posts: 4 [Master Traveler]
    So, having waited 8 days !!!! Still no workable response for this problem. What a bunch of t*ssers !
    My paperweight, ( start 60), is now completely useless. Time to start telling all how bad TomTom support and backup really is, and never ever to waste their money on any of their kit.
    GARMIN all the way for me now
  • dhndhn Posts: 33,368
    Did you actually call support about your problem?
Sign In or Register to comment.

Who's Online in this Category0