FAQ - MyDrive Connect troubleshooting tips — TomTom Community

FAQ - MyDrive Connect troubleshooting tips

MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
edited January 2019 in MyDrive Connect
Here are some tips and tricks from the forum, with my own additions and support FAQs to help people with issues updating their devices.
First, MyDrive Connect is not to be mixed up with MyDrive.

There are some specific things to consider regarding the device model you have as well as the operating system of your computer and I will mention these when applicable. Most of the advise below, however, applies to all devices connecting to MyDrive Connect on all supported operating systems.
[h2]Main differences to TomTom HOME[/h2]
For those users migrating from a device connecting TomTom HOME to a device connecting to MyDrive Connect, there are a couple of things I'd like to note. Which models are updated with which software can be checked here [support FAQ - Which TomTom software?].
For more information click the spoiler.
Unlike the older generation devices, the devices connecting to MyDrive Connect won't show up as mass storage devices on your computer but only as a Network Adapter.
Also devices connecting to MyDrive Connect no longer ask if you want to connect to the computer. When your navigation device is connected to the computer, the device will show a "Connected to computer" text.
While your device is connected to your computer, you can use it normally. When an installation is in progress, a text warning not to disconnect appears on the screen with a progress circle.
[h2]The most common symptoms[/h2]
Below are some of the most common symptoms you might see in connection/updating issues:

[h3]MyDrive Connect starts up when my computer starts[/h3]
This is default behaviour. You can change this in MyDrive Connect Settings.
For more information click the spoiler.
[h3]MyDrive Connect error messages[/h3]
The error messages MyDrive Connect gives when things don't go smoothly, unfortunately, are not always very informative as the software doesn't have any analytic capabilities to tell you what actually went wrong. Especially, the Rush hour... message can be caused by various scenarios and I'd recommend going through all the steps below (if needed), if you're receiving this error.

The most common error message states Something has gone wrong. It might even say there's something wrong with your device, but as explained below the issue rarely is with the device itself.
For more information, click the spoiler.
First do a soft reset (also known as drum roll reset) by holding down the power button for ca 20 sec or until you hear a drumming sound. You can also reinitialize the connection between your device and MyDrive Connect by clicking the MyDrive Connect icon 5ee73f32-8a48-4aa1-8b26-6fe3b6ca6b7c.jpg or 713d98e7-ad5b-47cc-8596-b97da43ec426.jpg in the Windows notification area (in Win 8 in Desktop view) or the Mac menu bar 3bb1b705-c788-463a-b380-4feb841d994b.jpg and choose Settings - Save settings. Settings can also be accessed by clicking the country flag in the top right corner of the MyDrive Connect window.
Data transfer error is a bit more informative and refers to a problem in the communication between the device and the MyDrive Connect. This error also shows a exclamation mark on the MyDrive Connect icon b76df70c-6687-43d2-bae8-98dceb0291ef.jpg
For more information, click the spoiler.
Reinstalling the device driver usually fixes this (see Connecting to computer below). As explained below, this might also have to do with antivirus or firewall settings. However, it might also be caused by corrupt data in the MyDrive Connect cache (which again might be cause by interference in your internet connection, see below). You can clear the cache by clicking the MyDrive Connect icon in the Windows notification area (in Win 8 in Desktop view) or the Mac menu bar and choose Settings - Downloads - Empty Empty download folder - Save settings. The following video helps you with changing settings:
Sometimes a manual clearing of cache is needed (e.g. if the Settings button is grayed out):
-       Close MyDrive Connect by clicking the MyDrive Connect icon in the Windows notification area (in Win 8 in Desktop view) and choosing Exit
-       Remove the HOME 3 folder at
XP:                   C:/Documents and Settings/Local Settings/Application Data/TomTom
VISTA/7/8:       C:/Users/Username/AppData/Local Settings/TomTom
10: C:\Users\Username\AppData\Local\TomTom
Mac:                 /Users/Library/Application Support and /Users/Library/Caches/ [to see Library press alt/option on your keyboard] 

This error might also be cause by a driver issue. Please, see below.
MSVCP100.dll missing is an error message you might get when upgrading a Windows OS to a newer version (for instance Win 7 to 8, or 8.1 to 10). You can find more information about this issue here [Microsoft.com].

[h3]Download/installation slow/getting stuck[/h3]
The first thing to note is that any durations given anywhere (in MyDrive Connect or on device) are estimations based on the current data transfer speed. As data transfer through internet and locally is always somewhat unstable - you might see some fluctuations and/or dyssyncrony in these estimations.

Sometimes an update appears to be stuck in MyDrive connect. This does not always indicate a problem. Sometimes it just has difficulty calculating the remaining time needed to complete the update, especially for Mapshare this is common.
For more information click the spoiler.
If you want to check if MyDrive Connect is actually doing something or if its completely stalled, you can use the Windows Resource Monitor or Mac OSX Activity Monitor to check if there is any activity. Please note that this only works in Windows Vista, 7 and 8. For Mac instructions, please see here (Thanks, Will!).
To access Windows Resource Monitor:
Open Task Manager (Ctrl+Alt+Delete)
Go to the Performance tab
Click on Resource Monitor in the bottom right corner
You now get an overview of all activity in the computer, including CPU Usage, Memory usage, Disk activity and Network activity. Your device is seen as a network device under the Network tab
If you sort by Total (B/sec) during an update you will see the following:

As you can see, the MyDriveConnect.exe process has a LOT MORE network activity than any other process and it will appear to be fluctuating as well, this means that there currently is a lot of data transfer between MyDrive Connect and your device which indicates it is still busy.
Best not interrupt this, just let it run its course and don't troubleshoot this unless an actual error occurs and it actually stops.

[h3]Full memory[/h3]
As the maps and software are developed and gain content and features they also tend to grow in size. This might result in the internal memory of your device running out and not able to accommodate the latest updates.

The quickest way to free up some space on your device is to remove some of the voices you don't use, especially the computer voices in other languages. You can do this with MyDrive Connect in the My Voices - Other languages section. For more information, please see here.
Click the spoiler for more information.
If you run into this situation when updating a map, a Content Wizard will pop up allowing you to choose which items to install and where. If you have a memory card in your device you can install (only) the map there.

Otherwise go ahead with the map installation by clicking Continue and you'll be offered a choice between smaller maps (if available) with a regional or no 3D buildings. For more information about installing maps, please see here.

You can also free some space in the internal memory by factory resetting your device. This removes the MapShare corrections from your device and can free up to 400 MB of memory. To factor reset your device by choosing Settings (cog wheel) - System - Reset - Reset. Please note, that this will delete your personal information, e.g. My Places. You can save and restore them with MyDrive (requires at least software v15.101).

[h3](Mac only) Admin password requested and MyDrive Connect stuck on "Connecting..."[/h3]
On Mac OSX Sierra (10.12) you might get requested the admin password if you wake your computer from sleep mode while your TomTom device was connected to it. Simply enter the password to continue updating your device. Restarting your computer also solves this.

For more information about this, please see this FAQ.

[h3]Device not connecting/recognised[/h3]
These issues usually have to do with internet connection, device driver or compatibility. Please, see the corresponding troubleshooting sections below.

[h2]Troubleshooting tips[/h2]
I'll start with the simplest procedures and move on to more advanced ones.
The first thing to do in any problem situations with your device is to do a soft reset (also known as drum roll reset) by holding down the power button for ca 20 sec or until you hear a drumming sound(I'm repeating myself, I know). Before moving on also make sure you have the latest version of MyDrive Connect installed [support FAQ Latest MyDrive].

The tips provided here are largely based on a breakdown of/elaboration on the rather comprehensive list provided by user Lars. I'm not going to go through each of his 19 points but focus on the most essential ones.
General instructions can also be found in this FAQ [support FAQ Navigation device not connecting to computer (MyDrive Connect)].
The compatibility requirements for MyDrive Connect are listed here [support FAQ MyDrive compatibility].
For more information click the spoiler.
Windows 10 is supported as of version

For Windows 10 specific troubleshooting advise, please see this FAQ.

Please note, that Windows XP is no longer supported and with Vista and Mac OSX 10.6 you may run into issues we can no longer solve. Furthermore, the v16.60x software release brought some changes with the driver compatibility for Vista and XP. Please, see here [supprt FAQ - MyDrive Connect update for Windows Vista and XP] for more information.

Regarding Windows XP, please see this post. On XP, also please make sure you've installed all available Windows updates, especially .NET Framework.

With OSX 10.7.5 and later Apple introduced Gatekeeper, a program which checks if the application was approved on the iTunes webshop. The Gatekeeper might prevent you from installing MyTomTom. Please, contact Apple for more information about the Gatekeeper.

While Microsoft Surface Pro tablets are not supported some users have managed to get MyDrive Connect working on them.

[h3]Internet connection[/h3]
Various issues doing with internet connection are the most common cause for problems. General guidelines for internet connections can be found here [support FAQ recommendations for internet connections].
For more information click the spoiler.
In short, direct wired connections are preferred over wireless or proxy connections. 3G and 4G connections are especially vulnerable to interference.
Also business networks are often too strictly secured to allow MyDrive Connect to connect to the TomTom server and/or to the device (also a network connection) and the settings are usually beyond the users reach, however your system admin may be able to assist you.
Firewall and antivirus programs may also prevent successful connection, occasionally even between the device and MyDrive Connect. For some more specific tips about configuring firewall programs and routers, please see the posts below. Generally the settings should allow MyDriveConnect.exe ("MyDriveConnect.app" on Mac) full access to internet (in fact, tweaking these settings is rarely needed so try everything else first, before touching these settings).  On some firewall programs you might have the possibility to set the TomTom network device as a trusted network. Please note, that for any firewall/antivirus program re-configuration to have an effect MyDrive Connect needs to be restarted.
[h3]Connection to computer[/h3]
Important! USB cable should always be connected straight from the device to the computer. Note, that if you're using a windscreen mount that enables charging (e.g. with GO 500/600/5000/6000 devices) you can connect to computer through the windscreen mount for charging but not data connection.

If you're using Windows 10, please see first the Compatibility section above.

As devices connecting to MyDrive are recognized as Network devices, all data between the device and your computer also goes through the internet security software. To get this far, however, your computer needs to find the device and install a driver for it.
For more information click the spoiler.
You can confirm that this has happened and reinstall the driver if needed as follows:
-       Go to the Device Manager
XP/Vista/7: Click Start and right-click (My) Computer - choose Manage - Device Manager
Windows 8*: Press Windows logo key  +X to open the Quick Link menu and click on Device Manager.
Windows 10: Use search to find the Device Manager
Mac: Click the Apple menu and choose System Prefereces - Internet & Connection Network. You'll see the network service for your navigation device in the left hand pane.
-       Locate your device listed as a Network Adapter

If you do not see your device listed, click on the icon on the left of Universal Serial Bus Controllers. The device will show up as an unknown device or as a mass storage device. To determine which is the correct device, you can disconnect the device and the respective icon should disappear.
-       Right-click the device and choose Uninstall
(- Restarting your computer is recommended at this point)
-       Once the driver is uninstalled, soft reset (a.k.a drum roll reset) your device, while connected, by holding down the power button until you hear a drumming sound (ca 20 sec).
-       The driver will now be reinstalled.

If this fails you see a message on the screen saying that the installation failed, you can install the driver manually in the Device Manager. Right click on the device and click on Install driver manually and then choose Browse my computer for driver software.

Browse to "C:/Program Files/MyDrive Connect/DriverINF" and the driver will install (on 64 bit computers the path is "C:/Program Files(x86)/MyDrive Connect/Driver/INF").

Should your computer still not recognize your device, try another USB port (preferably straight, not a hub), another USB cable, and if possible, another computer. Also check whether your device is showing the "Connected to computer" message. Failing all this, you're most likely experiencing a hardware issue and should contact Customer Service for further assistance.
Installing MyDrive Connect is instructed here [support FAQ - How to install MyDrive Connect] on all supported platforms. There are a couple of situations where certain steps needs to be taken to successfully install MyDrive Connect.
[h3]Driver issues[/h3]
Should the re-installation of drivers not solve your issue, you might try a fresh installation of MyDrive Connect and the driver.
  • Uninstall the device driver (device needs to be connected, see Connect to computer above)
  • Disconnect the device
  • Uninstall MyDrive Connect
  • Remove the HOME3 folder from C:/Users/AppData/Local/TomTom and C:/Users/App/Data/Roaming/TomTom
  • Restart you computer
  • Download the MyDrive Connect installation file from www.tomtom.com/getstarted and run it as Administrator
  • Connect your device

Some more advanced driver troubleshooting on Windows 8.1 can be found here. Please note, that troubleshooting provided by other users on the forum is not supported by TomTom but you will follow it at your own risk.
[h3]Using SD card[/h3]
When using an SD card to install to install maps your device or MyDrive Connect may not recognise the SD card. First you might check the excellent tips posted by user Niall :D
Click the spoiler for more information.
When you insert an SD card into your device it should prompt to format it. Should this not happen, or MyDrive Connect doesn't recognise the card after it's been formatted, you can do the following (try again in between the steps):
  • Make sure the device is not connected to a computer.
  • Reset your device (with the card in it) by pressing and holding down the power button until you hear a drumming sound(ca 15 sec).
  • Insert the card into your computer's card reader and format it (no quick format) to FAT32 (on Mac MS-DOS filesystem).
  • Make sure the card is of a known brand and reasonably high speed (preferably Class 10).
  • Make sure the card is properly inserted into the device. It needs to make a clicking sound when inserted.
I hope this helps.
Cheers, Mikko
Disclaimer: Although these tips are provided by a TomTom staff member, the forum Use Agreement applies.


  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Here are some additional tips gathered from the forum regarding connection issues and specific av/firewall software: Other issues: Please, see the following links for further assistance:

    Antivirus / Firewall / Internet security Routers Cheers, Mikko
  • Will TWill T Posts: 9 [Legendary Explorer]
    Not quite true! The Mac OS has always had an equivalent resource monitor called "Activity Monitor". It's usually located in the Utilities folder in the Applications folder and a shortcut to it can easily be added to the Dock (Mac equivalent of the Windows Task Bar) it one isn't already there.


  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Will,

    Thanks for sharing your tip! I'll add it to the FAQ.

    Cheers, Mikko
  • BigGuyCABigGuyCA Posts: 9 [Master Explorer]
    A number of months ago - all was fine with Tom Tom software and updating my Go 600. I have tried all the suggestions as published on this web site. I am still experiencing the stuck at "1 minute and 47 seconds" during update. After about an hour I receive this message on my device: "Update failed - Please go to MyDrive and try again".

    I would expect Tom Tom to fix this problem. Thank you.

    P.S. The only change to my computer - software and hardware - was, in July/August, I upgraded/installed Microsoft's Windows Home 64 bit OS - after that successful OS upgrade, Tom Tom's MyDrive downloading and installing has failed to work

    Update: Just tried again and deselected all downloads except for the new version of device software - the files actually downloaded and installed to the device. IT'S A MIRACLE! I will post more if there are continued problems.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi BigGuyCA,

    Welcome to the forum!

    This issue is addressed in the FAQ above. The last software update also addressed this issue but was unfortunately not able to fix it for all customers. We'll continue to work on finding a solution to this issue.

    However, according to our logs MapShare last failed on your device a few weeks ago and you have indeed successfully installed it today :D

    Cheers, Mikko
  • BigGuyCABigGuyCA Posts: 9 [Master Explorer]
    Hi there

    Good news for me - all is working again


  • jbbjbb Posts: 91 [Renowned Trailblazer]
    I have a Start 60/6 and found when connecting to the internet using the default setting it's slow downloading but if I change to use system settings it's a lot quicker.
  • sparky9sparky9 Posts: 1 [Apprentice Traveler]
    I have the start 60, it wont connect to home or my drive connect whatever I do. I only purchased in sept 2015, done all the re-sets, removed and downloaded loads of times and nothing. it worked until November. I only purchased because I could update maps, now cant do anything with it. must still be under guarantee so would like to change it I think as its not doing what is advertised.
  • dhndhn Posts: 33,355
    The Start 60 uses MyDriveConnect, not Home.

    Anything here?:

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • AnatolAnatol Posts: 5 [Master Traveler]

    I have a problem with my new GO 610
    TT dont connected to computer

    Mac OSX
    El capitan

    I installed latest MyDrive ver

    connected TT to usb port
    and nothing

    I opened network service
    And there isnt network service TT
    I press +
    But in list have not TomTom Interface
  • DominikJaworskiDominikJaworski Posts: 1 [New Traveler]

    Can you help with my Rider? I am trying to install an update on my Mac OSX 10.11.3 through My Drive Connect, however the device disconnects just before the end. I have unplugged and plugged back in a dozen times, restarted both devices and used different cables, all without success. Can you help? All assistance gratefully received!
  • niffersniffers Posts: 2 [Apprentice Traveler]
    I am losing my mind with this.

    I have tried two different computers. Wireless and wired connections. Both OSX. They keep failing.

    I have previously managed to update without the maps, but now, having selected all the items it keeps failing.

    Is this fixable? I need to sort this today or get a different device as I'm on holiday from friday evening.

    2016-04-13 22:20:33.026|50331698|Error|DownloadFileCache::SendRequests|url: http://download.tomtom.com/nav3/965/nav4/Europe_0.ttpkg, error:
    2016-04-13 22:30:54.566|50331698|Error|DownloadFileCache::SendRequests|url: http://download.tomtom.com/sweet/navcore/00000000-0311-0016-1010-022670072525_system-update.ttpkg, error:
    2016-04-13 22:30:54.567|50331698|Error|DownloadFileCache::SendRequests|url: http://download.tomtom.com/nav3/965/nav4/Europe_0.ttpkg, error:
    2016-04-13 22:59:36.648|50331698|Error|DownloadFileCache::SendRequests|url: http://download.tomtom.com/nav3/965/nav4/Europe_0.ttpkg, error:
    2016-04-13 23:14:43.914|50331698|Error|DownloadFileCache::SendRequests|url: http://download.tomtom.com/sweet/navcore/00000000-0311-0016-1010-022670072525_system-update.ttpkg, error:
    2016-04-13 23:14:43.915|50331698|Error|DownloadFileCache::SendRequests|url: http://download.tomtom.com/nav3/965/nav4/Europe_0.ttpkg, error:
    2016-04-13 23:28:30.649|50331698|Error|DownloadFileCache::SendRequests|url: http://download.tomtom.com/sweet/navcore/00000000-0311-0016-1010-022670072525_system-update.ttpkg, error:
    2016-04-13 23:28:30.650|50331698|Error|DownloadFileCache::SendRequests|url: http://download.tomtom.com/nav3/965/nav4/Europe_0.ttpkg, error:
    2016-04-13 23:42:08.693|50331698|Error|DownloadFileCache::SendRequests|url: http://download.tomtom.com/nav3/965/nav4/Europe_0.ttpkg, error:
    2016-04-13 23:56:31.807|50331698|Error|DownloadFileCache::SendRequests|url: http://download.tomtom.com/nav3/965/nav4/Europe_0.ttpkg, error:
  • dhndhn Posts: 33,355
    See support assistance:

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.

    But it isn't wise to use a wireless connected computer. Anyway, make the call............Also, try downloading one update at a time, including individual speed camera files if relevant.
  • niffersniffers Posts: 2 [Apprentice Traveler]
    Thanks, I'll give them a call - but I can't go back to unselect all the updates, it just keeps restarting the download.. I swapped to a wired computer in any case, which is frankly a ridiculous requirement.
  • Will TWill T Posts: 9 [Legendary Explorer]
    As I've said before MyDrive Connect has some interface (window) issues with Mac OSX. Using 10.6.8 (Snow Leopard) and the latest version of MC plus a Go 50 and the original TomTom USB cable what happens is the main window doesn't refresh. So if you're downloading an update the progress bar will start then appear to stop after a short while as if the app. has crashed. But if you close the window then click on the MC icon in the Dock a new window will open showing the correct progress bar reading. Or you can minimise the window (put it in the Dock) then click on the window's icon in the Dock and it will open with it's contents updated. Either way the window will freeze again so you have to repeat the process until the window says the update has completed. Sometimes you can simply look at the TomTom's screen and get that info (saves keep on reloading the MC window). As it seems people with later OSX versions may be having the same problem as me it looks as if it's a deep (basic) issue, maybe on the Unix side. I have reported the bug - only TomTom Inc. can fix it...

  • momistmomist Posts: 6 [Master Explorer]
    Hi. I'm a long time Linux user, but I do keep a 17 year old laptop with Windows XP on it, just for things like TomTom which doesn't recognise other operating systems. Unfortunately, I've been having trouble with the MyDriveConnect program, and was advised to look to my firewall. I use Comodo (free) firewall, on the laptop. The link in this guide "Comodo (Thanks Lars!)" given by MikkoK 5 months ago: https://discussions.tomtom.com/t5/GO-800-1000-2000-Via-Start-20/Updating-Via-135-with-Win7-running-Firefox-and-Comodo-solution/td-p/496606 - appears to be broken. It probably would not have helped much on an XP machine anyway.
    Does anyone have some advice on this?
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi momist,

    Thanks for the heads-up about the broken link! A few of them seem to be still pointing at the old forum. I fixed the Comodo one already and will check the rest soon as well.

    Cheers, Mikko
  • ddSteveddSteve Posts: 4 [Neophyte Traveler]
    I find MyDrive Connect less informative generally than TomTom Home, but it certainly seems to work fairly well for my purposes. However, I do miss the ability to operate the TomTom device from the computer screen - Mac in my case.

    I have also found that there is no compatibility with the Mac's "dark mode", which changes the menu bar background to black. I find that this mode greatly improves the visibility of most menu bar items, but the TomTom logo does not invert when in this mode, so becomes entirely invisible. I am aware that there are other 3rd party apps that suffer from this, but there are plenty that don't, so I feel that TomTom need to have a close look at their icon definitions!
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Steve,

    Thanks for your feedback!

    Please note, that you can plan routes also online with MyDrive and sync them to your device. For more information and troubleshooting tips for MyDrive, please see this FAQ.

    Cheers, Mikko
  • fincastle84fincastle84 Posts: 84 [Renowned Wayfarer]
    There is a small community update sitting in MYDrive & it won't load & won't go away! As soon as I connect my Go 6000 it keeps trying to install itself. I've emptied the download folder, the empty cache option has gone, I've tried absolutely everything. Can TomTom please remove it from their end? Thanks
  • NiallNiall Posts: 11,002

    As this is a user forum you will need to contact Customer Services to sort this out

    CS United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi fincastle84,

    I'd recommend you to factory reset your device by choosing Settings (cog wheel) - System - Reset - Reset. Please note, that this will delete your personal information, e.g. My Places and destination prediction data. You can save and restore My Places with MyDrive.

    Cheers, Mikko
  • fincastle84fincastle84 Posts: 84 [Renowned Wayfarer]
    Thanks Mikko, I already did that to stop the attempted install, I have to do that every time I connect my 6000 to stop it happening. All I want is for the damn useless update to disappear!!
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi fincastle84,

    In that case I'd recommend you to contact Customer Service. They can check in the backend what's going on and help you sort it out :D

    Cheers, Mikko
  • fincastle84fincastle84 Posts: 84 [Renowned Wayfarer]
    Cheers Mikko.
Sign In or Register to comment.

Who's Online in this Category0