TomTom Go Mobile - claiming 3 years free problem — TomTom Community

TomTom Go Mobile - claiming 3 years free problem

lightwavinlightwavin Posts: 4 [Neophyte Traveler]
I cannot find how to claim the 3 years free - upon opening the new GO app, I get a message saying that I need to open the old app and follow the instructions to claim for the free upgrade. My options are 2 buttons - NOT NOW and OPEN APP (referring to original old app). I click the OPEN APP button and am directed to the old TomTom app, but no instructions appear as suggested. What next?
«1

Comments

  • RobhenstRobhenst Posts: 1 [Apprentice Traveler]
    Are you sure you must go to your "old" app, and not the "new" app (TomTom Go)? You can open the new app, and go to "upgrade" if it says "valid until:" followed by a date three years from your activation, you have succesfully upgraded.
  • lightwavinlightwavin Posts: 4 [Neophyte Traveler]
    When I open the new app, it prompts me with a message and link to open the old app - see pic attached. The old app is opened for me with no instructions as promised. Very confusing.

    0177c9b5-dc8b-4d2a-953d-67f8d486d7aa.png
  • mistermarkmorganmistermarkmorgan Posts: 3 [Neophyte Traveler]
    Same problem for me -- it just doesn't work. I've followed the instructions, deleted and reinstalled the app, rebooted the phone, followed the instructions again... it doesn't work. I get exactly the same screen as lightwavin, and when I tap 'Open App' it opens the old app, and then... nothing happens. I've tried downloading a map to see if that prompted it, still doesn't work. I've tried signing in, still doesn't work. I'm struggling to think of a reason not to just delete it and carry on using the old app.
  • FarushkuFarushku Posts: 3 [Neophyte Traveler]
    Restart your IPhone and check upgrade in menu.
  • mistermarkmorganmistermarkmorgan Posts: 3 [Neophyte Traveler]
    As I said, I've already restarted the phone. Several times, in fact. The 'upgrade' option in Go only gives the choice of two paid options, and instructions do clearly say "Follow the instructions in your old TomTom Navigation app to claim your free upgrade". The problem is that there *are* no instruction in the old app.
  • lightwavinlightwavin Posts: 4 [Neophyte Traveler]
    I restarted my iPhone twice already, no change. No instructions on how to upgrade for free as promised. Seems broken. :(
  • RYXRYX Posts: 6 [Master Explorer]
    I'm getting the same although now I don't get the not now / open app anymore.
  • xiphiasxiphias Posts: 3 [Apprentice Traveler]
    Was having the same problem, kept going round in circles ... open app, choose Not Now, go to Menu - choose upgrade , restore purchases, enter name and password and it should then update, and confirm expiry of march 2019.
    Not too keen on the new app and only just paid for traffic on old tomtom which apparently I don't need.
    Also disappointed that none of my places have been taken across to the new app, also cannot find how to navigate to photo or existing contacts.
  • FarushkuFarushku Posts: 3 [Neophyte Traveler]
    I had the same problem after downloading Go Mobile app.
    At points how I solved the problem with an upgrade in my iphone 6.
    1. downloaded go mobile
    2. closed all applications
    3. restart the iPhone
    4. open go mobile app and press the "Open App"
    5. opened the old tomtom app WAS NOT ANY INSTRUCTIONS !!!
    6. pushed the tomtom shop/GO Mobile
    7. opened app
    8. at the bottom of the screen appeared loading, and after upgrade was dan

    First of all, after update the old application tomtom you need to log in or register
  • TomahaukTomahauk Posts: 1 [Apprentice Traveler]
    I was facing the same issue until I found a solution a moment ago. When clicking the button 'Upgrade' I was presented with two options. Either a 1 year upgrade or 3 year upgrade, but they were both listed with a price. However, there was also a button near the bottom of the screen, which in Norwegian had the text 'Gjenopprett kjøp', which translated to English would be something like 'Restore purchase'. When I clicked this button I was presented with a login screen. I preceded to log in with my TomTom account credentials, which resulted in a text showing up telling me I have an unlimited navigation subscription valid until the 14th of March 2019. Returning back to the menu, it has been extended with several new options.
  • mistermarkmorganmistermarkmorgan Posts: 3 [Neophyte Traveler]
    Restore Purchases didn't work for me, but the following did:

    In the OLD TomTom app do this:

    Menu
    Change Settings
    Advanced
    switch Your Information on to allow data to be sent to the app

    Once I'd done that I quite the app and restarted it, and a screen popped up almost immediately offering me the free three years in the new app.
  • MadManMarcusMadManMarcus Posts: 4 [Master Traveler]
    I am getting this error when I try to upgrade via the old app - can anyone help?

    'Adding your purchase to your tomtom account failed. You can try again now. Or it will be retried when you next open the app.'
  • Jim manJim man Posts: 2 [Apprentice Traveler]
    Tap on the NOT NOW button. I had this prob as well!
  • lightwavinlightwavin Posts: 4 [Neophyte Traveler]
    Hey all, thanks to Mistermarkmorgan, his solution worked. You must ensure in the old app that you have gone to Menu>Change Settings>Advanced>YOUR INFORMATON must be turned ON. Then restart your iPhone, and go to the new app. You can now click the OPEN APP button that links to your old app - the option to upgrade appears now.

    You may need to create a TomTom account if you don't already have one - once registered, you will then be offered the free 3 year upgrade, which will require your iTunes log-in used for purchasing the original app. hope this helps!
  • CirienoCirieno Posts: 2 [Apprentice Traveler]
    I was getting the upgrade screen in the "old" app but got a message that purchasing the upgrade failed every time. I followed the recommendation to hard-reset the phone and now the upgrade has worked - I have the 3 free years licence.
  • filohfiloh Posts: 7 [Master Explorer]
    I'm getting this message. I don't know what else to do!!!
  • AirhawksAirhawks Posts: 1 [Apprentice Traveler]
    This suggested solution didn't work for me, what did however was the following...
    - On new TT Go App - choose 'not now' (instead of option to open old App)
    - Go to menu and choose 'upgrade'
    - Choose 'new account' then enter your normal TT account / password information.
    - Choose restore purchases
    - Job done (you can check by closing then reopening app, going to menu/upgrade and it should show "Unlimited Navigation - Valid until ../../19
  • filohfiloh Posts: 7 [Master Explorer]
    I already found the problem.
    Is because some tweak are causing this.
    When I deleted the IAPCrazy and LocalIAPStore the update goes well.
  • j.doej.doe Posts: 2 [Apprentice Traveler]
    I also had issues "purchasing" the upgrade in the old app. It would fail every time. I only got this fixed after clicking the forgot password link, the followed the email instructions to set a new password and subsequently update my profile on the tomtom page. My old profile had some missing details like date of birth. Only when I had a complete profile, did the purchase succeed.
    Hope this tip might help somebody out having the same issue
  • RichardFosseRichardFosse Posts: 6 [Master Explorer]
    The restart was needed. Now works. Thx to all. This was not entirely intuitive
  • DveGosDveGos Posts: 36 [Outstanding Wayfarer]
    Why would I want to "upgrade" to "Mobile GO" when I bought a free maps for life version of my map?
    If I upgrade for 3 years free I'm then into costs again after 3 years.
    Surely - there's a legal situation here if I'm not going to be able to keep and have what I was sold?
  • CarylRCarylR Posts: 3 [Apprentice Traveler]
    I have the same problem. I have made sure that I have my info on in the old app, I have deleted and downloaded 3 times. I have restored purchases. None of it made a difference, I can't seem to get it to link to the old app and give me the free upgrade!
  • Edwin272Edwin272 Posts: 1 [Apprentice Traveler]
    Same story inhere
    Cant get the free 3 years even
    Restored restarted dowloaded it 3 times but still get the massage TRY AGAIN
    Contacted TomTom but still no usefull answer
  • VikramKVikramK Posts: 7,990 TomTom Moderator
    Hi Edwin272

    Welcome to the forum.

    I have sent a heads up to customer service so they will be getting back you

    Sorry about the inconvenience caused.

    Regards
    Vikram
    Have a question? Ask!
    Did a reply resolve your query, please mark it as answer!
    Try the search; the information you are looking for could already be available.
  • YuliaTYuliaT Posts: 2 [Apprentice Traveler]
    Same here, did everything above, restored iPhone a few times, deleted and restored both new and old tomtoms. Need help ASAP!

    Can you please send the customer service my way too? Pretty please
This discussion has been closed.

Who's Online131

AndersNordh
AndersNordh
Andreas_Killer
Andreas_Killer
bastle
bastle
Bembo
Bembo
dhn
dhn
dmirlin
dmirlin
DougLap
DougLap
Elchdoktor
Elchdoktor
Jim07
Jim07
Justyna
Justyna
lampard
lampard
LCSM45380
LCSM45380
lorrydriver
lorrydriver
mapfanatic
mapfanatic
SabineT
SabineT
scheibenklar
scheibenklar
+115 Guests