my tomtom start25 doesn't connect with Mydrive, so I cannot download the updates on it. — TomTom Community

my tomtom start25 doesn't connect with Mydrive, so I cannot download the updates on it.

Hello everybody, suddenly when I try to download free timelife updates on my tomtotm start 25, I cannot do it any longer. The mydrive program says that my device "is not connected". Evrything is fine, but I cannot download. So I tried with Tomtom support, they told me to uninstall and reinstall the program and the driver, I've done with no result. I have seen during the installation of mydrive an error 1006, I told the support guy but she weas not able to solve my problem. After many many mails I've understood they do not know how to soolve the problem. Is there anybody that could help me, please? I have on my laptop Windows 8.1. Thank you!

Thanks a lot for any answer!

Giovanni

Comments

  • KakdeKakde Posts: 118
    Hi giocons,

    We apologize for the inconvenience caused to you.

    Looks like the web connector port you are using is not responding.

    Here try this :
    -Click the MyDrive Connect icon in the Windows notification area or Apple menu bar and then click Settings > Settings.
    -Click on connections tab.
    -Please change the webconnector port to 5000 and test.
    Please save the settings and connect the device.

    Hope this helps.

    Regards,

    Shardul
  • ZsoltZsolt Posts: 36,006 Superusers
    Some more tips if the above didn't help:

    "Official" TT tips:

    https://en.discussions.tomtom.com/go-800-1000-2000-series-via-series-start-20-and-60-series-mydrive-19/faq-mydrive-connect-troubleshooting-tips-990570

    If these didn't help, then try some of these:

    *Always make sure that you are logged in with the correct account. One device, one account*

    *** for Windows 10 users ***

    If you have just updated recently, you might run into trouble with TT (and other devices too). Disconnect the device, uninstall the MyDrive Connect support app with Revo Uninstaller, restart the PC, download the latest MyDrive Connect installer from http://www.tomtom.com/getstarted and install it again. Also in Windows 10, click on the "Start" menu (Windows icon in lower left corner), click on Settings and then Updates. Look for further updates, download and install those. Restart the PC, wait a minute or two, until everything starts up. Connect the device. If it is not recognised yet, keep it connected and then press and hold the ON button, until you hear the drum roll. Then wait another minute. If you have no luck yet, visit the web site of the manufacturer of the PC and look for newer (Windows 10 compatible) USB or chipset drivers for your computer and install it.

    *** TT CS official reply that worked for many with W10 issue ***

    Close MyDrive Connect completely:
    If your navigation device is connected to the computer, disconnect it.
    Click the MyDrive Connect icon ( or ) in the Windows notification area or Apple menu bar and then select > Quit
    Uninstall MyDrive:
    Click on the Start button and go to All Programs › TomTom › Uninstall TomTom MyDrive
    Alternatively you can use Add or Remove Programs in the Contol Panel to remove TomTom MyDrive Connect.
    Remove the application file:
    Press the Windows logo key +R to open the Windows Run dialog
    Type %localappdata%. Click OK.
    You will see list of folder. Find and open TomTom folder
    Delete HOME 3 folder.
    Delete the MyDrive Connect folder from: C:\Program Files (x86) (if still present)
    Delete the TomTom folder from: C:\Users\[username]\AppData\Local\ (USERNAME - It is the user name which you use to login to Windows )
    Delete the TomTom folder from: C:\Users\[username]\AppData\Roaming\
    Delete every file and folder from: C:\Windows\Temp\ (in case some files can't be removed, reboot the PC and retry)
    Restart your computer.

    Re download a new installer from http://www.tomtom.com/mydrive (I recommend you to use the Google Chrome while downloading the installer)

    Now install MyDrive Connect with the newly downloaded installer.

    After the installation process of the new MyDrive application completes successfully, please restart your computer. Now, check if the application is able to connect to your device properly or not.

    *** For further troubleshooting tips, please see below ***

    PLEASE NOTE:

    - It is very unlikely that one would have to do these all, it is usually one of the below mentioned possibilities

    - As in IT Crowd: Have you tried to turn the computer off and on again? :)

    - Try to add MyDrive Connect to the exclusion list of your antivirus and firewall (or disable those temporarily)
    - Make sure that your computer is not going into stand-by or similar (this shouldn't happen with the latest MyDrive Connect)
    - Clear the cache before each update attempt. Also could do a soft reset before and after the update
    (http://uk.support.tomtom.com/app/answers/detail/a_id/6965/)
    - Make sure you have all the latest updates and hotfixes/patches to your OS (not only the mandatory ones, but the optionals too)
    - In case the device looks like hung during the update or the counter stopped (or not visible at all), just leave it.
    Most probably it will be fine in a few minutes (or within a couple of hours, in case of installing large maps)
    - Check your network connections, make sure that the TT's network adapter is enabled
    - Try to uninstall and re-install the MyDrive Connect application (best to use Revo Uninstaller to remove)
    - Try to use a USB port on the mainboard, rather than a USB hub (desktop PC)
    - Try to change the port to 5000 (or 5001) in MyDrive Connect's settings
    - Try to run the MyDrive Connect app as administrator
    - Sometimes disabling caching large files helps too
    - It is worth checking the USB power saver settings

    - Any further issue: Try it on another PC, try it with different USB lead...the shorter the better (below steps are Windows specific)
    - Whilst the device connected, remove the drivers from the Device Manager (Windows/Control Panel), DELETE the drivers
    - Remove the MyDrive Connect application and run CCLEANER (will remove your history, cookies, etc by default)

    - At the moment certain USB3 port looks like incompatible with the TT devices (those are usually coloured blue on the PC).
    Could try BIOS update on the PC or enable "Legacy mode" for the USB ports in the BIOS (for further instructions, look for the user manual of your PC/mainboard)
    - Don't use the magnetic mount whilst updating, connect the micro USB directly into the device
    - Disable any network monitoring software
    - Update one item at a time, don't select all.
    Best order: NavCore/software - Map - QuickGPSfix - Speed Cams - Map Share Corrections (this is the smallest but longest in some cases)

    Certain Mac versions (10.10.2, 10.10.3 10.10.4 and 10.10.5) have USB issues, but there is an official fix available, provided by Apple.
    The latest version of MyDrive connect is not compatible with Windows XP SP2 and below, make sure that you update to SP3 and install ALL the other updates.
  • gioconsgiocons Posts: 4 [Apprentice Traveler]
    Hello,
    thanks, I'm not sure I have followed the instructions coirrectly as my PC Language is italian I have saved the screenshots in a Word file but I cannot attach here. In any case the problem is still there.

    Have a good day!

    Gio
  • mg10c2mg10c2 Posts: 3 [Neophyte Traveler]
    hi,

    I tried the above solution but it did not work.


    I have a tomtom start 25. I use Tom tom MyDrive Connect to update it. I have windows 10 operating system windows firewall and malwarebytes installed. In normal circumstances I can never get MyDrive to connect to my tomtom device. It recognises that it is there and shows a circular spinning connecting icon (which dissapears when the tomtom device is unplugged and says start25 disconnected then).

    So I tried successfully by restarting windows in safe mode with networking ( right click windows icon - bottom left of screen select run type msconfig (into the open ... box) select the "Boot" tab click "Safe Boot" - it defaults to "Minimal" but change minimal to "Network". Restart the device in safe mode. Run MyDrive and connect tomtom start and it will update.

    It takes about 40 minutes to update the device, My concerns would be that the firewall and antivirus software in safe mode during that 40 minutes may not be as effective as normal.

    Maybe someone who knows more would advise if this is a safe way to do the update
Sign In or Register to comment.

Who's Online37

Elchdoktor
Elchdoktor
Merxmir
Merxmir
Oskar-2
Oskar-2
RoadRider
RoadRider
+33 Guests