FAQ - MyDrive Connect troubleshooting tips



  • Spycam
    Spycam Registered Users Posts: 4
    Master Traveler
    LAURE123 wrote: »
    Hi @Spycam

    For a connection problem or driver installation by Windows10 often a clean installation with a fresh copy of My Drive Connect (MDC) solves the worry.

    You can try to do this:
    With your device Not connected to the PC:
    1/ Uninstall MDC, accept the removal of downloads in the popup window.
    2/ "Restart" your PC (Not Shut down or Sleep)
    3/ Download and install the last version MDC, take it here:
    - On this page, at the bottom, the green button "Download for Windows®":
    - In the popup window, keep ticked "Download updates on my computer (recommended)"
    4/ "Log in" with your email and password in MDC.

    Do a Soft Reset of your Devise:
    Device Not connected to the PC and turned on with full battery, press and hold the On/Off button until you hear the drum sounds. This can take 30 seconds or more. The device restarts. If you see a black screen with white text, hold down the button until you hear the drum sounds.

    Only after that, connect your TomTom device to the PC. Wait if necessary while Windows 10 installs the TomTom driver.

    FAQ for Windows 10 (also valid for 8.1 and 7)


    Thanks so much for responding Laure123.
    tried this TOO and guess what?STILL no damn luck.
    This crap software really needs to be recreated and done porperly,after all its just an update program so why the hell do we the paying customers have to go through all this shite to try and get it to work?
    Ok TomTom, when i bough this device you entered into a contract to supply me with lifetime updates for maps and Speed cameras, dont you think that your company is breaking this contract by us not being able to damn welll down load these updates?
    you have my email address so please advise me HOW the effin hell i can update my device and stay uptodate!!!!!
    i really am sick of the amount of time i have wasted on this friggin piece of crap!
  • MikeElliottUK
    MikeElliottUK Registered Users Posts: 1
    New Traveler
    Another issue that I regularly bumped into when updating my device, it kept disconnecting every few seconds. The USB selective suspend power setting seems to be the issue as described here https://discussions.tomtom.com/en/discussion/1114556/disconnection-during-update. Would be a good idea for TomTom to update their MyDrive Connect software to detect this and alert the user. I spent hours struggling to update my device before finding this tip.
  • LAURE123
    LAURE123 Posts: 1,632
    Hi @Spycam

    You are on a users forum... If you want direct contact with an official TomTom agent, it's up to you to do the action ... by phone, chat or with the web link.
    Since you do not specify your country of residence, the contact list by phone:

    Support link UK for Tchat and email, you can change the country at the bottom of the page:

    Last night, there was a general problem with TomTom servers. Today everything works. I use my personal computer under Windows 10 and I was able to do all my updates on my 2 devices. I have also installed a map to check the process. TomTom software works, but some PC configurations can cause problems. Some thoughts ...

    Retry the process "clean installation" completely, but perform the Soft Reset with your TomTom device Connected to the PC to force the detection and installation of the driver.
    - Device turned on, press and hold the On/Off button until you hear the drum sounds.

    Our devices are identified as Network Adapters (removable), not USB devices. Check if the TomTom driver is activated.
    With your device Connected to the PC:
    In your PC ==> Right click on the Windows10 "Start button" /DeviceManager/Network Adapters/ you must have a "Remote NDIS compatible device" (or "TomTom")/ Right click on it, check if it's activated:
    - If you see the choice "Enable", click on it to activate your driver device.
    - If you see the choice "Disable" it's OK, you have nothing to do.
    - If you found an "unknown device" or a "USB device" with a problem (yellow triangle) removed it. You will have to redo the procedure "clean installation".

    Some firewall (the VPNs too) can block the connexion with MDC. Do an exception for MDC, this file:
    C:\Program Files (x86)\MyDrive Connect\TomTom MyDrive Connect.exe

    Check also if your firewall allows connection with your device, "trusted network".
    If you use the Windows firewall, look at this link "how to do", add TomTom MDC for "private" and "public" network.

    Otherwise if alas it still does not work, contact TomTom Customer Support directly for more help.

  • Shrimper19
    Shrimper19 Registered Users Posts: 2
    Apprentice Traveler
    edited January 2020
    I am trying to update my GO 5000. I keep getting messages that the servers are busy, or that there's no internet (when there is - everything else is working fine). I keep being told to reconnect my device even when it's connected. So far, I have:
    • Uninstalled and reinstalled Mydrive using the Windows uninstaller
    • Uninstalled and deleted all extraneous files using Revo
    • Rebooted between each uninstall and reinstallation

    Currently, it is apparently downloading the updates but then can't transfer them to the device so it starts again. It's in a continuous cycle of downloading without ever actually accomplishing anything.

    I'm using a W10 64-bit operating system with a consistent and strong internet connection.

    I'm not even going to try downloading the maps; there's no point. I guess I'll just have to keep using last year's.

    What is the point of giving me lifetime maps if the app is so useless that I can't actually ever download them with ease. Every time I try and download updates I go through pretty much the same rigmarole (though this is worse than in the past). Isn't it time TomTom actually produced an app that worked? My device is probably coming to the end of its life; I like TomTom devices and would be OK with getting another, but this inability to update the device quickly and easily may be a reason not to.
  • thezhen17
    thezhen17 Registered Users Posts: 4
    Apprentice Seeker
    Other issues:
    Connecting device disconnects router
    (Thanks, mvl!)

    Power settings (Thanks, lsz45!)

    The above link doesn't work, plz check
  • Johnh510
    Johnh510 Registered Users Posts: 21
    Master Traveler
    I have a go 5100 which used to connect to MDC in windows 10, but it no longer does.
    (Bearing in mind windows 10 is forever updating itself, and my pc's are all as updated as they will go)
    I have tried several different leads, three different computers, multiple uninstalls and reinstalls and cannot make the go 5100 connect: there are no devices in the network adapters.

    This morning I found my old start 25, and made it connect (using MDC) at the second attempt - first time it appeared as tomtom! in the network adapters, one restart, without reinstall it sorted itself out.

    So the computer as configured/updated, and lead the usb I am currently using works, but the go 5100 doesn't connect.

    Any suggestions? bearing in mind most of the stuff I've found here is about very much earlier versions of windows 10.
  • Johnh510
    Johnh510 Registered Users Posts: 21
    Master Traveler
    Hi douglap,

    Yes, I have tried that, and more besides.

    There is no network adapter to uninstall when trying my go 5100.
    When I logged on with my old account and tried my old start 20, the driver software was downloaded and installed.

    The computer(s) do not "see" the go 5100. And I've tried several different (TomTom) leads.

    I did consider doing a factory reset on the go 5100, but it still works,... If I can't connect it the thing is then a doorstop/landfill.

    My feeling is it's a windows problem, but I have no access to Apple stuff, and you don't support Linux.


    Only more ideas?
  • phil1579
    phil1579 Registered Users Posts: 5
    Apprentice Seeker
    I had the issue where the tomtom starts the update then disconnects after 10-30 seconds telling me to reconnect the device and also freequently telling me I had no internet connection - this was with MyDriveconnect and a start25 updating from a brand new HP envy PC. There is lots of help above on how to do most of these steps so I will not repeat it. I read several posts here and elsewhere on the subject and this is what I did to fix the issue including all the steps - your mileage may vary and more than one of these steps may be unnecessary - I just thought to write down what I did that finally worked after 3-4 hours of trying would be a useful idea.

    1) do the registry fix to enable turning off of USB selective suspend. it seems that MS hide this for all new PCs/WIndowsOS
    2) disable USB selective suspend ( see other posts here and elsewhere )
    3) in device manage go in and find the USB root hub and extensible Host controller. for these do right click to get properties and turn off any power management options.
    4) in device manage I deleted (uninstalled) the tomtom network device
    5) then I uninstalled the drive connect software completely deleting any data as well as the Software.
    6) restart the laptop...
    7) factory reset the tomtom - I suspect I did not need this but did it anyway
    7) reinstalled the tomtom software, using a brand new downloaded version from the web site ( which as far as I can see is exactly the same version as the one I uninstalled )
    8) started up the drive connect and logged in again and as soon as the tomtom was connected
    9) restarted the laptop with the tomtom connected and the software saying it was able to provide an update. - this was a tip from a german web site that I read elsewhere and I suspect was the only thing that actually fixed the problem. As an IT manager with 30+ years experience and talking to several colleagues I have no idea why this would work but trust me it did seem to...
    10) ran the update successfully.

    As I say your mileage may vary, but this convoluted set of steps saved me from the need to buy a brand new tomtom for my wife's trip tomorrow.

    Ah yes and all the time it was updating I kept nudging the mouse to stop the laptop going into any sort of sleep - 90min in front of the PC doing nothing but move the mouse just in case :-)
  • tollcross
    tollcross Registered Users Posts: 27
    Prominent Wayfarer
    To solve many update problems...servers busy etc...you have to remove My Drive connect completely....download for free Revo Uninstaller. and uninstall My Drive connect....this program removes all remnants of a program....after uninstalling reinstall My drive connect
  • Locouarn 2
    Locouarn 2 Registered Users Posts: 7
    Apprentice Seeker
    Clearly, noone talk about the request GSM cover to get MDC working ! Seriously, do you imagine that every place in the world is covered by a GSM service ? At home, I must go far in the garden to get someting, and with a power supply and an ethernet cable. Doing that, I can hope to get an updated map after a dozen of hours... That's just scandalous. Tomtom was a good brand for GPS, with this GSM technology the brand is dead.
  • vidmantas
    vidmantas Registered Users Posts: 5
    Apprentice Seeker
    edited April 2021
    Hi, my TOMTOM 6000 LTS shuts down while driving and restarts in ten minutes. Maybe anyone knows where the problem is.

    Mod edit: Machine translated (Lithuanian)
  • DJSheridan
    DJSheridan Registered Users Posts: 128
    Sovereign Trailblazer
    Do you have an SD Card inserted into your unit?

    If your unit is particularly slow whether switching on, booting up or just generally in trying to get started on planning a route, etc. then do the following:
    1. Depending on map if you only drive in a certain country (or countries) then connect to My Drive Connect
    2. Scroll to Maps and check where your map is loaded - if on the SD Card then move it to the internal memory instead
    3. If point 2 not possible due to memory size - check if you actually need all the map (like all Europe, etc.) and if you don't then select just the part of the map you need
    4. Update and check and you should see the map has now moved to the internal memory - which should make the unit work faster as it does not need to access the SD Card
    5. Just use the SD Card for other secondary maps you might use
  • Johnh510
    Johnh510 Registered Users Posts: 21
    Master Traveler
    I'm back again. My GO5100 is still working, but the maps are now (Europe 07/2019) out of date.

    So I tried again to connect

    I downloaded My Drive Connect onto a newly setup from scratch (old) Windows 10 laptop,
    but the computer doesn't "see" the 5100, although the 5100 powers up.

    I eventually noticed that My Drive Connect thinks my GO5100 is a GO5000

    Could someone with the knowledge/rights/and the time please update my account records to
    show my device as a GO5100 and keep the serial number the same, please?


    John H
  • Willy875
    Willy875 Registered Users Posts: 7,293
    Elite Voyager
    Go 5000/Go 5100 it's the same devices in my opinion if you can't download new maps it means you don't have enough space to install it

    solution add an SD.
  • Johnh510
    Johnh510 Registered Users Posts: 21
    Master Traveler

    I can't update maps because the 5100 doesn't connect to the computer.

    The memory is not the issue:

    5100 Memory is
    6.48 GB Internal memory
    8.61 GB Memory card.

  • Johnh510
    Johnh510 Registered Users Posts: 21
    Master Traveler

    I tried all the options a long while ago and drew a blank - I decided not to "factory reset" it as the last option as it works, and if the reset failed it would brick my 5100 - I think I'll just continue to use it until it fails as it is primarily used for traffic info these days.

    Your link above opens briefly on an interesting looking page, but for some reason eventually ends up back at


    Presumably tomtom don't want your link used anymore.

    Thanks for your efforts.

    John H
  • Willy875
    Willy875 Registered Users Posts: 7,293
    Elite Voyager
    The link works delete your cookies.

    Have you tried with another cable?
  • Johnh510
    Johnh510 Registered Users Posts: 21
    Master Traveler
    Thank you. The link works in the pristine Windows 10 box I am trying was trying to update the 5100 with, unfortunately I tried the link in my work-a-day Linux box with multi-account containers in Firefox.

    Anyway, I have tried another cable, but nothing appears in the network adapters section of device manager, mydrive connect has an entry in the firewall, and I'm still where I was in January 2020 ago up this same thread.

    I will draw a line under this and stop trying the same things and expecting a different result, that way madness lies.


    John H