New MyDrive Connect for Mac OSX available for download — TomTom Community

New MyDrive Connect for Mac OSX available for download

MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
edited January 2019 in News and announcements
Hi all,

In anticipation of the release of Mac OSX 10.10.11 El Capitan, we’ve just released a new version of MyDrive Connect for Mac OSX 4.0.5.2428.

Please note, that this is an optional update. If you’re using Mac OSX 10.10.11 El Capitan you should update to this version.

Drive safe! :D

Cheers, Mikko
«1

Comments

  • the-civviethe-civvie Posts: 545 [Apprentice Traveler]
    Great stuff. Off to fire up the Mac
  • Stu69Stu69 Posts: 7 [Legendary Explorer]
    Excellent - many thanks!

    I've just updated it and have now successfully connected and updated my TOMTOM (GO Live 820).

    To upgrade just fire up the existing MyDrive app and a pop up will appear in the bar at the top of the window to update.

    Happy days!
  • jasonbuckleyjasonbuckley Posts: 4 [Master Traveler]
    I've installed the latest version 4.0.5.2428 and am running El Capitan. Can't get the mac to recognise that the device is connected. Have spent a lot of time faffing around with this and would really appreciate some guidance from TomTom that works.
  • the-civviethe-civvie Posts: 545 [Apprentice Traveler]
    I've installed the latest version 4.0.5.2428 and am running El Capitan. Can't get the mac to recognise that the device is connected. Have spent a lot of time faffing around with this and would really appreciate some guidance from TomTom that works.

    Did you restart your Mac afterwards. I had to restart my Air for it to work.

    Does the TTR 400 show that it is connected to a PC?
  • jasonbuckleyjasonbuckley Posts: 4 [Master Traveler]
    Thanks. I've restarted it a couple of times. Still no connection.

    My Tom Tom is a 1050 I think (says "GO MODEL 4CR52"). It says it's charging the battery but other than that, nothing.
  • the-civviethe-civvie Posts: 545 [Apprentice Traveler]
    Have you tried a different USB cable. I t know that model but both my TTR and the wife's TomTom when connected have almost the same screen as below
  • jasonbuckleyjasonbuckley Posts: 4 [Master Traveler]
    Thanks. I need to order a new cable for another TomTom so I'll try that out. Maybe only the power is getting through and not any data.
  • the-civviethe-civvie Posts: 545 [Apprentice Traveler]
    Let us know how you get on. Try any other micro USB cable, it should work,
  • JimveeJimvee Posts: 3 [Neophyte Traveler]
    I have the same issue as jasonbuckley - since running OSX 10.11, my TomTom Live 1005 won't connect. Also on 4.0.5.2428, I have the original cable, I've rebooted the Mac and I've tried deleting TomTom from the Network as suggested by Support. The next stage was supposed to be re-adding TomTom but it's not there as an option. Help?
  • Rich MolesRich Moles Posts: 1 [Apprentice Traveler]
    having a real trouble uploading POIs to my go 50 tried everything. new tom-tom and getting a bit peed off any suggestions I've been all over the internet
  • Rob JLRob JL Posts: 1 [Apprentice Traveler]
    Same issue here as jasonbuckley and Jimvee - no connection with my TomTom Go Live 825 on my iMac running OSX 10.11 (El Capitan). Have installed version 4.0.5.2428 of MyDrive connect. I've also rebooted the Mac. Didn't help. Expect soon a solution from TomTom!
  • eoneon Posts: 21 [Outstanding Explorer]
    hi all

    little confused i have a uconnect 5" do i need mydrive or TT home or both
  • jasonbuckleyjasonbuckley Posts: 4 [Master Traveler]
    I have two Tom Toms, both GO 1005 and seemingly identical. One worked in the end (with one account) and one won't work, with the other account. The best explanation I have found is that there is an issue with USB 3.0 - it isn;t quite as backwards-compatible as it is supposed to be. The device that doesn't work is slightly older, so perhaps between batches Tom Tom added a fix that allowed the new device to work with the USB 3.0 on my Mac. I am going to try updating the older TomTom on an older computer that doesn't have USB 3.0.

    It's really lousy that Tom Tom doesn't have better information about known problems like this.
  • Stu69Stu69 Posts: 7 [Legendary Explorer]
    For what it's worth, as per my earlier post, I did get my GO LIVE 820 (approx. 3yrs old) to update on my MBPr (2014) which also has USB 3.0 -
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi all,

    Thanks for reporting your issues!

    For MyDrive Connect troubleshooting tips, please see this FAQ.

    Cheers, Mikko
  • robsterukrobsteruk Posts: 1 [Apprentice Traveler]
    Where do I go to download new version of MyDrive Connect for Mac OSX 4.0.5.2428.
  • Stu69Stu69 Posts: 7 [Legendary Explorer]
    as per my earlier post, to upgrade just fire up the existing MyDrive app and a pop up will appear in the bar at the top of the window to update - well it did for me anyway....
  • JimveeJimvee Posts: 3 [Neophyte Traveler]
    Click 'download for Mac' at the bottom of this page:

    https://www.tomtom.com/en_gb/mydrive/
  • JimveeJimvee Posts: 3 [Neophyte Traveler]
    Mine now works!!

    TomTom support advised rebooting my Mac with TomTom connected. This seems to have resolved the issue for me.
  • AggravatedAggravated Posts: 2 [Apprentice Traveler]
    I updated the MyDrive as prompted and now it is showing my VIA 1435 as a VIA 130. And I can't update my maps that I just purchased for it and it won't recognize that I have an SD card installed. I'm getting very annoyed trying to update this.
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Aggravated wrote:
    I updated the MyDrive as prompted and now it is showing my VIA 1435 as a VIA 130. And I can't update my maps that I just purchased for it and it won't recognize that I have an SD card installed. I'm getting very annoyed trying to update this.

    Can you try again as we released yesterday a server side update to MyDrive Connect and it looks a bit different now.

    For further MyDrive Connect troubleshooting tips, please see this FAQ.

    Cheers, Mikko
  • AggravatedAggravated Posts: 2 [Apprentice Traveler]
    I uninstalled and reinstalled the MyDriveConnect app from my Mac. When I open the MyDriveConnect it is still showing the wrong device. Everything is still as it was yesterday. I've gone through your FAQ document again and it wasn't helpful. In the drop-down for the app icon in my task bar, it is showing the correct device but when I open the app, it is showing the wrong device. (See the screenshot I posted previously.) I've tried downloading the app to my PC but I get the error that the PC doesn't recognize my device. It suggested I try another USB cord or port and if that doesn't work, replace the device. It didn't work. I'm getting a bit more than just aggravated and if this doesn't get resolved soon, I may very well have to replace the device. And I highly doubt it will be the same brand.
  • Stuart_RStuart_R Posts: 2 [Apprentice Traveler]
    I am running OSX 10.10.5
    Just installed MyDrive Connect on my MacBook Pro.
    Connected my Go Live 825 Tom Tom.
    ! Not Connected.
    Disconnect.
    Restart.
    Start My drive COnnect.
    Plug in USB
    Not Connected
    Try different USB socket.
    Not Connected.

    So it appears the Software will not recognise the TT 825, even although it is actually being charged from my macbook!

    Any ideas?
  • Mr PRTMr PRT Posts: 2 [Apprentice Traveler]
    Hi,
    I have not updated to El Capitan yet and currently using OS X 10.9.5. When I connect to My Drive connect it is saying there is a new update. Do i still update? The reason for asking after reading on forums etc and your reply, this update reads only for OS X 10.10.5. If i had not read any of this the update would be still showing and i would have updated and possibly end up with problems?
    Just a little confusing.
    For the moment i will not update till you reply.
    Thanks
    Paul
  • MikkoKMikkoK Posts: 23,905 Retired Community Managers and Staff
    Hi Mr PRT,

    Welcome to the forum!

    The updates are always backwards compatible so you don't need to worry about that :D

    Cheers, Mikko
This discussion has been closed.

Who's Online in this Category1

IMAPOI
IMAPOI