How to stop your device from killing your Windows WiFi network connection?

NiallNiall Posts: 10,521 Superuser
edited January 31 in MyDrive Connect
In the first place, your computer should be directly connected to your router, preferably via an Ethernet cable.
If you cannot directly connect and have to use WiFi, here is how to make sure that plugging in your device does not instantly kill you WiFi connectivity.
  1. Right click the network adapter in your task bar and select "Open network and sharing centre"
  2. Click "Change adapter settings" on the left side of the Network and Sharing Centre
  3. Right click your wireless adapter and go to "Properties"
  4. In the networking tab, click "Configure"
  5. Go to the Advanced tab and find "Disable upon wired connect" - make sure it is set to "disabled"

For the technically minded:-
Due to the USB/TCP bridge driver, the your device appears to the system as another Network Interface Card, it's the same (to the OS) as if you plugged the PC into a hardwired network.
Help others identify useful content :- - If someone posted something that was helpful? Click the Like button 👍

If someone answered the question you asked? Answer Yes to "Did this answer the question? Yes · No"

Comments

  • momistmomist Posts: 6 [Master Explorer]
    Hi Niall. Does this apply to all Windows versions please? I use Linux on my main PC and keep a 17 year old Win XP laptop for jobs like TomTom which don't like Linux.
  • NiallNiall Posts: 10,521 Superuser
    @momist

    If you can see each of the stages then it should work, it was tested on Win 7 & 8, Win 10 does does not seem to have the "Disable upon wired connect" operation but as I hand set it to be disabled, before I updated all seems to be OK
    Help others identify useful content :- - If someone posted something that was helpful? Click the Like button 👍

    If someone answered the question you asked? Answer Yes to "Did this answer the question? Yes · No"
  • Johnh510Johnh510 Posts: 15 [Outstanding Explorer]
    I thought I had read somewhere that TOMTOM have discontinued support XP, or are about to..

    I got a windows 10 tablet for use with TOMTOM, which was problematic due to USB power saving.

    The settings for USB power saving on battery powered Windows laptop/tablet/surface devices is hidden, and involves a registry tweak to reveal them, which TOMTOM won't publish for fear of a user breaking the Windows device with regedit.

    However, your mileage may vary.
  • DMC314159DMC314159 Posts: 45 [Prominent Wayfarer]
    Thanks Niall,
    Makes sense and will save me a lot of hair, as it means I will be able to use Win 10 as my fall back position on a Mac laptop while traveling now.
    David
  • NiallNiall Posts: 10,521 Superuser
    Help others identify useful content :- - If someone posted something that was helpful? Click the Like button 👍

    If someone answered the question you asked? Answer Yes to "Did this answer the question? Yes · No"
  • Navigator1964Navigator1964 Posts: 4 [Master Traveler]
    Thanks for the response. I am using an ethernet cable and I have wi-fi turned off. I would appreciate your further assistance. This problem only occurred after updated MyDrive loaded recently. Previously no problems.
  • josefin1josefin1 Posts: 1 [Apprentice Traveler]
    Here is how to prevent your Wi-Fi from turning off in Windows 10
    1:- Right click on “Start” icon positioned at the bottom left corner of your screen. Click on “Control Panel”.
    2:- On selecting the “Category View”, click on “Network and Internet”.
    3:- Now, click on “Network and Sharing Center”.
    4:- In the left sub menus, click on “Change adapter settings”.
    5:- Right click on your Wireless Network Connection (Wi-Fi) & click on “Properties”.
    6:- In the “Wireless Connection Properties” window, click on “Configure”.
    7:- Click on “Power Management” tab.
    Source:- http://merabheja.com/prevent-your-wi-fi-from-turning-off-in-windows-10/
Sign In or Register to comment.

Who's Online58

DougLap
DougLap
helmet48
helmet48
levitt
levitt
TomDone
TomDone
YamFazMan
YamFazMan
+53 Guests