Formatting a microSDHC card — TomTom Community

Formatting a microSDHC card

For NAV3 devices you have the application software upgraded to latest version 12.071.
For NAV4 devices you have the application software upgraded to latest version 15.401.
For a full list of compatible memory cards:-
for UK devices see this FAQ
for USA devices see this FAQ
for Australian devices see this FAQ

The ideal card is a Sandisk 16Gb class 10
  1. Insert card and perform a soft reset by holding the on/off button firmly in until a drum-roll is heard and then releasing it.
  2. When the device restarts, that is when it will recognize the card and ask if it can format it, to which you answer yes.
  3. If it fails to format the first time, introduce the card to your computer and perform a full FAT32 format on it and restart from 1.

After the card has been formatted by your device it will not be readable in your computer, as TT use their own proprietary file format.

Location of possible card slot38e4fd56-5b6d-47ea-a43f-18d9ea69a199.jpg
or see this video:-


  • ZsoltZsolt Posts: 36,012
    Good stuff Niall. However I wouldn't even go as far as 16GB. Maybe for the NAV4 devices with world maps if one wants to have EU and US together, plus some others. Otherwise I would go with 8GB for NAV3 and for most users of NAV4. Even with the world maps, as I doubt there are tons of people in the need to have all the maps on the device all the time.
  • franko10afranko10a Posts: 29 [Master Explorer]
    Thank you Niall, helpful as always.
  • afcsafcs Posts: 3 [Apprentice Traveler]
    I have the same problem with a GO 6100 and a SunDisk 32 GB SD HC I
    Does your procedure works with this model?
  • NiallNiall Posts: 10,957

    As far as I know it should, but if not you might have to create two 16Gb partitions and format each one as FAT32
  • KakdeKakde Posts: 118

    The procedure to format a memory card is exactly as Niall wrote.

    @afcs 32 GB microHDHC is supported by your Go 6100 device. However a 16 GB card would suffice for the time.
    Your device has internal memory of 8 GB. You only need a memory card if you want to add European or the US maps on the device.

  • BEARBUG3BEARBUG3 Posts: 2 [Apprentice Traveler]
    I have a Mac laptop.
    What is FAT32?
  • NiallNiall Posts: 10,957

    FAT32 is Microsoft's Windows file format using a 32 bit File Allocation Table

    As found elswhere:-
    "Format USB Key on Mac OS

    Mac OS users can format their USB keys into the FAT format in a few simple steps.

    Open Disk Utility and select the icon of the USB key on the left side of the window. Then click on the Partition tab in the right window.

    Replace Current with 1 partition and then click on Options > Master Boot Record (MBR).

    Click OK to confirm the selection. Then, back in the main window, choose the MS-DOS (FAT) option. Give a title to this volume, and finalize by clicking on Apply."
  • AghileraAghilera Posts: 4 [Apprentice Seeker]
    Thank you so much you were very useful thanks
  • Becky_UKBecky_UK Posts: 3 [Neophyte Traveler]

    I've bought me a new SanDisk 8GB MicroSD card for my 5150. I'm a Mac user, so followed the above instructions to format it to FAT, but my satnav still isn't asking if I want to format the card. I've tried soft reset but no response.

    When I went into Disk Utility, the "partition" option wasn't available (greyed out) so instead I did an "erase" which enabled me to choose the MS-DOS FAT option... when i tried disk utility again it recognised the card as formatted as FAT.

    How can I get my 5150 to prompt me to format the card so it can take further maps?

  • dhndhn Posts: 33,350
    Was the SanDisk card bought in a store or someplace like eBay?

    Support Monday:

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • YamFazManYamFazMan Posts: 19,648

    I always use the program SD Former v4 from the SD Association

    It's available for Windows (Works on Win 10) and the MAC

  • NiallNiall Posts: 10,957

    Did you do the first item

    Insert card into your device then perform a soft reset?

    A soft reset :- with your device charged for at least 2Hrs "OR" have the device plugged into a power supply; press and hold your on/off button until you hear a drum-roll sound (or the TomTom hands symbol appears) then release the on/off button.
  • BeauBlueBeauBlue Posts: 3 [Neophyte Traveler]
    So far none of this has worked for me, and my case escalated to tier 2 Tom Tom tech support. I've tried four different microSDHC cards and had the same unfortunate results with all. Yesterday I bought a brand new 16GB class 10 SanDisk Ultra Plus. My Via wouldn't recognize it even after performing the full FAT32 format on my PC. When I am logged into the Tom Tom desktop My Drive software and go to MY CONTENT and try to install a new map it asks I free up space on my device. At this point, for a few seconds, I will see the status change to "reading your memory card" and then it switches back to "insert a memory card." For some reason, it's just not making the connection. I asked tech support if perhaps 16 GB was too big, or if Class 10 was too fast. They confirmed this is the correct card specifications and that it should be working. I fear that my device is faulty. Any workaround suggestions others might offer are appreciated. Likewise, I will provide and update once contacted by tier two support.
  • Becky_UKBecky_UK Posts: 3 [Neophyte Traveler]
    I bought the card in Argos, so I'd say pretty reputable store.

    Yes I performed the soft reset with the card in the slot.
  • Becky_UKBecky_UK Posts: 3 [Neophyte Traveler]
    Has anyone got any further suggestions? It seems that the satnav just doesn't seem to notice that there's a memory card in the slot... I only have until this weekend to get it sorted so if anyone has a suggestions I'd be dead grateful.
  • dhndhn Posts: 33,350
    Maybe support has some ideas:

    United Kingdom
    02079 490 134
    Monday - Friday: 9:00 a.m. to 5:30 p.m.
  • yesitsmineyesitsmine Posts: 15 [Outstanding Explorer]
    From reading all the steps you have taken and still you cannot connect a sd card, You are most likely going to be told all the old stuff i.e. shut down computer, restart your tom-tom eat eat.
    I would be very surprised if this work.
    As normal operation would be insert you SD card and turn on you tom-tom and at the on screen prompt press yes to format card.
    Any SD card should work from a 8GB 16GB 32GB 64GB and more but in most cases 16GB would be fine.

    So If you have done the resetting you tom-tom and computer? have you tried it on another computer starting a fresh format of the SD card to fats32 then putting it in your tom-tom? If it still will not see any of the SD cards you may have to try, then I would say the trouble you are having is not with the SD cards but the software installed on your tom-tom is the problem.
    The only thing I can think of that may fix this would be a full factory back up and delete and install, so that your tom-tom will have a full fresh install of software.
    If you look in the tom-tom help pages you will find how to delete your tom-tom device and factory restore your unit.
    The only reason I would say try this is that i was having trouble with my Tom-tom and tried every thing I was told to do from help of Custer service and from the forum and nothing worked, I read all the help pages I came across the factory restore, delete every thing off of my tom-tom and format it then down load and install from the internet a fresh copy of the software and install your maps from your back ups.
    Aft I did this my tom-tom worked fine and seemed to run a lot better. But that may just be thing its running better.
    Have a good read of the factory reset option if you have tried every else then that may be the only thing you can do.
    Hope you get it work
    Best of luck
  • NiallNiall Posts: 10,957
    For those using Mac computers, see this comprehensive FAQ by user basmeyer
  • insanitybrittinsanitybritt Posts: 2 [Apprentice Traveler]
    how did you factory reset?
  • insanitybrittinsanitybritt Posts: 2 [Apprentice Traveler]
    Well I can't get it to turn on, I can't tell if it's charging, and it won't register to my computer via USB. Is there a way to enter serial and model # on mydrive and reset that way? My warranty ended I think, so I'm not sure what to do
  • NiallNiall Posts: 10,957

    In that case talk through your problem with a Customer Services agent

    CS United States
    Monday - Friday: 9:00 a.m. to 8:00 p.m. EST
    Saturday: 10:00 a.m. to 6:00 p.m EST
  • JaySheppardJaySheppard Posts: 6 [Master Traveler]
    I guess my original query sparked a lot of concerns out there in TomTom land.

    I inserted a new 16 GB SDHC 10 sandisk. The ONLY way I can get the device (Via 1435) to recognize it is to hold it down in its slot. If I release it it does not recognize it. It juts out of the slot maybe 2-3 mm when not pressing on it. I saw the comment from YESITSMINE. Suspect it is same issue. Micro disk does not seem to be fully seated in its slot. When I press down on it, it goes into slot another mm or so, but as soon as I take any pressure off, it bounces back out to the 2-3 mm position. I did get it to format the disk (took a few seconds) according to your first reply instructions (Very helpful!), but only while holding the disk down. MyDrive Connect (MDC) kept chirping as I pressed or released the chip. At one point MDC did indicate I had an empty memory card with 15.....MB memory available, but when I released pressure it went to zero.

    What gives??
  • dhndhn Posts: 33,350
    As you push the microdisk in the slot, try applying pressure backwards as well as down and see if it clicks in then.
  • JaySheppardJaySheppard Posts: 6 [Master Traveler]
    MANY MANY THANX!!! Why I did not figure out that simple cure....!!??????
Sign In or Register to comment.

Who's Online in this Category0