Is MyDrive Connect compatible with Windows 10? - Page 4 — TomTom Community

Is MyDrive Connect compatible with Windows 10?



  • ZsoltZsolt Posts: 36,011
    Kaspersky is well know on W10 having issues. Also the Avast antivirus can cause trouble on W10 too (not with TT, but in general). It can block W10 to start up at all. I use Eset Smart Security (and previously Eset Nod32) since 2003 or 2004 and never had a single issue with it. Starting from XP to W10. Fastest, best antivirus one can buy. Doesn't require even to put TT on the exclusion list.
  • Mandraghe51Mandraghe51 Posts: 4 [Master Traveler]
    Hello. Sorry for my terrible English. More than 1 month ago I upgraded my 3 PCs to Windows10. Starting from today I have a new TOMTOM VIA 135 and it is impossible connect it to my laptops. I tryed the solutions that I found in TOMTOM support but without result: MyDrive Connect it is unable to connect to my laptops (I tried all my 3 laptops). In addition I checked the compatibility of MDC with WIN10 and the result was: "Not compatible".Please see attached documents --> 28490c18-a3e0-4d64-b0fe-64a0f442fcf5.png4c123fb5-7e1c-4902-8bb4-8540f6e4802f.pngIn addition if I connect to one of these laptops my old GO 730 via TOMTOM HOME everything is working. My be TT have to release a new driver ? Thanks.
  • ZsoltZsolt Posts: 36,011
    They don't have to release new driver and your PC can clearly see it, as you have it in the device manager. Something is blocking MyDrive Connect to access the device. Which antivirus do you use? Do you have any network monitoring software installed?
  • Mandraghe51Mandraghe51 Posts: 4 [Master Traveler]
    Hello. Thanks for your answer. I don't think it is a problem of antivirus because if I connect to the same PC another TOMTOM model/device: TT GO 25 and everything is working well and I'm able to update the TT GO 25. About TT VIA 135 I did another check in the event of the OS-WIN10 and for TT VIA 135 there was the message: "impossible to migrate the USB device ..." ( fb09b201-515f-471a-95c7-0bc0db0b3a93.png ).
    After this error I tried to uninstall/install again the TT VIA 135 but there was the same error.
    Please see the attache jpg file.
    My AV is McAfee Total Protection
  • Mandraghe51Mandraghe51 Posts: 4 [Master Traveler]
    Hello again. Here below you can find the detail of the error occurred 15 minutes ago when I tried to reinstall the TT VIA 135.
    The error message is: not possible to migrate the device. I tried the same check on two different PCs (booth with WIN10) and the error was the same and on booth these PCs TT GO 25 is working well.
    Livello Data e ora Origine ID evento Categoria attività
    Errore 20/10/2015 06:53:40 Microsoft-Windows-Kernel-PnP 441 Nessuna "Impossibile eseguire la migrazione del dispositivo USB\VID_1390&PID_5454\BP2385D08960.

    ID ultima istanza dispositivo: USB\VID_12D1&PID_1520\5&c20c667&0&1
    GUID classe: {4d36e978-e325-11ce-bfc1-08002be10318}
    Classificazione migrazione: 0xF000FFFFFFFFF032
    Presente: false
    Stato: 0xC0000719"

    At the other side, on the same PC connecting TT GO 25 everything is working well. Thak you in advance.
  • ZsoltZsolt Posts: 36,011
    Have a look at these:

    "Official" TT tips:

    If these didn't help, then try some of these:

    *Always make sure that you are logged in with the correct account. One device, one account*

    *** for Windows 10 users ***

    If you have just updated recently, you might run into trouble with TT (and other devices too). Disconnect the device, uninstall the MyDrive Connect support app with Revo Uninstaller, restart the PC, download the latest MyDrive Connect installer from and install it again. Also in Windows 10, click on the "Start" menu (Windows icon in lower left corner), click on Settings and then Updates. Look for further updates, download and install those. Restart the PC, wait a minute or two, until everything starts up. Connect the device. If it is not recognised yet, keep it connected and then press and hold the ON button, until you hear the drum roll. Then wait another minute. If you have no luck yet, visit the web site of the manufacturer of the PC and look for newer (Windows 10 compatible) USB or chipset drivers for your computer and install it.

    *** TT CS official reply that worked for many with W10 issue ***

    Close MyDrive Connect completely:
    If your navigation device is connected to the computer, disconnect it.
    Click the MyDrive Connect icon ( or ) in the Windows notification area or Apple menu bar and then select > Quit
    Uninstall MyDrive:
    Click on the Start button and go to All Programs › TomTom › Uninstall TomTom MyDrive
    Alternatively you can use Add or Remove Programs in the Contol Panel to remove TomTom MyDrive Connect.
    Remove the application file:
    Press the Windows logo key +R to open the Windows Run dialog
    Type %localappdata%. Click OK.
    You will see list of folder. Find and open TomTom folder
    Delete HOME 3 folder.
    Delete the MyDrive Connect folder from: C:\Program Files (x86) (if still present)
    Delete the TomTom folder from: C:\Users\[username]\AppData\Local\ (USERNAME - It is the user name which you use to login to Windows )
    Delete the TomTom folder from: C:\Users\[username]\AppData\Roaming\
    Delete every file and folder from: C:\Windows\Temp\ (in case some files can't be removed, reboot the PC and retry)
    Restart your computer.

    Re download a new installer from (I recommend you to use the Google Chrome while downloading the installer)

    Now install MyDrive Connect with the newly downloaded installer.

    After the installation process of the new MyDrive application completes successfully, please restart your computer. Now, check if the application is able to connect to your device properly or not.

    *** For further troubleshooting tips, please see below ***


    - It is very unlikely that one would have to do these all, it is usually one of the below mentioned possibilities

    - As in IT Crowd: Have you tried to turn the computer off and on again? :)

    - Try to add MyDrive Connect to the exclusion list of your antivirus and firewall (or disable those temporarily)
    - Make sure that your computer is not going into stand-by or similar (this shouldn't happen with the latest MyDrive Connect)
    - Clear the cache before each update attempt. Also could do a soft reset before and after the update
    - Make sure you have all the latest updates and hotfixes/patches to your OS (not only the mandatory ones, but the optionals too)
    - In case the device looks like hung during the update or the counter stopped (or not visible at all), just leave it.
    Most probably it will be fine in a few minutes (or within a couple of hours, in case of installing large maps)
    - Check your network connections, make sure that the TT's network adapter is enabled
    - Try to uninstall and re-install the MyDrive Connect application (best to use Revo Uninstaller to remove)
    - Try to use a USB port on the mainboard, rather than a USB hub (desktop PC)
    - Try to change the port to 5000 (or 5001) in MyDrive Connect's settings
    - Try to run the MyDrive Connect app as administrator
    - Sometimes disabling caching large files helps too
    - It is worth checking the USB power saver settings

    - Any further issue: Try it on another PC, try it with different USB lead...the shorter the better (below steps are Windows specific)
    - Whilst the device connected, remove the drivers from the Device Manager (Windows/Control Panel), DELETE the drivers
    - Remove the MyDrive Connect application and run CCLEANER (will remove your history, cookies, etc by default)

    - At the moment certain USB3 port looks like incompatible with the TT devices (those are usually coloured blue on the PC).
    Could try BIOS update on the PC or enable "Legacy mode" for the USB ports in the BIOS (for further instructions, look for the user manual of your PC/mainboard)
    - Don't use the magnetic mount whilst updating, connect the micro USB directly into the device
    - Disable any network monitoring software
    - Update one item at a time, don't select all.
    Best order: NavCore/software - Map - QuickGPSfix - Speed Cams - Map Share Corrections (this is the smallest but longest in some cases)

    Certain Mac versions (10.10.2, 10.10.3 10.10.4 and 10.10.5) have USB issues, but there is an official fix available, provided by Apple.
    The latest version of MyDrive connect is not compatible with Windows XP SP2 and below, make sure that you update to SP3 and install ALL the other updates.
  • Mandraghe51Mandraghe51 Posts: 4 [Master Traveler]
    Solved - many thanks.
    I did these steps (following your instruction):

    1) Closed MyDrive Connect completely
    2) Uninstalled MyDrive using REVO Uninstaller (in Advanced mode)
    3) Removed application file – deleted HOME 3 folder
    4) Deleted the TomTom folder from: C:\Users\[username]\AppData\Local\
    5) Deleted every file and folder from: C:\Windows\Temp\
    6) Restarted the PC
    7) Deleted again every file and folder from: C:\Windows\Temp\
    8) Run CCLEANER – cleaner
    9) Run CCLEANER – registry
    10) Run again CCLEANER – registry
    11) Restarted the PC
    12) Check for WINDOWS10 update (none available)
    13) Check the drivers using IOBIT DRIVER BOOSTER – updated driver for Intel ICH8 Family PCI Express Root Port xx to version
    14) Restarted the PC
    15) Downloaded a new installer from using CHROME
    16) Installed MyDrive Connect using the new downloaded installer
    17) Restarted the PC
    Then the application started correctly and I was able to connect TT VIA 135 to my PC.

    Many thanks again
  • VikramKVikramK Posts: 11,954 Moderator
    Hi Mandraghe51,

    I am happy to know the issue with connecting your Via 135 has been resolved.

    We appreciate you have provided the steps to resolve the issue, and this post will be helpful to others who visit the forum with similar issue.

    Thank you:).

  • David_VallespiDavid_Vallespi Posts: 4 [Neophyte Traveler]
    I follow without can connect my 6100 to MyDrive connect with Windows 10:(
  • ZsoltZsolt Posts: 36,011
    Have a look at the tips above. Plenty of help.
  • rbringwoodrbringwood Posts: 7 [Master Explorer]
    The problem I had on Windows 10 with MyDrive was that it just said "connecting" but never connected. The only thing that got it to connect was the advice from zsolt:

    Connect the device. If it is not recognised yet, keep it connected and then press and hold the ON button, until you hear the drum roll. Then wait another minute.
  • 11lotus11lotus Posts: 120 [Prominent Wayfarer]
    To me it's the case of 'the squeaky wheel' know what I mean?
  • dave_un17dave_un17 Posts: 3 [Neophyte Traveler]
    Same problem here with GO 6100 and Windows 10. Been working perfectly with Windows 7. I've followed all the relevant advice in this thread and it still shows in Windows as connected but not connected in MyDrive Connect.
  • dhndhn Posts: 33,346
    With the device connected to the computer and MyDriveConnect open, do a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds. Wait a few seconds and see if the device is 'seen' then.

    Also see here:

    and here:
  • dave_un17dave_un17 Posts: 3 [Neophyte Traveler]
    I'm afraid I'd already tried that, but I tried it again and the device is still not seen by MyDrive Connect.
  • ZsoltZsolt Posts: 36,011
    Have you tried all from "my" list above?
  • 11lotus11lotus Posts: 120 [Prominent Wayfarer]
    Mine now 'seems' to connect but my other TomTom GO600 which, annoyingly I have to link to a separate account, similarly ticks down to 1 min 47 sec when updating the device, then stalls and after some minutes says 'failed' (what is about 1 min 47 sec anyway?)
    When you go back to MyDrive Connect, I'm told "your device is up to date".
    I have no confidence that the updating process will go through like it used to on Windows 8.1 or Vista before it.
    The convoluted steps above, I regard as being beyond me at my pre tech age.
  • catjencatjen Posts: 1 [Apprentice Traveler]
    "With the device connected to the computer and MyDriveConnect open, do a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds. Wait a few seconds and see if the device is 'seen' then."

    That did the trick for meg. Windows 10 and Start 25.

    Thanks mate.
  • dave_un17dave_un17 Posts: 3 [Neophyte Traveler]
    I contacted TomTom support and followed their instructions and it worked. I'm pretty sure I did all that twice before, but perhaps not. Anyway, if you're having problems it's worth contacting support.
  • 11lotus11lotus Posts: 120 [Prominent Wayfarer]
    All problems fixed
    Did I get some sort of special treatment from TomTom?.
  • 11lotus11lotus Posts: 120 [Prominent Wayfarer]
    I'd like to see TomTom permit say, a maximum of 2 devices per account and avoid having to pay for services, potentially, twice.
  • 11lotus11lotus Posts: 120 [Prominent Wayfarer]
    Good to see a TomTom sponsored forum allowing good AND bad comments/responses.
  • TimeoppTimeopp Posts: 1 [Apprentice Traveler]
    Many thanks it works, atlast I can update from Windows 10 Pro.
  • 11lotus11lotus Posts: 120 [Prominent Wayfarer]
    Maybe it's an initialisation issue of some sort.
    Either way AU is a long way from BV it seems
  • IBTRUCKN67IBTRUCKN67 Posts: 1 [Apprentice Traveler]
    The problem I have is customer service keeps telling me they have customers running WIN10 with no issues rather than trying to help me get my product working and its VERY FRUSTRATING. They keep asking me to try it on other pcs and I keep getting the same results. I agree with the person that says it maybe the version of windows 10 because the pcs I have tried are both win 10 PRO.

    The customer service people at TOMTOM treat you like a kid and that you do not understand anything when I believe its totally the opposite. If its not within their "PreDefined" set of parameters they are absolutely useless and of no help, then send you on endless missions like finding someone else with Windows 10 and see if you can get it to work. That is why I called TomTom customer service. I tried everything else including these forums before wasting TomTom customer services precious time and now they want to waste mine. I am now considering purchasing other than TomTom products if this does not get resolved and all the people I have turned onto TomTom (in the upper hundreds) I will turn off of TomTom. I am the tech guy everyone turns to for advice. Just saying.... :o(
Sign In or Register to comment.

Who's Online in this Category0