no Maps but device up to date — TomTom Community

no Maps but device up to date

my start  20 device started showing no maps found earlier today! once home i installed all the updates and computer isshowing it is completely upto date but device still saying no maps found :(

Comments

  • dhndhn Posts: 33,195 Superusers
    Try to clear the cache in the desktop's icon and save.

    Then do a drum reboot on the unit.

    Connect to MyTomtom and see if a map is offered in Manage Content or My Maps.

    If not, call CS:

    [url=http://uk.support.tomtom.com/app/home/locale/en_GB"; rel="nofollow" target="_blank]UKUnited Kingdom[/url]

    0845 161 0009 or 020 7387 5444
    Monday-Friday: 9:00 am to 5:30 pm BST
  • ZsoltZsolt Posts: 36,006 Superusers
    This one should help:

    [url=http://uk.support.tomtom.com/app/answers/detail/a_id/1898"; target="_blank]http://uk.support.tomtom.com/app/answers/detail/a_id/1898[/url]

    Just recovered a similar device a few days ago with the same error.
  • colin43colin43 Posts: 2 [Apprentice Traveler]
    I have the same issue. MyDrive on both a PC and Mac say my device is up to date but my device says no maps available. This was after it said it would install 3 updates. I've tried clearing the cache and re-starting the device and nothing works. I was doing this on a Windows PC and getting this error so thought I'd try it on a mac (to ensure no caching issues) and after installing MyDrive it still says the device is up to date but the device says otherwise. I now have an unusable device just from trying to update.
  • dhndhn Posts: 33,195 Superusers
    Try a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds.
  • colin43colin43 Posts: 2 [Apprentice Traveler]
    None of the 're-boot the device' advice worked. I clicked on 'My Content' and the active map was showing as corrupted with the options to Repair or Uninstall. I selected Repair but this just led to a waiting icon and nothing further. I had to disconnect the device and re-connect each time I tried to Repair to get back to the Repair or Uninstall options. (Note that it seemed to take ages to re-connect each time). In the end I selected Uninstall. That worked quite quickly and then gave me the option of installing the Europe map again. When I selected it it said there wasn't enough space on the device with the selected options so I had to select one of the (many) options to not install as much building data (whatever that is!). Clicking on each option gave me information about whether it would fit on the device. I selected one that said it would and selected install and it successfully installed and it is now fully working.

    It seems that my specific issue was that the automatic update included options that wouldn't fit on my device but the automatic installer didn't check enough space was available (and neither did the repair option). Only trying to do a new install appears to check space requirements and install correctly.
  • Julie2019Julie2019 Posts: 4 [Neophyte Traveler]
    I have the TomTom go 50 and have the same issue, this happened following an update. The TomTom Connect says it is up to date yet the TomTom 50 device says no maps available. I tried to install yesterday but it said insufficient space so I purchased a 32 GB memory card today and now I have no maps. The UK and Republic of Ireland map also no longer shows in my maps so I am unable to re install from here either

    Please help!!!
Sign In or Register to comment.

Who's Online18

bastle
bastle
Ewaa
Ewaa
levit
levit
ploum115
ploum115
+14 Guests