GO Live 1000 Keeps restarting

Hi

My TomTom GO LIVE 1000, just keeps on restarting.

Even after resetting the device, it still does it. I have the latest updates installed but still getting this issue.

Please assist.

Regards;

Yugz

Comments

  • StefanStefan Posts: 6,090 Superusers
    Did you performed a factory reset in the settings or a full reboot?

    Perform a full reboot - All Settings are kept

    * Make sure that the device has enough battery power left, otherwise connect to a power source.

    Press and hold the power button for 15 - 30 seconds untill a drum roll sound is being heard, release the button after hearing the sound and wait untill the navigation screen is displayed.

    Recovery Mode (all settings are kept)

    Follow the instructions in the TomTom Knowledge Base Article:

    [url=http://uk.support.tomtom.com/app/answers/detail/a_id/1898"; target="_blank]http://uk.support.tomtom.com/app/answers/detail/a_id/1898[/url]
  • Gabriel PinterGabriel Pinter Posts: 4 [Master Traveler]
    My Go Live 2050 does the same. Keeps on restarting every 2 - 3 minutes. VERY annoying, tried everything mentioned here. Please HELP!!!
  • MikeJamesMikeJames Posts: 388 [Revered Navigator]
    Is that on internal battery or connected to external power, or both?
  • Gabriel PinterGabriel Pinter Posts: 4 [Master Traveler]
    Connected to my laptop.
  • dhndhn Posts: 33,155 Superusers
    A full factory reset may resolve the problem but all custom settings are lost.
  • Gabriel PinterGabriel Pinter Posts: 4 [Master Traveler]
    And how do I do a full factory reset on Go Live 2050 please? I don't mind losing any custom settings, I'm desperate here. Thank you!
  • dhndhn Posts: 33,155 Superusers
    I think there is an icon somewhere that says factory reset. Scroll through the various screens.

    See page 61 of this user guide:

    http://download.tomtom.com/open/manuals/LIVE/TomTom-EU-LIVE-RG-en-gb.pdf
  • Gabriel PinterGabriel Pinter Posts: 4 [Master Traveler]
    It worked!!! The unit is staying turned on for over 15 minutes now, after the full factory reset. It took me a while as it was keep on re-starting every 2 minutes, not giving me even enough time to get to the menu and scroll. I had to memorise the steps and use speedy fingers LOL! Thank you VERY much Elite Vanguard!
  • dhndhn Posts: 33,155 Superusers
    You are welcome.
Sign In or Register to comment.

Who's Online47

aon1961
aon1961
cupalsky
cupalsky
PGS0704
PGS0704
s-i-g-g-i
s-i-g-g-i
+43 Guests