TomTom Home Runtime Error

XigaluXigalu Posts: 5 [Master Traveler]
edited January 26 in Archived Discussions
 When I start the Home software I get "TomTomHomeruntime.exe failed with error 0".

I have tried uninstalling and reinstalling the software. I have used Revo uninstaller and then reinstalled, but nothing helps. I have not been able to find a solution in the forums that worked for me. Can anyone help?

I have a XXL 550. I am running TomTom Home on Windows 7 Home.

Comments

  • dhndhn Posts: 32,962 Superusers
    Do you have dot net framework installed? If not, get it here:

    [url=http://www.microsoft.com/en-us/download/details.aspx?id=17851" target=_blank>
  • XigaluXigalu Posts: 5 [Master Traveler]
    Yes. I do have that installed and recently updated.
  • dhndhn Posts: 32,962 Superusers
    Something here help??

    [url=http://uk.support.tomtom.com/app/answers/minor_detail/a_id/13348/" target=_blank>
  • XigaluXigalu Posts: 5 [Master Traveler]
    Unfortunately, no. I saw that too.

    Would going back to a previous version of Home work? If so, how would I do that?
  • KevinmhKevinmh Posts: 1 [Apprentice Traveler]
    The simplest solution is to uninstall Tom Tom Home, restart the computer and reinstall Tom Tom Home, but change the default installation directory.  I just put another letter at the end of the default directory.  This fixed the problem because it updates the registry entries.
  • XigaluXigalu Posts: 5 [Master Traveler]
    Thanks for replying.

      I tried again. Uninstalled with Revo. Restarted the computer. Reeinstalled TomTom Home with an "a" at the end of the name of the default directory. But it is still runtime.exe error 0. The software will not start and I cannot update my maps.

       Is there anything else that can help?
  • dhndhn Posts: 32,962 Superusers
    What is the operating system? Windows 7? If so, try running Home in XP compatible mode.
  • XigaluXigalu Posts: 5 [Master Traveler]
    Thanks for the suggestion. I hadn't tried that because it worked fine on this computer for a year. Nevertheless I tried XP compatibility mode now but it didn't help. I have the same problem and the Home software will not open.
  • robduckmanrobduckman Posts: 4 [Master Traveler]
    I too have had the problem of TomTomHome ceasing to work and getting the runtime.exe error message 1058.  The instructions at [url=http://us.support.tomtom.com/app/answers/minor_detail/a_id/15976/"; target="_blank]http://us.support.tomtom.com/app/answers/minor_detail/a_id/15976/[/url] are completely useless in re: Win 7 64 as they make no sense in my win explore directory as shown in my toshiba satelite laptop.  However, in my toshiba netbook running win7 32, it installed perfectly!  I tried all the suggested 'solutions' without success.  I surmise that the problem inheres somewhere in running 32 bit software in the 64 bit operting sysem.

    How can I run my win7 as if XP, as someone suggested?
  • dhndhn Posts: 32,962 Superusers
    Right click the Home shortcut icon and select Properties-->Compatibility. Choose XP.
  • robduckmanrobduckman Posts: 4 [Master Traveler]
    Thanks!!! Worked like magic.
  • Michel3435Michel3435 Posts: 1 [Apprentice Traveler]
    Thanks a lot.
    I have tried anything but nothing was working until your solution.
    For me the XP compatible mode run fine.
    For auto start, I have also set the "run as administrator" mode.
  • Rick7024Rick7024 Posts: 1 [Apprentice Traveler]
    I have the same problem.  The solution offered is to reinstalled runtime.exe. Finding the program is a joke.  It is time to look elsewhere for a different for a different GPS.
  • robduckmanrobduckman Posts: 4 [Master Traveler]
    It certainly is an aggravating problem!  Check the solution I found effective in my earlier posting.  That aside, I really love and utterly rely on my TomTom, named 'Richard'
This discussion has been closed.

Who's Online21

21 Guests