Voice search not available in Canada?

Hello,

Got a TomTOm 2535TM WTE.
Logged in to MyTomTom and updated everything (including the NA map to 880). Using the "Samantha" voice for US English.

When I try to give the voice command "Navigate to an address", the device says: "Voice search in not available for this country, please enter the address manually".

What gives?

Thanks,
Alex.



Comments

  • AlexoAlexo Posts: 30 [Outstanding Explorer]
    Anyone?
  • JasonTTJasonTT Posts: 64 [Prominent Wayfarer]
    Voice search is working on my 1530tm. Is your software up to date?
  • dhndhn Posts: 33,151 Superusers
    In another forum, the OP posted that he found the solution ....bizarre though it seems.

    He switched to the Europe map and then back to the North America map and it started working.
  • ronbroronbro Posts: 2 [Apprentice Traveler]
    sorry the switghing maps did not work for me.
    strange thin is when It was not updated every thing worked great.
    It only happened once I updated the unit.
  • dhndhn Posts: 33,151 Superusers
    Try resetting the unit by holding the power button for about 10 seconds till you hear the drum sounds.
  • ronbroronbro Posts: 2 [Apprentice Traveler]
    Sorry the hold the button for 10 sec till I hear the drums does not make the voice work. still says not available in your country.

    I spoke with TT on the phone and he told me to return it to the store as there is nothing I can do to fix it......   
  • dhndhn Posts: 33,151 Superusers
    What model do you have and is it still under warranty?
  • kentanakentana Posts: 4 [Master Traveler]
    Resetting by holding the switch for ten seconds worked for me, thank you. I have the TomTom 2535TM WTE with the Jan 1, 2012 maps.
  • vsvs Posts: 5 [Master Explorer]
    I have the same problem with 2535TM. Switching maps and resetting doesn't help. On TomTom's support advice I replaced my device at the store where I bought it. The new one worked. But only until I updated the software. Immediately after that the same problem popped up.

    So it's became evident that it's a software bug. After repetedly asking support I received this answer recently:

    "We would like to inform you that this is a known issue and is a bug in our software. Our corporate team is working on it. The issue should be resolved for you pretty soon, however there is no estimated time we can provide. We will post more info as soon as it gets updated."
  • Jeff_J_BrownJeff_J_Brown Posts: 1 [Apprentice Traveler]
    I have the same issue.

    You'd think after leaving us stranded after the whole "leap-year" bug that they'd give us a software update that actually works.

    I've tried restarting this device, switching maps, changing settings, and nothing seems to be working. I've talked to a number of people who own this same device, and are fed up. This is not the type of support I thought I'd get from a GPS device that costs $300+.
  • rabidcat77rabidcat77 Posts: 1 [Apprentice Traveler]
    I had the same problem with the "voice search not available in this country..." on a GO2435TM unit I just purchased. I live in the USA. I was able to fix the problem by changing a destination to one in Mexico, then back to one in the US. However, it would seem you MUST be using the latest map for this to work.

    This fix was outlined by another member of this forum in this post here and I tried doing that when I was running the latest version fo the TomTom software, but an older map and the fix did NOT work.

    I had tried using my latest map guarantee by entering in the promo code, but that did not work online, and it gave me a weird error about the application not working. I figured I couldn't possibly have the latest map as I saw it was listed as an 8.7 version from 2011, and there have been newer maps than that that I've seen others reference online.

    So, in a nutshell here's what I did to fix it:

    1) Called TomTom tech support to try and fix the voice issue. After waiting for about 15 minutes on hold, I spoke with a very helpful representative. He had me reset the unit to factory defaults, the usual steps one does when troubleshooting. I then went through the steps I originally did to recreate the problem, and the problem occurred again - he even heard the unit speak the error, which he was surprised by. He asked if I could return the unit to try and swap it out, but I told him about how I had bought it online and segued into my promo code issue. He thought it might be of help to try fixing that to get the latest map, so on to point 2.

    2) My other issue was that the lifetime maps promo code wasn't able to be associated with the unit online. The rep manually associated the unit's serial number with my account, along with the promo code and had me plug the unit into my pc, where it then found that a new map was available. At this point he assigned me a case number that I could reference after I had done the map update if that didn't work and I had to call back in. I thanked him for his help and he wished me luck.

    3) After downloading the map update I tried the voice search feature, and it again failed.

    4) I then tried manually entering in an address in Mexico, and had it figure out a route to that end destination. I then cancelled that route, and selected a destination in the US.I cleared that route, then tried the voice feature.

    5) It worked!

    For reference, I'm currently running v11.037.920860.84 (release date of 4/5/2012) of the Tomtom software and my map version is 885.4102 from 1/2012
  • kijijikijiji Posts: 6 [Master Explorer]
    I am having this notorious problem on a VIA1535TM. "voice search is not available for this country"... It started doing it after the latest updated map. I have done numerous resets. I manually select Canada since that is where I am using it. Then for a few times it works. Then randomly it comes back to saying voice search not available. It is a pain when you rely on the tomtom to find a dozen addresses a day. I will be abandoning the tomtom if I cant get some support or a patch to fix the problem. Very disappointing. After searching the forums it appears that tomtom has not fixed this glitch which seems to come and go in the software......
  • dhndhn Posts: 33,151 Superusers
    Yeah, a drum reset is the only (temporary) solution I know. you can try a complete factory reset (though you'll lose your custom settings) and see if that is any better.

    Also, support:

    866 486 6866
    Monday - Friday: 8:00 a.m. to 8:00 p.m. EDT
    Saturday: 9:00 a.m. to 6:00 p.m. EDT

    open today.........

    One other thing..........

    Try driving to an address but complete all steps manually, not using the voice search. Once that is 'set', perhaps voice search is more effective.
  • kijijikijiji Posts: 6 [Master Explorer]
    thanks for your suggestions. I think the problem could be fixed if there was an option in setup to tell the gps the country you are in and use it as home. When it refuses to use voice command it shows a screen and the first choice is a list of states in the USA. The program must be stuck in a default mode of that home country. Maybe if I downloaded a Canada only map.
Sign In or Register to comment.

Who's Online69

Elchdoktor
Elchdoktor
Juergen24b
Juergen24b
MaartenBastijns
MaartenBastijns
Sascha1712
Sascha1712
Sölktaler
Sölktaler
TomDone
TomDone
+63 Guests