No Voice installed

Ton1958
Ton1958 Registered Users Posts: 4
Novice Seeker
GO520; when starting up, the system reports: No Voice installed. All I did is leave it unused foor several month en now connected it to power source. A 'soft restart' did not help. How can I get the unit operating again ?

Tagged:

Comments

  • Willy875
    Willy875 Registered Users Posts: 7,096
    Elite Voyager
    Connect your GO to Mydrive connect to see if a voice is available for download.
  • Ton1958
    Ton1958 Registered Users Posts: 4
    Novice Seeker
    When connected to the TomTom site, it is suggested to buy an update at €49,95.
    However, I am suppost to have Lifetime update. I also performed updates regularly.
  • Willy875
    Willy875 Registered Users Posts: 7,096
    Elite Voyager
    GO 520 has lifetime updates
    Connect your GO to Mydrive connect to check if a voice is available. https://www.tomtom.com/en_gb/navigation/mydrive-connect/
  • VikramK
    VikramK Administrators Posts: 14,518
    Moderator
    Hi @Ton1958,
    We have activated a few computer voices for your TomTom, could you go into the updates
    Main menu-Settings- Updates & New items [the device should be connected to a Wi-Fi® internet connection before you look for updates]

    Regards,
    Vikram.
  • Ton1958
    Ton1958 Registered Users Posts: 4
    Novice Seeker
    when switching on: the GO 520 goes into the menu "choose Voice" with comment: 'no voice installed'.
    There is a menu button: 'Less voices'
    No matter where I touch the screen, nothing happens. The unit is completely frozen.

    Also, when connected to the PC with MyDrive Connect, the computer screen indicates that it is connected with the GO 520, however, on the TomTom unit, this is not vissible. It remains with the screen mentione above.

    Holding the on/off-button when starting up longer than the drums, I get a blac/white screen with details of the GO, but nothing else happens.

    What are my options now ??
  • Ton1958
    Ton1958 Registered Users Posts: 4
    Novice Seeker
    New development: when disconnecting the GO from the PC, the frozen screen op the TomTom unlocked, and I could acces the update menu.
    I reconnected the GO tot the PC-USB and started the update
    The screen now indicates that it is updating. however, it seems to stop at 13%.
    I will leave it for a while and see if the update proces is just very slow (as it always was when I updated via WiFi)