Go Professional 6250 GPS Problem

Gazza667
Gazza667 Registered Users Posts: 9
Apprentice Traveler
Hi.
A weird thing happened today. I turned my TT on and put in the address I was going to and then startedy journey. After a few minutes I notice that the device hadn't registered that I was 3 miles from my starting point.
My traffic and My Drive were all connected fine, my Europe HM Truck map is up to date and I'd also connected WiFi to my phone's WiFi hotspot.
This carried on for several minutes and then, suddenly the map seemed to catch up with its self and my speed and destination all worked for 40 seconds. Then it stopped. My position did not move although I was travelling down the M5.
I pulled over at the services to investigate and it started working again. Then a few minutes later it stopped. This happened several times until I lost my cool with it and did a reset. Still the same issue.
It was like the GPS system had just vanished.
Anyway. After about 2 hours in to my journey, it started working properly again and has been since.
Did anyone else have a similar problem or is my GPS module possibly on its way out?

Answers

  • VikramK
    VikramK Administrators Posts: 14,540
    Moderator
    Hi @Gazza667
    Sounds like the locating tracking is intermittent. Is the device placed such that it has a clear view of the sky?

    Perhaps I would also suggest that you try the troubleshooting steps on our support article here-
    https://help.tomtom.com/hc/en-gb/articles/360013900280

    Regards,
    Vikram
  • Gazza667
    Gazza667 Registered Users Posts: 9
    Apprentice Traveler
    Follow up to my post.
    Yes, i followed the tips listed but nothing worked. It wasn't until i was half way down the UK that i happened to notice that if i gently tapped the top of my TT, almost immediately, the map would then show my current speed and exactly where i was.
    So when i got home. I used one of the mobile phone picks i had and separated the covers. After close inspection i noticed the tiny connector that plugs the antenna to the board didnt seem very secure. The tape that sat on top had come away. Which meant the connector was born very loose.
    I then used a new strip of electrical tape and then cleaned all of the contacts between the board and the cases with isopropyl alcohol and put the unit back together.
    Ive used my TT today for around 6 hours and it has not missed a beat 🙂
    For the record, my 6250 is around 4 years old so would not have been covered by warranty anyway. So i had nothing to lose.