Traffic info not working on TT GO PRO 6200

RomainCG
RomainCG Registered Users Posts: 4
Apprentice Seeker
Hi,

The Traffic services on my TomTomGO PRO 6200 are not working.

The device has lifetime traffic but the device shows 'Traffic Service unavailable'.

I have tried resetting the device etc but it will not work.

Also, the app does not pick up the device I am connected to, My Bluetooth setting confirms the GO PRO 6200 is connected on my iphone and the Go Pro also confirms the device is connected to my phone. Except the App, which keeps on asking me to connect a device.

At the time the feature was working fine but did not have a chance to use it during COvid and now I can travel again the service is not working. I suspect a reboot is required on Tomtom side?

Thank you for the assistance

Regards Romain



Comments

  • Willy875
    Willy875 Registered Users Posts: 7,101
    Elite Voyager
    Hi

    No, on GO 6200 professional does not have lifetime traffic GO 6200 pro only Tomtom Traffic and speed cameras for 1 year

    You must purchase a subscription.
  • YamFazMan
    YamFazMan UKPosts: 21,316
     Superuser
    Hi
    @RomainCG
    See... https://www.tomtom.com/en_gb/navigation/truck-gps-sat-nav/go-professional-6200/
    Quote....
    GO Professional 6200
    Professional sat nav designed for large vehicles.
    Updates via Wi-Fi®
    Truck, coach, van and car routing
    Incl. European Map Updates
    >> 1-year Traffic and Speed Camera Alerts via built-in SIM <<
    End Quote....

    Stay Safe ATB YFM
  • RomainCG
    RomainCG Registered Users Posts: 4
    Apprentice Seeker
    Thank you Guys,

    I may have made a mistake wiht the model I have. it is not the PRO but the GO 6200 and it has the lefetime Tomtom Traffic.

    see pictures of the packaging
    l77g31qan1or.jpg
  • DougLap
    DougLap Posts: 10,114
    Superuser
    edited September 12
    Hi @RomainCG

    Look back here later to see what @VikramK has to say after he has reviewed your units settings on the TT servers.

    Doug
  • Willy875
    Willy875 Registered Users Posts: 7,101
    Elite Voyager
    @RomainCG


    Have you tried the troubleshooting video?



  • RomainCG
    RomainCG Registered Users Posts: 4
    Apprentice Seeker
    Hi Willy,

    Thank you, Yes I did follow those steps and still no traffic info.
  • b4u2
    b4u2 Registered Users Posts: 55
    Outstanding Explorer
    @RomainCG

    I have been having the same problem.
  • RomainCG
    RomainCG Registered Users Posts: 4
    Apprentice Seeker
    Hi @VikramK,

    have you been able to look into it?
  • VikramK
    VikramK Administrators Posts: 14,518
    Moderator
    Hi @RomainCG
    The services on your account all look okay. Our team will have to investigate it the problem is related to SIM connectivity.

    Please reach out to our customer service along with the below information-
    1. Current Country where you are located:
    2. Device Serial Number:
    3. SIM ID from device (Go to Settings > System > About > and look for SIM ID)
    4. Please send a photo of GPRS Status: (Go to Settings > System > About > and look for GPRS status)
    5. Send a photo of the device map screen with a route planned and traffic not working:
    6. Which country does the traffic not work?
    7. How long does the battery last after a full charge and disconnect from power/CLA?
    8. Does the Traffic work when connected to Wi-Fi?

    Thank you,
    Vikram.