Carminat Live not responding to built-in buttons

denissuu
denissuu Registered Users Posts: 3
New Seeker
Hi there! So I just got a Renault Laguna 3 with TomTom Carminat Live, I updated the sd card with tomtom home and went into the car, this went fine. I’m currently waiting for my world map order and I went ahead and bought a bigger sd card as the original renault one was only 2gbs. Plugged it in the car, everything was fine. I thought that maybe it was a good idea to just copy and paste everything from the original sdcard into this one and then wait for the map to install it as well. Went ahead and did that, now the navigation displays only temperature, no map, and a white crosshair in the middle where the arrow to represent the car would’ve been. Each time I update the navigation inside the car it was showing an image saying 9884 and an sdcard next to it, I’m not sure if that meant to check if it was the original sd card. No buttons or joystick work, pressing buttons on the radio displays nothing on the navigation, it just starts with the splash screen and then remains open with no map. What can be done here? I don’t have anything to overwrite this update and I don’t know how I could reset this as it’s built into the car. Any help about what I can do to at least get it back working? Thanks!

Comments

  • VikramK
    VikramK Administrators Posts: 14,540
    Moderator
    Hi @denissuu
    Welcome to the community! Copying the data content from one memory card to another won't work.
    Best to format the new card on a computer > Reinitialize it in built-in device > Install the maps using TomTom HOME.

    See the steps on the link below-
    https://discussions.tomtom.com/en/discussion/1147300/format-and-restore-the-tomtom-carminat-when-you-have-an-active-map-on-your-account#latest

    Regards,
    Vikram.
  • denissuu
    denissuu Registered Users Posts: 3
    New Seeker
    edited August 16
    Hi @VikramK I tried what you said, and honestly I think it did nothing. It still boots up over there and no car buttons work or radio. I reinstalled the firmware as some guy pointed out in the forums and he procedeed to share it. I got the screen to install the new one again with the 9884, pressed yes, it succeeded, but it's still the same, pressing radio buttons or using buttons in the joystick area does nothing. What should I continue to do now? I plugged in the sdcard after deleting the content from the firmware reinstall and the car popped up with a message that the sdcard is now ready to be used in tomtom home. Pressing the update carminat button only provides me with quickgpsfix and that's it.

    I can provide you some pictures with the file structure inside the sd card, the inside of the loopback file or what shows up on the car's tomtom display. Thanks for the help!
  • denissuu
    denissuu Registered Users Posts: 3
    New Seeker
    Coming back a few hours later, the car started working without an sd card plugged in, and I managed to install the maps and initliaze the sdcard after that. I think not using an sd card did a soft reset or something. Everything is good now. Thank you so much for the help! For anyone bumping into this, try installing the 9884 firmware again, it was provided in a post on the forums that I can’t seem to find again. I’ll come back with an edit after I find the link.

    Wish you guys success!
  • Troubadix12
    Troubadix12 Registered Users Posts: 2,034
    Revered Voyager
    edited August 18