GO620 fails to power down when power is disconnected

Duncan Williams
Duncan Williams Registered Users Posts: 23
Master Explorer
My GO620 has just started to exhibit a strange anomaly. Up until a couple of weeks ago, when I turned off my car's ignition (or pulled the cable out of the back if I'm not in the car) the TomTom would put up a screen asking me if I wished it to go to Sleep or Turn Off; however, now, when I switch off the ignition or pull out the cable, it flashes the TomTom logo at me and does not respond to the power switch or tapping the screen. The only way to get it to respond is to either turn the ignition on again (or reconnect the mains power supply) at which it then reboots normally. My only work around at the moment is to press the power button for a couple of seconds - it then gives me the usual choice of Sleep or Turn Off - it then shuts down in the normal fashion. I wondered whether this was a problem created by some recent update - my app version is 21.200.0003.411 (0) (09/11/2021). Has anyone else experienced this behaviour?
Tagged:

Best Answer

  • Lochfrass
    Lochfrass Posts: 18,904
     Superuser
    Answer ✓
    On Youtube some Videos was shown how to replace a battery on TomTom devices.
    Official TomTom must replace the batery.

Answers

  • Lochfrass
    Lochfrass Posts: 18,904
     Superuser
    Does set it to factory settings solve the problem?
  • Duncan Williams
    Duncan Williams Registered Users Posts: 23
    Master Explorer
    Hi. Thanks for your rapid response. I reset the device but it still exhibits the same strange behaviour if I disconnect the power without first turning the device off via the button on the back. Perhaps TomTom is just telling me that it's time I upgraded:)
  • Duncan Williams
    Duncan Williams Registered Users Posts: 23
    Master Explorer
    It occurs to me that, as the same thing happens if I simply turn on the device by pressing the button on the back, without having it plugged into a power supply, perhaps the internal battery has failed. Could this be the case and, if so, is it replaceable (the manual is no help on this aspect)?
  • Lochfrass
    Lochfrass Posts: 18,904
     Superuser
    Answer ✓
    On Youtube some Videos was shown how to replace a battery on TomTom devices.
    Official TomTom must replace the batery.
  • Duncan Williams
    Duncan Williams Registered Users Posts: 23
    Master Explorer
    Hi once again. many thanks for the tip re Youtube videos. Very interesting. I've nothing to lose so I'll give it a go.
    Once again, thanks
  • Duncan Williams
    Duncan Williams Registered Users Posts: 23
    Master Explorer
    There appear to be several different batteries that might or might not fit. You wouldn't know which is the correct battery for this GO 620? No worries if you can't help, I'll open up the device and measure the battery.
  • Willy875
    Willy875 Registered Users Posts: 7,095
    Elite Voyager
    If your GO620 fails to turn off when the power is disconnected, look in System then Battery Settings.

    Once the GPS is disassembled, look on the battery for reference.
  • Duncan Williams
    Duncan Williams Registered Users Posts: 23
    Master Explorer
    Many thanks
  • Charliebot
    Charliebot Registered Users Posts: 2
    Apprentice Seeker
    This seems very strange as my my sat nav tomtom go professional 620 has also started
    to display the same problems as yours has anyone got any answers from the company? As this seems to be a software issue that is effecting multiple people.
  • Duncan Williams
    Duncan Williams Registered Users Posts: 23
    Master Explorer
    Many thanks
  • Duncan Williams
    Duncan Williams Registered Users Posts: 23
    Master Explorer
    I've noticed something else strange that happened at the same time that my GO620 started failing to power down correctly - a 7.01MB speed camera update also failed. Now, each time I power the device it tells me that a speed camera update is ready to download. I wonder whether the speed camera update failed and corrupted the OS. We need someone from TomTom to look at this problem because it has all the markings of a software defect.
  • Willy875
    Willy875 Registered Users Posts: 7,095
    Elite Voyager
    Try to connect your GPS to Mydrive connect delete the speed cameras then reinstall the speed cameras.