Paid for the map, but did not receive it.

ychernyh1
ychernyh1 Registered Users Posts: 3
New Seeker
Hi all. I really got a problem with Tomtom. I ordered map of Southern Africa for my device. The money was paid from my bank account days ago. But no map was received. The system says "processing". This is really frustrating. Would you please give me any advice. Thank you!

Comments

  • Willy875
    Willy875 Registered Users Posts: 6,507
    Revered Voyager
    Hi

    What model of GPS do you have?

    Before buying the card have you checked with the checker if the map is compatible with your gps model.

    At the time of purchase, did you select the GPS for which you are purchasing the map.
  • ychernyh1
    ychernyh1 Registered Users Posts: 3
    New Seeker
    edited August 1
    Hi! I have a TomTom GPS navigator that I use in my car. The model is 4EQ50 Z1230 and S/N BOxxxxxxxxx56.

    Thank you for any help and advice.

    Best Regards,

    Yury





    Mod edit: Please don't post private or personal information on a public forum. Thanks.
  • ychernyh1
    ychernyh1 Registered Users Posts: 3
    New Seeker
    At the time of the purchase the system did not ask me anything, hence I did not provide GPS number. Please, let me know what to do. Thank you!
  • VikramK
    VikramK Administrators Posts: 14,283
    Moderator
    Hi @ychernyh1
    Welcome to the community!
    The map -Southern Africa, is showing active on your account now. Could you check for updates in MyDrive Connect (under My Content tab)?

    Regards,
    Vikram.