Device not booting Go premium tomtom

Bazil71
Bazil71 Registered Users Posts: 2
New Seeker
edited July 28 in Devices using Wi-Fi®
My devise will not load up properly. I have followed the instructions given but still will not load up. I turn it on the drums play. The white line loads to near the end & that's it. Can someone please help? I uploaded the new updates & it has not worked since.(Updated on the 25/7/22)

Comments

  • VikramK
    VikramK Administrators Posts: 14,330
    Moderator
    Hi @Bazil71
    Welcome to the community! Could you check if you are able to restore the device using the recovery mode-


    Regards,
    Vikram.
  • Bazil71
    Bazil71 Registered Users Posts: 2
    New Seeker
    Hello Thanks for getting back to me. I have tried this several times. Still doesn't fix the problem. I have followed the instructions. Drum sound then the white bar scrolls along the bottom of the screen but it stops just short of loading up. This all started doing this since I updated the maps & speed cameras. I updated on the 25/7/22.
  • YamFazMan
    YamFazMan Posts: 21,158
     Superuser
    Hi
    @Bazil71
    Do you have a Micro SDHC Memory expansion card fitted ??? If 'Yes' Try removing the Memory Card....
    Then... Try a Soft/Drum roll restart on the device ??? This restarts the devices Operating System

    RESETTING YOUR NAVIGATION DEVICE
    https://help.tomtom.com/hc/en-gb/articles/360013957499-Resetting-your-navigation-device
    Charge the device for at least 2 Hrs….
    (Preferably using something like a Smartphone or a Mains powered USB charger + Using the Tomtom USB lead)
    OR have the device plugged into a power supply while the device is restarting
    Press and hold the on/off button until you hear a drum-roll sound then release the on/off button.
    You won’t lose anything; it’s just like rebooting your PC

    Stay Safe... ATB YFM