MyDrive login error "Problem connecting to Tom Tom Services. Please try again " TomTom GO Discover

dgoedh
dgoedh Registered Users Posts: 9
Apprentice Seeker
edited July 28 in Devices using Wi-Fi®
Hi, I just got a new TT GO Discovery Camper system with WiFi and Bluetooth paired and both connected. Besides I have still my old TT 5100 World. On the new GO discovery I have problems connecting to MyDrive services to synch My Places etc. I tried the factory reset twice or so as suggested in the support video, but I repeatingly get the error "Problem connecting to Tom Tom Services. Please try again later." On my 5100 MyDrive connection works fine.
Is there any other way to tackle this issue. Besides the MyDrive app on my android phone shows the notification that "Device is not in range", while it is paired and blue tooth connected and 10 cm away from each other. That's also weird, but maybe due to the connection flaw with TT services. Thanks in advance. Regards, Daniel

Best Answers

  • VikramK
    VikramK Administrators Posts: 14,290
    Moderator
    edited July 28 Answer ✓
    Hi @dgoedh
    Does your password consist of special characters (e.g.- @,#,$ etc)?
    If yes, could you change to a password that does not contain any of these. Also, I would recommend that you try logging in when the device is connected to a Wi-Fi® network.

    Some of our users have also managed to get this to work by taking the device outside under a clear sky and wait for the device to get a GPS signal.



    dgoedh wrote: »
    Is there any other way to tackle this issue. Besides the MyDrive app on my android phone shows the notification that "Device is not in range", while it is paired and blue tooth connected and 10 cm away from each other.

    The GO Discover is not supported to work with the MyDrive app.

    Thank you,
    Vikram.

  • dgoedh
    dgoedh Registered Users Posts: 9
    Apprentice Seeker
    Answer ✓
    Hi, thanks for the suggestions. I also have set Mydrive Connect to only start on demand.

Answers

  • VikramK
    VikramK Administrators Posts: 14,290
    Moderator
    edited July 28 Answer ✓
    Hi @dgoedh
    Does your password consist of special characters (e.g.- @,#,$ etc)?
    If yes, could you change to a password that does not contain any of these. Also, I would recommend that you try logging in when the device is connected to a Wi-Fi® network.

    Some of our users have also managed to get this to work by taking the device outside under a clear sky and wait for the device to get a GPS signal.



    dgoedh wrote: »
    Is there any other way to tackle this issue. Besides the MyDrive app on my android phone shows the notification that "Device is not in range", while it is paired and blue tooth connected and 10 cm away from each other.

    The GO Discover is not supported to work with the MyDrive app.

    Thank you,
    Vikram.

  • dgoedh
    dgoedh Registered Users Posts: 9
    Apprentice Seeker
    Hi good morning from Amsterdam. Thanks a lot. Updating my TT password, omitting special chars (a % in my case) did the trick. Synchronizing over Wifi works like a charm now.

    Have a good day.

    Regards,

    Daniel
  • YamFazMan
    YamFazMan Posts: 21,136
     Superuser
    edited July 28
    Hi
    @dgoedh
    dgoedh wrote: »
    Hi, I just got a new TT GO Discovery Camper system with Wi-Fi and Bluetooth paired and both connected. Besides I have still my old TT 5100 World. On the new GO Discover, I have problems connecting to MyDrive services to synch My Places etc (Snip)
    On the new GO Discover & Go Expert etc... I Find that Data like My Places etc... does not sync over USB....
    If MyDrive Connect is running on the PC + The GO Discover connected to the USB Port....
    The USB connection will take priority over the Wi-Fi Connection....


    I have MyDrive Connect installed, but set up NOT to AUTO START UP when the PC starts....
    I only Start MyDrive Connect as and when required for say updates etc for the previous ranges of Tomtom devices....
    With MyDrive Connect running...
    Click on the Cog Wheel Icon Screen top right
    Click on the General Tab
    Un-Tick Start MyDrive when the Computer Starts
    Click on Save the Settings....

    I use the MyDrive Web Route planner....
    Here... https://mydrive.tomtom.com/
    I find the data sync from the MDW Route planner over Wi-Fi is instantaneous....

    Stay Safe... ATB YFM
  • dgoedh
    dgoedh Registered Users Posts: 9
    Apprentice Seeker
    Answer ✓
    Hi, thanks for the suggestions. I also have set Mydrive Connect to only start on demand.