No active subscriptions were found in the App Store - Cannot use App

ShiningN1ght
ShiningN1ght Registered Users Posts: 3
Apprentice Seeker
Though I also have had a current inactive subscription, I also have a current suscription with a different term length. The app does not pick up on the active sub. If I attempt to restore purchases, I get the "No active subscriptions" message. If I login like the app suggests, the message changes to "No active subscriptions were found for this TomTom account." If I go back to the subscription purchase page and select the same subscription that I know is active, I get "You're currently subscribed to this. Your subscription to..." If I tap OK, I get the "Oops. Something went wrong" screen. What gives? This is the second time I've attempted to begin a new subscription this week. I tried with a different subscription level that I had to cancel and am currently awaiting a refund for as it gave me the same issues. I've tried force restarting the app, force restarting the phone, uninstalling and reinstalling the app. Nothing changes to outcome.

Answers

  • feorlen
    feorlen Registered Users Posts: 2
    New Seeker
    The TomTom Go app on my phone claims my subscription expires today. I have a valid subscription, it renewed months ago and doesn't expire until next year. I can see that in the Apple app store, and Apple support confirmed it. The "Manage" button on the subscription page, purportedly where I buy a new subscription, takes me to a screen that says my subscription is valid.

    I have tried to contact TomTom support via the chat bot but it never does anything. It offers to send an email to support, but after I type in my question I only get "Please try again later." Even during the support hours. Right now, according to the automated message from the chat bot, both UK and US support is available. I have no way to contact support except via the chat bot, which does not allow me to contact a person.

    How do I fix my broken subscription? I paid for it, I should be able to continue using it. I can see many people reporting similar problems in the forums.
  • Willy875
    Willy875 Registered Users Posts: 6,611
    Elite Voyager
    edited July 26
    Have you tried uninstalling the app and then reinstalling it with your login credentials that allowed you to purchase the app?.

    If you purchased the app from the Apple Store, Tomtom does not manage subscriptions purchased from Apple.
  • evan9eleven
    evan9eleven Registered Users Posts: 1
    New Seeker
    edited July 26
    I have the same issue. WIll deleting and reinstalling the Go app cause all saved places to be deleted or are these saved in the cloud?
  • Willy875
    Willy875 Registered Users Posts: 6,611
    Elite Voyager
    edited July 26
    All locations are saved in the cloud.
  • ShiningN1ght
    ShiningN1ght Registered Users Posts: 3
    Apprentice Seeker
    I’ve tried removing and reinstalling at least a couple times. My Apple ID and TomTom are the same email. If I attempt to subscribe again for the same amount, it tells me I’m already subscribed. The subscription shows up in App Store.
  • feorlen
    feorlen Registered Users Posts: 2
    New Seeker
    My situation mysteriously resolved on its own, I opened the app today and it's fine. So the app and the Apple app store info were out of sync. But there was no way to tell what was going on.

    My issue is not the same as the original poster of this thread, not sure why my thread got moved to being a comment on this one.

    At least my app is working again. Still frustrating to be directed to the web chat bot for support when it doesn't do anything helpful.
  • ShiningN1ght
    ShiningN1ght Registered Users Posts: 3
    Apprentice Seeker
    I’ve been dealing with Apple support and their engineers today concerning the subscription recognition issues I have been having with TomTom Go. They have determined that the issue is indeed with the software and not on their end. Before I get yet another refund on a subscription, do you have any idea at all on how to resolve this problem ?
  • Willy875
    Willy875 Registered Users Posts: 6,611
    Elite Voyager
    @ShiningN1ght

    If it was a software problem, thousands of people would have this problem, not just you.