I can't start up or connect my Start 50/5 to MyDrive Connect

JTH_7
JTH_7 Registered Users Posts: 3
New Seeker
It's been plugged into the computer for hours but the screen still shows TOMTOM with the logo. I tried pressing on the on/off button for a long time but each time, after the little drum sound, it stays the same. Can anybody help?

Comments

  • VikramK
    VikramK Administrators Posts: 14,307
    Moderator
    edited July 21
    Hi @JTH_7
    Welcome to the community!
    Could you try a recovery mode, steps available in the video below-


    Regards,
    Vikram
  • JTH_7
    JTH_7 Registered Users Posts: 3
    New Seeker
    So the white text came up and I quickly pressed the button three times in succession, the screen goes dark for a short time, and then the Tomtom sign and logo come back. No spinning wheel. I tried it several times and the same thing happens each time.
  • JTH_7
    JTH_7 Registered Users Posts: 3
    New Seeker
    Hi - please could anyone help here? I already posted a question:

    "It's been plugged into the computer for hours but the screen still shows TOMTOM with the logo. I tried pressing on the on/off button for a long time but each time, after the little drum sound, it stays the same. Can anybody help?"

    Then a reply from Vikram with a video which I followed attentively, and tried several times. It didn't work so I posted another comment:

    "So the white text came up and I quickly pressed the button three times in succession, the screen goes dark for a short time, and then the Tomtom sign and logo come back. No spinning wheel. I tried it several times and the same thing happens each time."

    Is it impossible to fix? I'm leaving on a long trip in two days and it would be great to get it sorted out before then. Thanks in advance!
  • Willy875
    Willy875 Registered Users Posts: 6,604
    Elite Voyager
    Hi

    Have you tried with another cable?
    Have you tried with another computer?