Traffic Not working - Tomtom GO Premium X

tcattermole
tcattermole Registered Users Posts: 4
Apprentice Seeker
I have tried all of the recommended steps: restored the software from MyDrive, deleted and re-paired the Bluetooth connection to my Galaxy Note 8.
Settings shows that Traffic is subscribed, but the Traffic symbol shows 'X' and then "Service Unavailable"
How do I get Traffic working again?

Comments

  • VikramK
    VikramK Administrators Posts: 14,291
    Moderator
    Hi @tcattermole
    Welcome to the community!
    On a GO PREMIUM, the connection to TomTom Services works through a built-in SIM (smartphone pairing is not required).
    The device won't connect in a country or a location where 2G services have been discontinued. Which country are you located in?

    See also troubleshooting steps advised in the video below-



    Regards,
    Vikram.
  • tcattermole
    tcattermole Registered Users Posts: 4
    Apprentice Seeker
    Hi Vikram
    I am in the UK.
    Best
    TonyC
  • tcattermole
    tcattermole Registered Users Posts: 4
    Apprentice Seeker
    Hi Vikram
    I am in England, UK.
    I have tried resetting, but my Premium X then kept rebooting without ever stabilising.
    So I followed the YouTube video instructions to Restore my unit from MyDrive.
    Maps, Bluetooth connection to phone, and My Places all now working.
    But still no Traffic.
    Help/About shows Traffic as "Activated" but GPRS Status as "Disconnected"
    Clicking the Traffic icon shows Traffic as "Service unavailable"
    How do I get Traffic back?
    TonyC
  • VikramK
    VikramK Administrators Posts: 14,291
    Moderator
    Hi @tcattermole
    Thanks for trying...
    I am not sure, but this could be related to a SIM connectivity issue.
    My team did some changes in the backend, just do a soft reset and test it again.

    Should that fix the connectivity, then I would recommend contacting customer service for further guidance.

    Thanks,
    VIkram.
  • tcattermole
    tcattermole Registered Users Posts: 4
    Apprentice Seeker
    Hi Vikram
    Thank you very much - that has restored Traffic.
    All well now.
    Regards
    TonyC