TomTom Traffic Services not available, GO 50 device

sidxxxxx
sidxxxxx Registered Users Posts: 11
Apprentice Traveler
edited July 7 in TomTom Services
The traffic services on my TomTom Go 50 are not working. Serial number: VHxxxxxxx85.

They show as 'Activated' on the device but when you click on the car icon on the top of the display it says 'Service unavailable'.

Can anyone help with this? thanks




Mod edit: Please don't post private or personal information on a public forum. Thanks.

Answers

  • fergussion
    fergussion Registered Users Posts: 414
    Supreme Pioneer
    reset to factory settings and pair with smartphone for data
  • sidxxxxx
    sidxxxxx Registered Users Posts: 11
    Apprentice Traveler
    Hi, have already tried a reset and it did not work. It has also already been paired with my phone so thats not the issue. Thanks
  • Oleksandr_Kozachenko
    Oleksandr_Kozachenko Registered Users Posts: 5
    Novice Seeker
    Please tell me, did you manage to solve the problem? I have a similar story. I don't know what to do to display traffic. Dropped settings. Reconnected the phone - all to no avail. I would be grateful for tips on how to solve the problem?
  • sidxxxxx
    sidxxxxx Registered Users Posts: 11
    Apprentice Traveler
    Hey, yes I did in the end. After a few hard resets under the settings page on the device it did manage to connect to the traffic services. I also had to remove the device from my phone so it was a bit like starting the process again with regards to the smartphone link up via the TomTom Services menu on the device. Give it a try and it may work for you too.