Speed cameras alerts not working on the START 50 tomtom

Anderleee
Anderleee Registered Users Posts: 2
New Seeker
Hello!
I habe a TOMTOM Start 50. Today I made a MAP-Update. OK. Run OK. My Radarwarnerabo was expired. So I bought a new ABO. I successful installed the Radarupdate. But unfortunatly on my Start 50 unit the cameras will not display, so how before the update. I know some Cameras, but the will not displayed.
What can I do? You bought me the ABO, but it is not still running! Please help!!!

Best Answer

  • Anderleee
    Anderleee Registered Users Posts: 2
    New Seeker
    Answer ✓
    OK. And what's with the updates and downloads. Are they available? Or will they cleared by the reset? How I get them on the TomTom again??

Answers

  • rider1rider
    rider1rider Registered Users Posts: 1,543
    Revered Voyager
    soft reset or factory reset
  • Anderleee
    Anderleee Registered Users Posts: 2
    New Seeker
    Answer ✓
    OK. And what's with the updates and downloads. Are they available? Or will they cleared by the reset? How I get them on the TomTom again??
  • YamFazMan
    YamFazMan UKPosts: 21,480
     Superuser
    edited June 21
    Hi
    @Anderleee
    Welcome to the site....
    The restrictions as a result of the COVID-19 and people working from home, have delayed the Activation of Accounts and the Allocation of Maps & Services to Account’/Devices....
    @VikramK or @lampard the Forum Moderators should pick this up and check/correct your Tomtom Account status.....

    Stay Safe... ATB YFM
  • VikramK
    VikramK Administrators Posts: 14,712
    Moderator
    Hi @Anderleee,
    Welcome to the community on my behalf as well.
    I reviewed your TomTom account and I see that your TomTom has an active subscription for speed camera updates.
    Could try reinstalling the speed cameras:

    Connect device to MyDrive Connect > Go to My Content > Scroll down to the Speed Camera section and click on the drop arrow as shown in the image below-

    cgc4h7rrx0rk.png

    Disconnect the device and perform a soft reset.



    Connect the device again and check for updates in MyDrive Connect > Under 'My Content' tab

    Download and install the available updates for speed cameras.

    Once done, disconnect the device and follow-up with another soft reset again.

    Test the device on a planned route.

    Thanks,
    Vikram.