OCEANIA Truck Maps 34 Months Old

kaljade
kaljade Registered Users Posts: 7
Apprentice Traveler
So I recently purchased a Go Professional 620 for my work truck and it was a close choice between that and the competition as the other brand had some better truck specific features, but as I have used Tom Tom for my car GPS for many years and found that the regularity of map updates to be frequent enough to make it a superior candidate for the job.

This has certainly not been my experience thus far, just this week there was a delivery address in a two year old estate that did not appear in the truck map, but when I downloaded the Australia map (at an additional cost of course), it did appear.

So this makes me wonder if Oceania is abandoned due to lower than expected sales or maybe the market is too small for them to care, either way it has been a very underwhelming to say the least.

Looks like I'll be buying the competitor product after all and I guess this can be the new car GPS (seeing as I've already purchased a subscription for the car maps, lol).

Anyway, if you live in Australia or New Zealand, and are trying to decide which brand to buy for your truck maybe this will help?

End rant, haha

Comments

  • DougLap
    DougLap Posts: 9,833
    Superuser
    Hi @kaljade

    If there is a Truck specific map for Oceania ie a Map when selected you are able to input Truck details re Height Weight etc then you should get Quarterly updates. Look back here on Monday to see what @VikramK has to say after he has reviewed your unit settings on the TT servers and has sorted out any issues with your unit that he finds

    Doug
  • kaljade
    kaljade Registered Users Posts: 7
    Apprentice Traveler
    au17xlxyr0rg.jpg
    xsmp2273jaj7.jpg

  • YamFazMan
    YamFazMan Posts: 20,800
    Superuser
    edited May 8
    Hi
    @kaljade
    Welcome to the site....
    Looks like you have installed the OZ Car Map ???
    Tomtom Staff working from home, has delayed the Activation of Accounts and the Allocation of Maps & Services to Account’/Devices....
    @VikramK or @lampard the Forum Moderators should pick this up on Monday and check/correct your Tomtom Account status....
    44fl36hbh9pt.jpg
    Stay Safe... ATB YFM
  • kaljade
    kaljade Registered Users Posts: 7
    Apprentice Traveler
    YamFazMan wrote: »
    Hi
    @kaljade
    Welcome to the site....
    Looks like you have installed the OZ Car Map ???
    Tomtom Staff working from home, has delayed the Activation of Accounts and the Allocation of Maps & Services to Account’/Devices....
    @VikramK or @lampard the Forum Moderators should pick this up on Monday and check/correct your Tomtom Account status....
    44fl36hbh9pt.jpg
    Stay Safe... ATB YFM

    Hi @YamFazMan, thanks for the warm welcome!

    Yeah, I installed the car maps to find an address in a "new" (two years old) housing estate that was not listed in the truck maps.

    Thanks for explaining the situation with account activations and map allocations, that makes total sense.

    I look forward to hearing from the forum mods and seeing if there is something they can do to assist me.

    Cheers,

    Kal
  • VikramK
    VikramK Administrators Posts: 13,758
    Moderator
    Hi @kaljade
    Welcome to the community!
    My team has fixed the services for your TomTom, just do a soft reset and check for updates.



    Regards, Vikram
  • kaljade
    kaljade Registered Users Posts: 7
    Apprentice Traveler
    edited May 15
    @VikramK so things have gone from bad to worse. I followed the above steps and it said OCEANA Trucks was an invalid map so I could then only use the Australia car map I purchased and downloaded previously. Any attempts to download or delete the truck maps failed.

    This weekend I tried resetting the device to see if I could re-download, and now it's stuck on this screen:
    95zbe16m7z0g.jpg with no way of getting past it. I've even tried connecting it to my PC and doing the recover your device steps here: but still no dice.

    Any help would be greatly appreciated!

    Cheers,

    Kal
  • DougLap
    DougLap Posts: 9,833
    Superuser
    Hi @kaljade

    @VikramK should be back on the forum tomorrow.

    Doug
  • VikramK
    VikramK Administrators Posts: 13,758
    Moderator
    Hi @kaljade
    Did you delete the device from your account?
    I don't see the serial number linked when I search for the device using your email.

    Could you send me the serial number of your device through a private message by clicking on this link-https://discussions.tomtom.com/en/messages/add/VikramK, please ?

    Thanks, Vikram
  • kaljade
    kaljade Registered Users Posts: 7
    Apprentice Traveler
    VikramK wrote: »
    Hi @kaljade
    Did you delete the device from your account?
    I don't see the serial number linked when I search for the device using your email.

    Could you send me the serial number of your device through a private message by clicking on this link-https://discussions.tomtom.com/en/messages/add/VikramK, please ?

    Thanks, Vikram

    Thanks for looking into this for me.

    Serial number sent via PM as requested.

    Cheers,

    Kal