Speed cam purchase not working

kevinvanhooren
kevinvanhooren Registered Users Posts: 3
New Seeker
Hello,

I bought Speed Cam Warning for one month but it's not updating on my device. My device is een Go Discover. I tried reset but nothing is working.
My first device was a Via64 and never had problems. Since I bought this one, it's really a disaster!
I hope all problems are fixed soon.

Kevin.

Answers

  • DougLap
    DougLap Posts: 9,822
    Superuser
    Hi @kevinvanhooren

    You should contact Customer Support to ask them to check if your purchase has been allocated to your account.

    There have been no phone lines to Customer Support since the start of Covid and no indication that the facility will return.

    Try the following:-

    Tap Support at the top of this page
    You then HAVE to Sign in Top Right of next Page. (you have to do this)
    When signed in, and not before, Tap Contact Us bottom right
    Support Box appears and at the bottom with a message option
    Type Contact or Chat in the box
    If Chat is available you should be offered the chance to Tap Live Chat
    If it is Out of Hours for Chat you should be offered an option to message however I would recommend you try and use Chat

    If it does not work exactly as described then try another Web Browser.

    Doug
  • kevinvanhooren
    kevinvanhooren Registered Users Posts: 3
    New Seeker
    Hi @DougLap,

    Thx for your help and advice but even the chatbot isn't working. It's scrolling all the time with text and signs. I can't even type something. I tried on 3 different browsers and different devices.
    The after sale and customer support is terrible. Why not keep it simple like it was in the early days. If this continues like this, it will be my last TomTom.

    Grtz Kevin.
  • DougLap
    DougLap Posts: 9,822
    Superuser
    Hi @kevinvanhooren

    Works for me following exactly what I said using MacBook and Safari and Firefox.

    Are you sure you signed in where I told you too. You have to do this even although you were signed in on the Forum when you started. Chat is available during normal working hours.

    Doug
  • kevinvanhooren
    kevinvanhooren Registered Users Posts: 3
    New Seeker
    Hi Doug,

    It worked through mobile internet not through my home internet connection. Very strange!
    So I've managed to send mail. Hoping for a quick fix!

    Thx, for the help!
    Grtz Kevin.