Tomtom Discover services not activated

ARM_2808
ARM_2808 Canterbury Registered Users Posts: 6
Apprentice Seeker
Have just purchased the Tomtom discover and the traffic services are not activated? Have paired phone but cannot activate? Any idea?

Best Answers

  • DougLap
    DougLap Posts: 9,860
    Superuser
    Answer ✓
    Hi @ARM_2808

    Look back here tomorrow to see what @VikramK has to say after he has reviewed your units settings on the TT server and adjusted if required.

    Doug
  • VikramK
    VikramK Administrators Posts: 13,810
    Moderator
    Answer ✓
    Hi @ARM_2808
    All services are showing active for your GO Discover.
    Could you do a soft reset and check again?



    Regards,
    Vikram

Answers

  • ARM_2808
    ARM_2808 Canterbury Registered Users Posts: 6
    Apprentice Seeker
    Also do I need to connect to the MyDrive App as this does not connect and comes up with an error?
  • fergussion
    fergussion Registered Users Posts: 304
    Supreme Pioneer
    @ARM_2808
    go discover doesn't work with mydrive
    try factory reset and pair phone
  • ARM_2808
    ARM_2808 Canterbury Registered Users Posts: 6
    Apprentice Seeker
    Have done factory reset and paired and still no good
  • DougLap
    DougLap Posts: 9,860
    Superuser
    Answer ✓
    Hi @ARM_2808

    Look back here tomorrow to see what @VikramK has to say after he has reviewed your units settings on the TT server and adjusted if required.

    Doug
  • Lost_Soul
    Lost_Soul Registered Users Posts: 412
    Supreme Pioneer
    @ARM_2808

    Worthwhile checking that you have switched on the "Personal Hotspot" on your phone which is a requirement for the Go Discover.
  • VikramK
    VikramK Administrators Posts: 13,810
    Moderator
    Answer ✓
    Hi @ARM_2808
    All services are showing active for your GO Discover.
    Could you do a soft reset and check again?



    Regards,
    Vikram
  • ARM_2808
    ARM_2808 Canterbury Registered Users Posts: 6
    Apprentice Seeker
    Yes checked today after reset and show active. Many thanks.