How do I get TomTom Go to output audio over my Samsung S22 Ultra when connected to BT car kit?

Hoeksel
Hoeksel Registered Users Posts: 3
New Seeker
Hi,

I recently "upgraded" (between brackets as the intended upgrade is a huge disappointment) my Huawei P30 Pro (Android 10) for an Samsung S22 Ultra (Android 12). On my P30 pro I figured out I could set audio channels and got it working the way I wanted. If I am driving and my phone is BT connected to my car kit, I want TomTom to output audio over my phone speaker. This I want because it annoys me if a play BT music from my phone over my car kit, it get's interrupted when TomTom outputs audio.

On my current S22 Ultra (Android 12) and the latest TomTom Go Android version, I have 6 audio output channels but none of them acts the way I want. They all output over BT when I play BT audio in my car, they just have different behavior. I do not know how to get it working the way I want.

Does anybody know how I can get TomTom to work such that audio is ALWAYS done via my phone speaker?

PS: the channel options I have are 1) music channel 2) voice call channel 3) system channel 4) notification channel 5) alarm channel and 6) ring channel.

Comments

  • MUP
    MUP Registered Users Posts: 574
    Revered Pioneer
    edited April 16
    Do You have a S22U supported by Exynos or Qualcomm chipset?

    Your fone opens a BT channel to Your car and TT will enter this way.
    That's a problem of TT coding.

    The very 1st step should be enabling the dev options in settings of Your fone.
    https://www.samsung.com/uk/support/mobile-devices/how-do-i-turn-on-the-developer-options-menu-on-my-samsung-galaxy-device/

    After that You could disable A2DP, so TT will look for one of the remaining channels listed by You above.
    Music should be used by one of the other BT channel settings in dev options, just try it step by step.
    It depends on Your car and Your fone.
    Good luck.

    pzisdsd4ibp8.png
  • Hoeksel
    Hoeksel Registered Users Posts: 3
    New Seeker
    Hi MUP,

    Thanks for your reply. I have the Exynos S22 Ultra, I enabled "turn off A2DP hardware offload" and will check later if this works for me.

    Regards,

    Hoeksel
  • Hoeksel
    Hoeksel Registered Users Posts: 3
    New Seeker
    Just tested, disabling A2DP makes no difference. I also found the option "separate app sound" on my S22 Ultra, and added TomTom and set it to output to audio device "phone" i.s.o. my car. Also does not work.....sigh. It keeps outputting audio over BT to my car. I just want an option to use sound on my speaker phone only.
  • Kelstern
    Kelstern Registered Users Posts: 24
    Outstanding Wayfarer
    For me on my s22 ultra, having tomtom app audio set to "music channel" and the phone seperate app sound set to tomtom go /audio device phone it works for me.
    When your Bluetooth is connected to the car and tomtom is running, press the volume up button, tomtom will now have it's own volume bar. It might be that is on the quite side.vz72bupmm6o6.jpg