"Lets Go" button

MIKE_125169
MIKE_125169 Registered Users Posts: 4
Apprentice Seeker
edited April 16 in Devices using Wi-Fi®
The "Lets Go" button has disappeard from the screen of my Go Premium X device so maps no longer work. I have performed both a soft and full reset but nothing has worked. Any ideas?

Best Answer

  • YamFazMan
    YamFazMan Posts: 20,787
    Superuser
    edited April 17 Answer ✓
    Hi
    @MIKE_125169
    Welcome to the site....
    The "Lets Go" button has disappeared from the screen of my Go Premium X device so maps no longer work (Snip)
    Is your device is showing a small satellite dish Icon (Top left of the Traffic Bar) ???
    If 'Yes' the device hasn't achieved a Satellite lock
    In my experience the 'Let's Go' button does not appear if the device is searching for a Satellite lock....
    If the device has locked onto the Satellites, then the Satellite dish Icon will disappear and the correct time should display on your device....
    01f9db41-6004-465a-a1ad-75bff5da79cb.jpg
    A Drum-roll Soft Start can help.... Hold the ON/OFF Power button in until you hear a Drum-roll sound... Then release the button.... This will reinitialize the device's Operating System, like restarting your PC
    Fully charge the Battery (At least 2 Hours)
    (Preferably using something like a Smartphone Charger + Using the Tomtom USB lead)
    A low battery can cause GPS Satellite fix problems...
    First Plan a route on the device... Now place the device outside with a clear view to the sky
    (I used a 5200 mAh battery power-pack... while waiting for a Satellite lock)
    It can take anything up to 30 Minutes to get the first Satellite Lock
    After the Initial 'First Lock' the device should lock quickly onto the Satellites

    Stay Safe... ATB YFM

Answers

  • Willy875
    Willy875 Registered Users Posts: 5,330
    Revered Voyager
    Is it a reset via the power button or is it a factory reset of the device you did?
  • MIKE_125169
    MIKE_125169 Registered Users Posts: 4
    Apprentice Seeker
    I did both. The reset via the power button and a factory reset.
  • YamFazMan
    YamFazMan Posts: 20,787
    Superuser
    edited April 17 Answer ✓
    Hi
    @MIKE_125169
    Welcome to the site....
    The "Lets Go" button has disappeared from the screen of my Go Premium X device so maps no longer work (Snip)
    Is your device is showing a small satellite dish Icon (Top left of the Traffic Bar) ???
    If 'Yes' the device hasn't achieved a Satellite lock
    In my experience the 'Let's Go' button does not appear if the device is searching for a Satellite lock....
    If the device has locked onto the Satellites, then the Satellite dish Icon will disappear and the correct time should display on your device....
    01f9db41-6004-465a-a1ad-75bff5da79cb.jpg
    A Drum-roll Soft Start can help.... Hold the ON/OFF Power button in until you hear a Drum-roll sound... Then release the button.... This will reinitialize the device's Operating System, like restarting your PC
    Fully charge the Battery (At least 2 Hours)
    (Preferably using something like a Smartphone Charger + Using the Tomtom USB lead)
    A low battery can cause GPS Satellite fix problems...
    First Plan a route on the device... Now place the device outside with a clear view to the sky
    (I used a 5200 mAh battery power-pack... while waiting for a Satellite lock)
    It can take anything up to 30 Minutes to get the first Satellite Lock
    After the Initial 'First Lock' the device should lock quickly onto the Satellites

    Stay Safe... ATB YFM
  • MIKE_125169
    MIKE_125169 Registered Users Posts: 4
    Apprentice Seeker
    Hello YamFazMan
    I have just read your post and will attempt to follow the steps you suggest. I will advise once complete.

    Thanks

    Mike
  • MIKE_125169
    MIKE_125169 Registered Users Posts: 4
    Apprentice Seeker
    Hello YazFaz Man

    This worked perfectly. Thank you for your assistance.

    Regards

    Mike
  • YamFazMan
    YamFazMan Posts: 20,787
    Superuser
    Hi
    @MIKE_125169
    You're welcome, glad you're sorted :)
    To help others in the community with similar problems....
    If my reply answered your question ???
    Then on my Reply... Please answer 'Yes'
    To... Did this answer the question? 'Yes'< >' No'

    Stay Safe... ATB YFM