speed cameras not visible on device TomTom GO 520 wifi.

Mariusz_1980
Mariusz_1980 Registered Users Posts: 1
Apprentice Seeker
edited April 13 in Devices using Wi-Fi®
The device frequently updates the speed cameras, but they are not visible on the device. Sometimes I only see mobile speed cameras. What could be the reason for this?

Comments

  • VikramK
    VikramK Administrators Posts: 13,815
    Moderator
    Hi @Mariusz_1980,
    Welcome to the community!
    The services for speed cameras on your account looks okay. I would suggest that you remove the existing database of speed cameras and then do a fresh installation.

    1. Remove speed cameras using the Remove Content tab in MyDrive Connect. (Procedure explained here- https://discussions.tomtom.com/en/discussion/1137413/an-interface-upgrade-in-mydrive-connect-we-have-added-a-remove-content-button)
    2. Perform a soft reset -

    4. Reinstall speed cameras and follow up with another soft reset.
    5. Test the device on a planned route.

    - Vikram
  • YamFazMan
    YamFazMan Posts: 20,833
     Superuser
    Hi
    @Mariusz_1980
    For general improvement using the Tomtom Speed Cam Database over the default settings

    Always use a Computer voice...
    Here in the UK, it's Serena or Malcolm
    Also....
    From the main screen... Tap (.... Menu) -> Setting -> Sounds & Warnings...
    Set... 'Warning Type' to... Read Allowed... (Important... Needs a Computer Voice set in the Voices menu)
    Speed Cameras & Hazards... Set to ON
    The next 10 Setting ALL set to Always
    The next 4 Settings ALL set to ON
    Now, along with the standard triple 'dong dong dong' warning, the device will now say....
    'Fixed Camera'
    'Mobile Camera'
    'Mobile Hot Spot'
    'Average speed zone'
    'Red-light Camera'
    'Accident Black-spots
    ‘Spoken Traffic delays’


    Also keep an eye on the Traffic Bar....
    You can see a speed camera many miles ahead....

    Stay Safe... ATB YFM