tomtom home help

jacob3425
jacob3425 Registered Users Posts: 1
Apprentice Seeker
edited April 10 in Devices using TomTom HOME
i have a mac running 10.12.6, dowloaded tomtom home version that supports my mac os, however it wont install saying my mac os is unsupported.

if i then try installing an older version of TTH it says update to latest version and then i get the same problem !!
Tagged:

Answers