GO 520 with Wifi from Amazon does not show included lifetime maps, traffic and speed cameras

NSheard
NSheard Registered Users Posts: 6
New Seeker
I bought a GO 520 with Wifi from Amazon that is meant to have included lifetime maps, traffic and speed cameras. In MyDrive it registers only as a Go Essential and only has a 3 month trial of speed cameras and no live traffic service. Could someone from TomTom please resolve this?

Answers

  • Bembo
    Bembo ZentralschweizPosts: 16,842
    Superuser
    Hallo @NSheard

    Am besten meldest du dich im Support Chat. Weil hier im Benutzer Forum wird dir keiner gross helfen können.

    https://discussions.tomtom.com/de/discussion/comment/1722150#Comment_1722150

    mfg. Bembo
  • NSheard
    NSheard Registered Users Posts: 6
    New Seeker
    Thanks! will do
  • DougLap
    DougLap Posts: 9,822
    Superuser
    Hi @NSheard

    Look back here later to see what @VikramK has to say after he has reviewed your units settings on the TT servers and adjusted them if required.

    Doug
  • NSheard
    NSheard Registered Users Posts: 6
    New Seeker
    Ok Thanks! I did chat with support who have now enabled lifetime speed cameras. But as far as I can tell the traffic isstill not working despite a bluetooth connection to my Android Pixel 3a. Under Bluetooth it shows as 'Data for Traffic & Other Services' 'Unable to connect'. Hands free calls work though.

    On the portal it still shows as a Go Essential (rather than GO 520 Wifi) and also does not list the available maps and subscriptions anymore so not sure what has happened now
  • DougLap
    DougLap Posts: 9,822
    Superuser
    Hi @NSheard

    I am flagging this to @VikramK for his help. It will be tomorrow now I suspect.

    Doug
  • NSheard
    NSheard Registered Users Posts: 6
    New Seeker
    Hi @DougLap - many thanks for your help!
  • VikramK
    VikramK Administrators Posts: 13,709
    Moderator
    Hi @NSheard
    I reviewed the subscriptions on your GO WiFI 520 (serial number ending 166) and all embedded service are active.
    The device also is on the latest map of Europe v10.85.

    Regarding TomTom Traffic not working, I would suggest that you do a factory reset and pair the phone again to see if that gets it going.
    You will find detailed steps to get the device paired on our support article here- https://help.tomtom.com/hc/en-gb/articles/360013958659

    Thanks,
    Vikram.
  • NSheard
    NSheard Registered Users Posts: 6
    New Seeker
    ok thanks very much @Vikram. I will experiment a bit more with it to see if I can get it to connect
  • NSheard
    NSheard Registered Users Posts: 6
    New Seeker
    After resetting everything and re-doing the bluetooth connection it all works now - thanks all for you help. Looking forwards to trying it all out on a long road trip tomorrow