GO Discover 7 inch device issue

PJJB
PJJB Registered Users Posts: 7
Apprentice Seeker
edited March 30 in Devices using Wi-Fi®
I have no touch screen control.[/b] For example: the #1 will not execute in the 'search function'. Also unable to view the settings menu to try a hard update or see if any updates are available. I can get to sub-categories screen, but cannot return to previous screen unless I shutdown and restart. The device is FULLY charged using both the supplied cable and an alternate cable. I do get the 'drum roll' when starting. Tom Tom replaced my previous GO Discover 7 in. model for almost the exact problem. VERY disappointed with this device. Need suggestions please.

Answers

  • Willy875
    Willy875 Registered Users Posts: 5,444
    Revered Voyager
    Do you have access to factory reset menu.?
  • PJJB
    PJJB Registered Users Posts: 7
    Apprentice Seeker
    NO....been trying to get there.
  • Lochfrass
    Lochfrass Posts: 17,779
     Superuser
    Turn on the device and hold the "on button" about 20seconds til you herar the drum sound. the leave the button.

    If that not works:
    Shut down the device to a real off (not Sleepmode)
    Then hold the "On Button"til you see the TomTom Logo. Then release it briefly and immediately press and hold it again.
    It should then change to a black screen with white text where you can see device details.
    From there you can enter the recovery mode as described on the help page.
    The 3presses must made within 1 sec.
    https://help.tomtom.com/hc/en-us/articles/360013959579-Navigation-device-not-starting-or-displaying-a-cross
    That process recovers the firmware of the device.
    Crossing my fingers that it work for you.
  • PJJB
    PJJB Registered Users Posts: 7
    Apprentice Seeker
    Hello Lochfrass.... Thank you for your suggestion. Actually I followed your directions...Got to the white print on the black screen...waited and got a graphic with a computer cable strung between a computer and TomTom device....the cable was red in color on the computer side. Never has a swirling "load' symbol. Connected cable to computer data USB, and after a minute or so, the TomTom rebooted with a very slow white 'progress' line, making me believe software was loading into TT device...Then it rebooted with a normal progress line and still get only a map depiction where the bottom left "menu" does nothing. The search screen can be selected, with no keys working. Tried this many times.
    I think part of the problem is my GO DISCOVER does not show in MY Drive. I tried to load my unit in the ADD screen but can not do this because I can't get to the "settings" screen. So, full disclosure I previously had the Discover with Serial number there, but I removed it thinking I could simply reload the info....which I can not. Geeesch...very frustrating. Any idea on how to "ADD" my device/serial into TomTom?? Can't get WiFi because no 'settings' screen. Sorry for the long reply, but this is where I'm at. Hard to convince TomTom customer service to send for repairs or replacement. Thanks again for any assistance. //PB