TomTom 400, Mydrive wants to load Europe Maps V 10.85, 10.85 already on device but reporting no maps

Multistrider
Multistrider Registered Users Posts: 29
Master Explorer
Big issue where Mydrive computer programme struggles to connect with device, reports 4 items to load including full Europe maps 10.85, Insufficient memory so reduce content. 10.85 already on device according to content tab. Device reports no maps, constant Updating whirlygig constantly running. Device unusable, Fed up!!

Comments

  • Willy875
    Willy875 Registered Users Posts: 5,330
    Revered Voyager
    You may be able to add an SD of 16 or 32 GB maximum so as not to have an insufficient memory problem currently we are at version 10.85
  • Multistrider
    Multistrider Registered Users Posts: 29
    Master Explorer
    Hi Willy, SD card already installed but not identified by MyDrive. I’ve uninstalled MyDrive and will run a new App download and see if that clears it. I had to do that with Sena device manager yesterday.
    I’ll let you know if it works.
    John
  • Willy875
    Willy875 Registered Users Posts: 5,330
    Revered Voyager
    If Mydrive connect does not see your SD, format your SD with your computer then insert the SD again into the GPS to format it again.
  • Multistrider
    Multistrider Registered Users Posts: 29
    Master Explorer
    Thank you Willy. The uninstall of MyDrive and reloading has solved the problem. There was a large MS Windows10 update which took 4 hours to complete which might also have caused the app to struggle to read the device content. I’m pleased to say the Europe maps v10.85 has been fully installed and functions correctly now.
    Sorry if I was blaming MyDrive it appears it may have been my PC that caused the blip!