TomTom Sports Connect App - Opens in Wrong Browser

LightRunner
LightRunner Registered Users Posts: 2
New Seeker
This may be more of a Windows question than a TomTom Sports app question. I use different browsers for different things. I connected my watch to a reloaded computer, which means all the defaults were to ask you how you wanted to connect thing. I tried to open the TomTom Sports Connect app and may have clicked it twice. When it finally opened and I clicked on the TomTom Sports link in the middle of that app, it asked me which browser I wanted to open it in. I opened it with Firefox. I was about to click "set as default" and then a second TomTom Sports Connect app opened and right away opened in the Edge browser. I was clicking set as default for Firefox, but saw just as I clicked it, it went to Edge.

I've been through all the Default app settings in Windows 11 and can't find an app called TomTom Sports Connect. I've uninstalled the TomTom Sports Connect app and reinstalled, but that did nothing.

Thank you in advance for any help you can provide.

Thank you,
Frank

Answers

  • tfarabaugh
    tfarabaugh Posts: 16,943
     Superuser
    It would not be a default app since you installed it, it would be under Programs & Features or whatever they call it now in Win11. But it is not TT Sports that is set to use Edge it is using whatever the default browser in Windows is, so you need to find that setting.
  • LightRunner
    LightRunner Registered Users Posts: 2
    New Seeker
    Thank you tfarabaugh for your help. I changed the default browser for .htm and .html to Firefox. The app still opens in Edge.
  • tfarabaugh
    tfarabaugh Posts: 16,943
     Superuser
    Thank you tfarabaugh for your help. I changed the default browser for .htm and .html to Firefox. The app still opens in Edge.

    It is not opening an htm or html file, it is an internet shortcut opening a URL. What is listed as the browser under default apps? Mine was set to Edge and when I clicked the shortcut it opened in Edge. I then changed the default browser to Chrome, clicked the shortcut and it opened n Chrome. I changed it back to Edge, clicked the shortcut again and it opened in Edge.
  • [Deleted User]
    [Deleted User] Posts: 0
    Supreme Pioneer
    Hi Everyone :)

    Kindly note that there isn't a way to set Chrome as a default in one click, that is still in testing right now, though you have to go to Default Apps --> Chrome, then you have to put everything to Chrome, you will have to select each one and press chrome, yes to all the prompts.

    Though some parts of the OS will still open in Edge, it's the same with Apple devices which some places still open in another browser. Anyways it shouldn't impact how you will use the TT app :)

    Have a great day!

    Shawn