Golf 2 SE watch will not update courses and now stuck in that mode and won't at all

ShrpGolf
ShrpGolf Registered Users Posts: 1
New Seeker
Have tried to update Golf 2 SE watch on Windows 10 and it updates ok first but then stops on updating golf courses. It just states: oops, something went wrong. We have tried resetting, tried turning off, updating (after reinstalling app). It is now just stuck and has a picture of a usb stick on the screen. We can't do anything with it at all. Does anyone have any suggestions (other than throw it away) please? Thanks.

Answers

  • HvdW
    HvdW Registered Users Posts: 41
    Renowned Wayfarer
    Did it fail to reset?
    I had some trouble with my watch and tried another USB port.
    Since that moment I know the first USB port of my computer is defective.
  • tfarabaugh
    tfarabaugh Posts: 16,935
    Superuser
    A few things to look at (and I apologize if some are very basic, but it is best to get past the obvious issues first):

    1) Are you plugged directly into the machine and not a hub?
    2) Does the port work, can the computer detect other devices (like flash drives) in that port?
    3) Is the watch firmly snapped into the cradle and the USB plug firmly in the port?
    4) Is the USB port free of any debris or blockages?
    5) Is the Connect software running (is there an icon for it in the notification area)?
    6) Did you install Sports Connect, not MyDrive Connect? It is downloaded from tomtom.com/123
    7) Do you have administrator rights to the computer?
    8) Is a firewall or antivirus running that is blocking the software from connecting to TomTom (try turning them off before docking the watch)?
    9) Does the computer have a good Internet connection (Internet is required to sync)?
    10) Can you try installing it on a different machine to determine if it is an issue with the computer versus the watch?

    For computer connection issues, is there any damage to the pins in the charger or the contacts on the watch? If any of the pins are bent or deformed straighten them out with a pin and make sure the contacts on the back of the watch are free of tarnish or grime. Also make sure it is fully snapped into the cradle. Are you getting any error messages when you plug the watch in or is it being recognized at all? Does the clock face change to a battery charging icon (which indicates it is getting power so there is a partial connection)?