GO 5200. TomTom Traffic not working anymore

tmrafa
tmrafa Registered Users Posts: 19
Master Explorer
edited February 22 in TomTom Services
Hi all,

TomTom Traffic is not working anymore in my GO 5200 device.
System info states "You have a TomTom traffic subscription".
But GPRS status is disconnected and gets not connected no matter how long I wait.

Can anybody please help recover the Traffic service?

Answers

  • Willy875
    Willy875 Registered Users Posts: 5,319
    Revered Voyager
    Hi

    Are you in Belgium?

  • tmrafa
    tmrafa Registered Users Posts: 19
    Master Explorer
    Hi Willy875, I am in Spain.
  • Willy875
    Willy875 Registered Users Posts: 5,319
    Revered Voyager
    Factory reset the device.

    Procedure to do if your Go is no longer under warranty.

    Some users take out the SIM card which is under the label, wipe it gently then reinsert it
  • tmrafa
    tmrafa Registered Users Posts: 19
    Master Explorer
    What label? How can I take out the SIM card? Is there any video or picture showing the process?
  • DougLap
    DougLap Posts: 9,822
    Superuser
    edited February 22
    Hi @tmrafa

    On the bottom of the GO5200 is the serial number label next to the extra memory slot. If you, at your own risk, very very carefully remove it so that you can replace it afterwards you will see the Mobile Sim under it. You can carefully pull the sim out with fine tweezers making sure to avoid static electric. If you push the sim in and out a few times this can help clean the contacts inside the unit. It may also help to clean the sim contacts with a clean pencil rubber. Make sue to cover the sim in its slot with the label after you have restored it to the device

    Doug
  • tmrafa
    tmrafa Registered Users Posts: 19
    Master Explorer
    Thank you DougLap,

    I'll try and comment back
  • tmrafa
    tmrafa Registered Users Posts: 19
    Master Explorer
    edited February 22
    Hi @DougLap

    I have followed your recommendations (cleaning the sim with a pencil rubber and pushing the sim in and out a few times). But unfortunately it didn't work for me.

    Tomtom Traffic is still out of service for me :/

    Best regards
  • Willy875
    Willy875 Registered Users Posts: 5,319
    Revered Voyager
    @tmrafa
    You will need to contact customer service, they will see if your Sim card is still activated.
  • DougLap
    DougLap Posts: 9,822
    Superuser
    Hi @tmrafa

    Have a look back here later to see what @VikramK has to say after he has checked your units settings on the TT servers. There may be an issue he can resolve.

    Doug
  • tmrafa
    tmrafa Registered Users Posts: 19
    Master Explorer
    Hello @Willy875 and @DougLap

    I am a little bit confused

    Is VikramK going to contact me?
    Should I contact customer service as Willy875 advised?

    Best regards
  • Willy875
    Willy875 Registered Users Posts: 5,319
    Revered Voyager
    Hi

    You can do both

    contact customer service and wait for the moderator to verify your account.
  • VikramK
    VikramK Administrators Posts: 13,709
    Moderator
    Hi @tmrafa
    The services for your GO 5200 look okay. It's best to get in touch with our customer service team to review the SIM status and see what they have to advise further.

    Regards,
    Vikram.
  • tmrafa
    tmrafa Registered Users Posts: 19
    Master Explorer
    Thank you VikramK and Willy875.

    I have opened a support request.

    Best regards