Trucker Map US/Canada was accidentally deleted, where can I download the map again

Lexpilant
Lexpilant Registered Users Posts: 7
Apprentice Seeker
I just bought the Trucker 520 GPS, the Trucker map was dated 2018, I tried to download a different map to test whether it was up to date, it won't fit, so I deleted the trucker map from the device, is there anyway to recover the trucker map, it not listed under Maps option

Answers

  • Willy875
    Willy875 Registered Users Posts: 5,417
    Revered Voyager
  • DougLap
    DougLap Posts: 9,851
    Superuser
    Hi @Lexpilant

    Look back here later to see what @VikramK has to say after he has reviewed your units settings on the TT servers.

    Doug
  • VikramK
    VikramK Administrators Posts: 13,787
    Moderator
    Hi @Lexpilant
    If you check for updates now, the TRUCKER version of the map should be offered as a download.


    Regards, Vikram.
  • Lexpilant
    Lexpilant Registered Users Posts: 7
    Apprentice Seeker
    Hi, Vikram,

    The situation is even worst now, my device cannot connect to MyDrive Connect in the computer, it is keep asking me "Do you want to add this device?" I followed the on screen instruction, doesn't work.

    If I click on "Updates and New Items" on the GPS, it tells me "The Trucker 520 is up to date!"

    If I click on "Maps" on the GPS, I click on "Add Maps", no maps displays, I lost the ability to add any maps, this is bad.
  • Lexpilant
    Lexpilant Registered Users Posts: 7
    Apprentice Seeker
    Hi, Vikram,

    I think you might have erased my device from associated with my account, my GPS is no longer listed under the account, can you reverse what you did on the TT server please? Because I cannot add my device to my account no matter what I try.
  • VikramK
    VikramK Administrators Posts: 13,787
    Moderator
    Try this-

    1. Disconnect the device from the computer.
    2. Perform a factory reset- Main menu- Settings- System- Reset
    3. Log-in to MyDrive on the device- Main menu Settings- MyDrive
    4. Now connect the device to the computer and open MyDrive Connect.

    Do you see your device listed under your account?

    Thanks, Vikram
  • Lexpilant
    Lexpilant Registered Users Posts: 7
    Apprentice Seeker
    I did what you told me, but when i connect the device to the computer, My Drive Connect keeps asking me "Do you want to add this device?" I clicked "continue", it keeps poping the same message,

    If I login to my account on your web site, my device is not listed under my account, i also lost the ability to add any map on my device using Wifi, no maps listed, when I click "add maps"

    Please help, my last day of returning this device to Amazon is Mar 17, I need to know if this device is defective or not to make a decision, it was working before you change some settings on the TT server.
  • Lexpilant
    Lexpilant Registered Users Posts: 7
    Apprentice Seeker
    Hi, Vikram,

    I was able to connect to my device to My Connect Drive, I solved it by clear browser cache and cookies.

    Now my device is listed under my account, however, I still lost the ability to add any map on my device, no maps listed, when I click "add maps"

    And

    US and Canada Trucker map recovery issue still not resolve yet.
  • Willy875
    Willy875 Registered Users Posts: 5,417
    Revered Voyager
    Hi @Lexpilant

    Come back tomorrow, moderator @VikramK will review your account and assign you the service.
  • VikramK
    VikramK Administrators Posts: 13,787
    Moderator
    Hi @Lexpilant
    For some strange reason, the services have been activated on your account yet..
    Could you do another soft reset, log in to your TomTom account on the device and check for updates?

    Regards,
    Vikram.
  • Lexpilant
    Lexpilant Registered Users Posts: 7
    Apprentice Seeker
    The GPS is completely screw up after the soft reset / factory reset.

    I did what you told me, but when I connect the device to the computer, My Drive Connect keeps asking me "Do you want to add this device?" I clicked "continue", it keeps popping the same message. (the previous fix of clearing the cookies and cache doesn't work anymore)

    If I login to my account on your web site, my device is not listed under my account, I also lost the ability to add any map on my device using Wifi, no maps listed, when I click "add maps"

    Very disappointing, the GPS lost the lifetime map features completely.
  • Willy875
    Willy875 Registered Users Posts: 5,417
    Revered Voyager
    Hi
    Lexpilant wrote: »

    Please help, my last day of returning this device to Amazon is Mar 17, I need to know if this device is defective or not to make a decision, .

    The solution to solve your Amazon return problem.
  • DougLap
    DougLap Posts: 9,851
    Superuser
    edited February 25
    Hi @Lexpilant

    You should not need to connect your GO520 professional to your PC in order to update if you can connect it to your Wifi directly.

    If you connect your unit to your Wifi can you download a small map like Venezuela. If you can then you will be able to delete any other maps you may have on the unit. Following that then go to Settings/Updates and new items on the unit and see if there is a Truck Map to add. If not there look in Settings/Maps/Add a Map to see if you can find the Truck map there.

    Regarding seeing the new unit listed when you open My Drive Connect you can sometimes resolve this by doing a Factory Reset and setting the unit up again as you did when you first got it. If not it is possible to get one of the Mods on here to add it.

    Doug

    Ps if you add a small map leave it there as having 2 maps on the unit is beneficial in the event of you losing your main map.
  • Lexpilant
    Lexpilant Registered Users Posts: 7
    Apprentice Seeker
    Hi, DougLap,

    In Wifi mode and MyDrive Connect mode, there is no maps under add new map option, did factory reset many time, uninstall / install My Drive Connect many times, nothing works. I am a Tomtom GPS user since 2009, so I am experienced with TomTom devices, never experienced this. Hopefully Mods can fix it.