New(?) Site - Rubbish!

CatNip
CatNip Registered Users Posts: 487
Sovereign Trailblazer
edited February 22 in Forum feedback
This is the first time I have visited this New(?) TomTom site (for the MyDrive Connect/GPS Quick Fix bug). It wasn't easy! I had to:

1. Waste oodles of times on your ridiculous - To Infinity & Beyond - Captcha
2. Fail to log on with my credentials
3. Fail in my attempt to create a new account
4. Change to a new browser
5. Waste even more time on that ridiculous Captcha
6. EVENTUALLY manage to log on with my original credentials

Lesson One: THAT BL****** CAPTCHA HAS GOT TO GO!

Comments

  • rider1rider
    rider1rider Registered Users Posts: 1,417
    Exalted Pioneer
    clearing browser history cookies can help
  • CatNip
    CatNip Registered Users Posts: 487
    Sovereign Trailblazer
    edited February 23
    ...And another thing!

    The Message system on this site defeats me. I want to simply reply to a message I have received (in Dutch), how do I do that simple thing? I can't tell. I don't want to "Add People to this Conversation" I simply want to reply to a message!

    The Message editor appears not to have a way of including another message - i.e. that you are replying to. Plus no apparent way of actually viewing/editing a message before sending...

    The person I am replying to has a username with an odd character in it that I do not know how to reproduce via the keyboard and seemingly I CANNOT COPY via Copy&Paste! So... altogether, I appear unable to reply to them via the message system. I have send one reply... seemingly to myself. :|

    I cannot think of anything other than trying to guess if they saw my username on a particular board and post their message and my reply there.

    This is NOT looking good. In so very many ways...
  • CatNip
    CatNip Registered Users Posts: 487
    Sovereign Trailblazer
    ...And the above post is NOT how I wrote it! I have edited it three times, it's still wrong.

    Time to give up on this by the look of it...
  • CatNip
    CatNip Registered Users Posts: 487
    Sovereign Trailblazer
    edited February 23
    For the attention of Joris100_

    "Wij hebben altijd via Ziggo onze Tom tom Go premium geüpdatet. Sinds kort hebben wij een andere provider, KPN via Budget energie. Als we nu ons navigatiesysteem willen updaten krijgen we bij beschikbare netwerken steeds de berichten , verbinding maken, verifiëren, opgeslagen en uiteindelijk Authenticatieprobleem. Wat staat ons te doen?
    Bij voorbaat dank."

    "We have always updated our Tom tom Go premium via Ziggo. Recently we have another provider, KPN via Budget energie. If we now want to update our navigation system, we always get the messages, connect, verify, save and finally authentication problem with available networks. What do we have to do?
    Thanks in advance."

    Dear Joris100,

    Could you please post your question on the TomTom Go Premium board:

    https://discussions.tomtom.com/en/search?query=tomtom go premium&scope=site

    I only have a Start 25 which updates using MyDrive Connect.

    CatNip