No GPRS connection on Go Premium

GeertVh
GeertVh Belgium GhentRegistered Users Posts: 3
Apprentice Seeker
Since the last system update my 8 month old Go Premium does not connect anymore to GPRS, so no MyDrive and no Traffic...
My other device Go 5100 funtions well with GPRS conntection. I did everyting (cold reset, last update, ...), nothing works. With a wifi connection traffic works, but that is not the problem. I cannot not use my device anymore in the car!
So how can TomTom fix this?
thanx for a quick solution.

Answers

  • Willy875
    Willy875 Registered Users Posts: 5,330
    Revered Voyager
    edited February 18
    To try.

    Factory reset the device.




    You are on a user forum for direct questions to Tomtom.

    How to contact TomTom customer support by chat or email
    https://help.tomtom.com/hc/en-gb/articles/360015568919/

    How to contact TomTom customer support by email
    https://help.tomtom.com/hc/en-gb/requests/new?ticket_form_id=360000679560
  • YamFazMan
    YamFazMan Posts: 20,787
    Superuser
    Hi
    @GeertVh
    You haven't stated your Home Country in your forum profile....
    There's a known problem in Belgium (Under investigation)....
    On the Go Premium... Startup screen bottom left... Check...
    Tap the 4Dot (.... Menu) --> Setting --> System --> About... Scroll down to Data Connection....
    If the data connection displayed is Wi-Fi, USB or Bluetooth....
    See... https://discussions.tomtom.com/en/discussion/comment/1752190/#Comment_1752190
    Turn off the disruptive Wi-Fi, USB or Bluetooth data connection or connections

    Recheck GPRS Status....
    Tap 4Dot (.... Menu) --> Setting --> System --> About... Scroll down to GPRS Status

    Stay Safe... ATB YFM
  • GeertVh
    GeertVh Belgium GhentRegistered Users Posts: 3
    Apprentice Seeker
    Hi YamFazMan

    Thank you for all suggestions.
    Indeed, my country is Belgium. I did everything you suggested, but GPRS status remains 'not connected'.
    Any idea how long the investigation will take? The problem has been going on for almost 2 months...

    Should I email to Tomtom directly?
    But how? The links
    - How to contact TomTom customer support by chat or email https://help.tomtom.com/hc/en-gb/articles/360015568919/
    and
    - How to contact TomTom customer support by email https://help.tomtom.com/hc/en-gb/requests/new?ticket_form_id=360000679560
    redirect immediately to the discussions website...

    GeertVh
  • Willy875
    Willy875 Registered Users Posts: 5,330
    Revered Voyager
    Delete your cookies on your browser.

    This is a Tomtom bug, so sending an email will not expedite the bug fix.
  • GeertVh
    GeertVh Belgium GhentRegistered Users Posts: 3
    Apprentice Seeker
    OK, thanks.
  • winerwalker
    winerwalker Registered Users Posts: 12
    Apprentice Traveler
    I’ve had the same problem since at least November ‘21. I was told they were aware of a problem with their GPRS provider. I chased support over and over and eventually they accepted my GO5000 back for free “repair” - though it works fine except for the GPRS/SIM problem. It’s on its way back to Romania at the moment so I don’t know if they will fix it or not.
    Seems to be a widespread problem with TT, not with individual devices.