Can't get past NAV4 installation

cjj0701
cjj0701 Registered Users Posts: 4
Apprentice Traveler
Hi tomtom admin. I have to update nav4 before any other updates, tried on my Lenovo PC running windows 11. Reached 25% and just hung at that point. Swapped to a windows 10 laptop reached 100% and has now been checking for hours. Please advise how you can resolve this issue for me.

Comments

  • VikramK
    VikramK Administrators Posts: 14,710
    Moderator
    Hi @cjj0701
    Welcome to the community!
    Did you get this sorted already? I reviewed the download logs in the backend, and it seems the RIDER is on the latest firmware version 21.200.0003

    Regards,
    Vikram.
  • cjj0701
    cjj0701 Registered Users Posts: 4
    Apprentice Traveler
    Unfortunately not. Happy I have the latest firmware confirmed, but still have the issue.
  • cjj0701
    cjj0701 Registered Users Posts: 4
    Apprentice Traveler
    qtgalbwkgmry.png
  • RoadRider
    RoadRider Registered Users Posts: 750
    Revered Pioneer
    edited February 3
    Check your antivirus an firewall settings.
    (You can try to disable it during the test)
    And Clear the MyDrive Connect cache.

    And retry

    (Re enable AV and Firewall)
  • cjj0701
    cjj0701 Registered Users Posts: 4
    Apprentice Traveler
    Hi Road rider, followed all suggestions, and also closed VPN, finally, got to 100% and now it's still checking after, maybe 4 hours. Appreciate the help.
    Vikram, as an admin I would expect more... Maybe we as users of older units are not important any longer.... you have any additional information to impart to assist in solving this issue?
    jkwtisfsgleb.png