TomTom Go 600 won't connect to Mac any more

coffee_king
coffee_king Registered Users Posts: 29
Master Explorer
Hi
I'm trying to update my Go 600 using my Mac but it won't show as a connection. I've tried different USB leads and different USB ports directly on my Mac.
The My Drive Connect app (Just updated) constantly shows "Connect your device to see the latest status, available updates and the removable content".
I am running macOS Big Sur 11.6.3
The TomTom WILL charge over the various USB ports and leads.
Please advise?

Comments

  • coffee_king
    coffee_king Registered Users Posts: 29
    Master Explorer
    Hi.
    Thanks for your response.
    I can't even get past step 1

    1. Click the plus (+) button at the bottom left and select the TomTom Interface.

    There is no "TomTom Interface" listed when I press the (+) button.
  • coffee_king
    coffee_king Registered Users Posts: 29
    Master Explorer
    Nor does this work on a Mac running High Sierra 10.13.6
    It wont show up in Finder or in Network. Nor can you make it appear by doing Step 1
    Again though, it DOES charge while being plugged in by USB though.

    On both Macs the splash screen on the TomTom that usually shows "Connected to Computer" doesnt show up when plugged in.
  • coffee_king
    coffee_king Registered Users Posts: 29
    Master Explorer
    Oh great. I just contacted Live Help and they said they would give me 20% off a new TomTom as my unit is "Faulty".
    This is NOT a solution to this problem. The TomTom works apart from it not being able to connect to my Mac.
    This is not an eco friendly solution at all.
    I am very annoyed.