Cannot Connect to Server Error App Version 3.3.53

Crusader3020
Crusader3020 Registered Users Posts: 43
Renowned Wayfarer
I have 2 x Samsung S9+ mobile phones which both have TT Go Navigation installed - Android 10. Both working fine.
Updated one phone (1) to 3.3.53 which required quite large map updates. However they loaded OK. All good.
So I updated the other phone (2) to 3.3.53 which required the same map updates. Looked like it had done its thing ok.
When I checked it had deleted most of my maps. Went to ADD maps and it took a while doing its 'loading' thing then came up with a 'Cannot Connect to Server' Error.
Ok, maybe it's busy. That was 3 days ago and still no connection after many tries.
Now here's the thing. After the first error I tried it on phone (1) and got the same error. So getting the same issue on both phones.
I've tried it on a number of healthy wifi connections and still the same problem. Also on mobile data, same issue.

k9hrdw70d263.jpg


Any ideas please?
Larry

Best Answer

  • Jürgen
    Jürgen Community Managers, Administrators Posts: 7,202
    Community Manager
    edited January 24 Answer ✓
    Earlier today we had an issue. This has been fixed and for me the download works again. Can you restart the app and try again?
«1

Answers

  • Jürgen
    Jürgen Community Managers, Administrators Posts: 7,202
    Community Manager
    Is there a VPN involved perhaps?
  • Crusader3020
    Crusader3020 Registered Users Posts: 43
    Renowned Wayfarer
    Jürgen wrote: »
    Is there a VPN involved perhaps?

    Thanks Jurgen.
    No VPN involved. I've tried it on 5 different networks with the same results.
    I was hoping (not really but you get my drift) others were having the same issue.
  • Jürgen
    Jürgen Community Managers, Administrators Posts: 7,202
    Community Manager
    I was hoping (not really but you get my drift) others were having the same issue.
    One similar incident escalated last year. I added to that that there's no VPN involved.
  • Crusader3020
    Crusader3020 Registered Users Posts: 43
    Renowned Wayfarer
    Thanks Jurgen.
    It's very odd that it's happening on both my phones, albeit they're exactly the same type of phone.
    I'd have thought others would be having the same issue.
  • AndyLewer
    AndyLewer Registered Users Posts: 9
    Apprentice Traveler
    I have a Samsung Galaxy A21 and it’s doing the exact same thing! akwbvboqbmaz.jpeg

    Have tried deleting and reinstalling the app, and from either 4G / 5G cellular and 2 different WiFi networks, same issue.
  • AndyLewer
    AndyLewer Registered Users Posts: 9
    Apprentice Traveler
    Sorry, wrong picture! jifs9694ra4u.jpeg
  • AndyLewer
    AndyLewer Registered Users Posts: 9
    Apprentice Traveler
    Hi, I recently tried to download the maps for TomTom GO but i keep getting “cannot connect to server” when trying to download the maps for my area. So far I have tried:

    * Deleting and reinstalling the app from the play store.
    * Trying WiFi and 4G / 5G cellular networks.
    * Checking that I have enough free slave on my phone to store the maps.
    * I also have an iPhone, strangely enough it works and I can download the maps without a problem!

    I am NOT using a VPN etc. g3e5imet9w47.jpeg
  • Crusader3020
    Crusader3020 Registered Users Posts: 43
    Renowned Wayfarer
    Thanks Andy.
    Is it just .53 that this is happening with. Was it working ok previously?
  • AndyLewer
    AndyLewer Registered Users Posts: 9
    Apprentice Traveler
    Thanks Andy.
    Is it just .53 that this is happening with. Was it working ok previously?

    I’ve tried several versions, even back to 1.9.x and same problem. Funnily enough my iPhone can download the maps without issue.
  • Vipapi
    Vipapi Registered Users Posts: 4
    Master Traveler
    Hello, I have the same problem, I have tried several smartphones and it always gives the same problem.
    I don't know where to get support, I paid for a 12-month subscription and I can't use the app.
  • Crusader3020
    Crusader3020 Registered Users Posts: 43
    Renowned Wayfarer
    Hi guys.
    So had this just started happening since updating to the latest version? Or has it been happening for a while?
    also, if you've tried reinstalling have you first deleted the TT configuration file: Android/data/com.tomtom.gplay.navapp ?
  • AndyLewer
    AndyLewer Registered Users Posts: 9
    Apprentice Traveler
    Hi guys.
    So had this just started happening since updating to the latest version? Or has it been happening for a while?
    also, if you've tried reinstalling have you first deleted the TT configuration file: Android/data/com.tomtom.gplay.navapp ?

    It seems TT’s servers are down for the Android maps, have been for almost a week now.

    Yes just tried that too, same issue.
  • Crusader3020
    Crusader3020 Registered Users Posts: 43
    Renowned Wayfarer
    Ha! If that's the case, real nice of them to let ppl know?
  • AndyLewer
    AndyLewer Registered Users Posts: 9
    Apprentice Traveler
    edited January 24
    Yep exactly!

    There’s 3 people now (that have bothered to come on here) with the same issue on different devices and different WiFi networks etc.

    @Jürgen anything you can add about this? Thanks in advance 😊
  • Willy875
    Willy875 Registered Users Posts: 5,349
    Revered Voyager
    edited January 24
    Salut
    OPPO smartphone running Android 11 application versions 3.3.53 yesterday I was able to update the France Monaco map + 2.4 GB Ferry map without any problem if that helps.
  • Jürgen
    Jürgen Community Managers, Administrators Posts: 7,202
    Community Manager
    Could you please let us know if you were downloading map regions from scratch, or tried to update existing maps?
  • Willy875
    Willy875 Registered Users Posts: 5,349
    Revered Voyager
    Jürgen wrote: »
    Could you please let us know if you were downloading map regions from scratch, or tried to update existing maps?

    If the question is for me it is an update of the map already installed.
  • Jürgen
    Jürgen Community Managers, Administrators Posts: 7,202
    Community Manager
    We need to know from those who are shown the error. Our statistics show that there's an increase in download failures. It's not affecting many users but we need to fix this.
  • Vipapi
    Vipapi Registered Users Posts: 4
    Master Traveler
    The app developer has responded to my complaint.
    We are aware of this issue and are actively working on it. Thank you very much for letting us know about this, it seems like a temporary problem.
  • Vipapi
    Vipapi Registered Users Posts: 4
    Master Traveler
    I have tried TomTom GO Navigation on several devices, Samsung A5, Samsung A40, Redmi 9Pro, OnePlus 8 and Samsung Gaalaxy Tab A7 Lite Tablet, all of them give the same error "Unable to establish connection with the server".
    In my opinion it is a general problem and not one of some smartphones or others.
  • Jürgen
    Jürgen Community Managers, Administrators Posts: 7,202
    Community Manager
    We still need to know whether this is happening with updating downloaded maps or downloading new maps.
  • Crusader3020
    Crusader3020 Registered Users Posts: 43
    Renowned Wayfarer
    For me it was updating existing maps on both of my Samsung S9+ phones.
  • AndyLewer
    AndyLewer Registered Users Posts: 9
    Apprentice Traveler
    edited January 24
    Jürgen wrote: »
    We still need to know whether this is happening with updating downloaded maps or downloading new maps.

    It’s happening with both actually. I have an older version on an older Samsung phone and I just turned it on tonight to see what would happen (the maps on the older phone are 12+ months old) and it did say there were updates available, but when I tried to download them I got an error “something went wrong, please try again later”.

    I hope that helps.
  • Jürgen
    Jürgen Community Managers, Administrators Posts: 7,202
    Community Manager
    Thanks @AndyLewer
    What Australia map are you trying to update?
  • AndyLewer
    AndyLewer Registered Users Posts: 9
    Apprentice Traveler
    Jürgen wrote: »
    Thanks @AndyLewer
    What Australia map are you trying to update?

    No problem 😊

    Dosent matter what state, or even country. I can try North America, India etc etc. Same error
This discussion has been closed.